WinFuture-Forum.de: SCSI-Festplatte unter MS-DOS - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Windows
Seite 1 von 1

SCSI-Festplatte unter MS-DOS


#1 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 02. Dezember 2016 - 10:21

Hallo,

ich habe eine SCSI-Festplatte (Seagate ST19171W), der Controller ist ein Symbios Logic 53C875J.

Unter Windows 7 funktioniert es einwandfrei.
Ich formatierte die Festplatte mit FAT 32, jedoch wird sie, wenn ich den Rechner mit MS-DOS starte, nicht erkannt (auch FDISK gibt die Platte nicht an). Unter MS-DOS 7.10 (mit Aspi-Treibern) wird die SCSI-Platte ebenfalls nicht erkannt.

Brauche ich für MS-DOS einen speziellen SCSI-Treiber? Leider konnte ich keinen SCSI-Treiber für MS-DOS finden.

Vielen Dank im Voraus.

Gruß
Denis
Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

Anzeige



#2 Mitglied ist offline   NCC-1701 B 

  • Gruppe: aktive Mitglieder
  • Beiträge: 448
  • Beigetreten: 30. Juli 15
  • Reputation: 48
  • Geschlecht:Männlich

geschrieben 02. Dezember 2016 - 10:35

Also mein alter Adaptec SCSI 2940 Controller brauchte unter Dos 6.22 Treiber damit ich unter Win 3.1 mit Single Speed eine CD Brennen konnte.

Und wehe da lief ein andere Prozess an denn schwupps waren 15 DM für einen Rohling futsch.

Dieser Beitrag wurde von NCC-1701 B bearbeitet: 02. Dezember 2016 - 10:36

Eingefügtes Bild
0

#3 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.562
  • Beigetreten: 19. August 04
  • Reputation: 1.393
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 02. Dezember 2016 - 11:07

Brauchte für meinen SCSI Adapter seinerzeit auch einen DOS Treiber. War damals aber kein Problem. Aber heute, gute Frage. Finde da leider auch keinen Treiber (nicht einmal bei Station Drivers), nur auf diversen anderen Seiten mehrere Hinweise darauf, aber bei den Downloads kommt immer nur eine *.exe, welche wohl einen Downloader oder so installieren will. Das wollte ich jetzt nicht unbedingt testen.

Finde da im Moment auch keinen Treiber.

---

Eventuell hier: http://www.ekf.de/c/cscs/sdms/cs5/dos/

DOS/Windows drivers for 53C8xx and 53c10xx family I/O
processors and host adapters. These drivers support DOS
5.0 and later versions.

Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
0

#4 Mitglied ist offline   Airboss 

  • Gruppe: aktive Mitglieder
  • Beiträge: 951
  • Beigetreten: 27. Januar 07
  • Reputation: 26
  • Geschlecht:Männlich
  • Wohnort:Area 51

geschrieben 02. Dezember 2016 - 18:10

DOS-Treiber
O <<<--------------- NSA! - Anschluß für Sonden --------------->>> O

Eingefügtes Bild
0

#5 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.562
  • Beigetreten: 19. August 04
  • Reputation: 1.393
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 02. Dezember 2016 - 18:21

Sind praktisch die selben Treiber, welche ich auch verlinkt habe (Version sehe ich da gerade nicht), nur das man sich bei Deinem Link dort durch so eine suspekte Seite klicken muss (JavaScript muss laufen und Adblocker aus), die einem Driver Turbo unterjubeln will. Der FTP Dowload ist da soweit sauber.
Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
0

#6 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 03. Dezember 2016 - 14:51

Hallo,

vielen Dank für die Links zu den Treibern.

Ich probierte die Treiber aus, jedoch wird die Festplatte nicht erkannt, es erscheint stets die Meldung "No device" oder "No drive found".

Gruß
Denis
Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

#7 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 03. Dezember 2016 - 17:37

Naja, der Treiber ist ja nicht für den Datenträger, sondern für den Controller.

Spuckt der keine Meldungen beim Systemstart aus, so in Richtung "Controller found at IRQ=X, DMA=Y" oder sowas?

Eventuell mußt Du auch schauen in die hoffentlich dabeiliegende Doku wie das aussieht mit der Konfiguration, hardware- wie softwareseitig, und die Einbindung von .sys-Dateien in config.sys reicht auch nicht immer. Da ist EMS vs XMS zu berücksichtigen, Umgebungsvariablen die evtl gesetzt sein müssen, Gerätetreiber in SYS oder EXE-Format oder sogar beiden Formen und mit ganz viel Glück sagt das mit dem EXE oder COM auch nix in Richtung WIE das eingebettet werden muß. Manchmal klappt es nur mit device= und manchmal nur mit devicehigh=. Einmal mußt ich ne EXE-Datei zweimal verwenden, einmal in config.sys als TSR und dann nochmal in autoexec.bat als Steuermodul. Sehr seltsames Konstrukt gewesen. Bissel wie smartdrv.

Und manchmal braucht man noch Basistreiber fürs SCSI-Subsystem selber, zusätzlich zu den Controllertreibern.

Wie das genau geht und was man braucht sollte aber eigentlich in der README oder in der Installationsanleitung für den Controller zu finden sein.

Dieser Beitrag wurde von RalphS bearbeitet: 03. Dezember 2016 - 17:39

"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#8 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 04. Dezember 2016 - 08:43

Hallo,

ich werde im Internet suchen, vielleicht werde ich die Dokumentation des Controllers finden. Die Dokumentation der Festplatte habe ich bereits.

Gruß
Denis
Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

#9 Mitglied ist offline   Airboss 

  • Gruppe: aktive Mitglieder
  • Beiträge: 951
  • Beigetreten: 27. Januar 07
  • Reputation: 26
  • Geschlecht:Männlich
  • Wohnort:Area 51

geschrieben 04. Dezember 2016 - 08:53

vielleicht das
O <<<--------------- NSA! - Anschluß für Sonden --------------->>> O

Eingefügtes Bild
0

#10 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 04. Dezember 2016 - 09:34

Nur insoweit, daß es da augenscheinlich verschiedene Treiber gibt für angeschlossene HDDs und CDROMs; wer weiß wie die das damals eingerichtet hatten, sieht so aus als ob die das durchreichen mit ATA und ATA/PI und dann je einen Treiber haben für das eine und das andere.

-- Aber die Treiber selber sind für NT. Damit kann man unter DOS nicht viel anfangen. Da bräuchte man dann schon Windows NT. ... Was auch nicht gänzlich unerwartet ist, weil solche Adapterkarten wohl eher weniger in Consumer-Umgebungen verwendet wurden, sondern eher auf Servern oder Workstations, und da lief auch damals schon kein DOS.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#11 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.562
  • Beigetreten: 19. August 04
  • Reputation: 1.393
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 04. Dezember 2016 - 12:55

Ja, Treiber für Windows NT nutzen da einem für DOS auch nicht viel.

Hier ist eine Webseite mit der Anleitung für die drei Treiber:

http://ridl.cfd.rit....ml/INSTMAIN.HTM

Die Kapitel ASPI8XX for DOS, SYMDISK for DOS und SYMCD for DOS sollten da passen.

Die Treiber, welche ich da oben verlinkt hatte, stammen von der SDMS™ (Software Device Drivers and Utilities CD-ROM). Auf dem FTP findet man da eigentlich alles von dieser CD, so dass es eigentlich funktionieren sollte.

Und ja, kann mich noch dran entsinnen, dass es etwas fummelig war, dass unter DOS zum Laufen zu bekommen, da man herausfinden muss, mit welchen Parametern man die drei Treiber in die Config.sys einbinden muss und in welcher Reihenfolge.
Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
0

#12 Mitglied ist offline   Nemo_G 

  • Gruppe: aktive Mitglieder
  • Beiträge: 91
  • Beigetreten: 19. Juni 09
  • Reputation: 20
  • Geschlecht:Männlich

geschrieben 04. Dezember 2016 - 13:11

Hi,
Aus meinem Fundus gebe ich meine
  • CONFIG.SYS (mit Abfrage des jeweils verwendeten CD-Laufwerks)
  • AUTOEXEC.BAT

für MS-DOS 6.22 zum besten. Die dazugehörigen Treiber wären auch noch vorhanden.
Die beziehen sich hauptsächlich auf Adaptec, nicht jedoch auf SymbiosLogic.
Nachdem ich einmal kräftig auf die Nase gefallen war, nachdem ich eine an einem Adaptec-Controller betriebene Platte an einen SymbiosLogic (oder umgekehrt) gehängt hatte und nach einiger Zeit den "schönsten" Datensalat hatte, habe ich mich später auf Adaptec konzentriert. Lediglich mit Tekram gab es keinen Krempel.

Ich frage mich allerdings, ob FAT-32 damals schon unterstützt wurde.
Wichtig waren außerdem
  • die richtige ID an Controller und auch HDD
  • Terminierung am Bus


Gruß, Nemo

Angehängte Datei(en)


Dieser Beitrag wurde von Nemo_G bearbeitet: 04. Dezember 2016 - 16:16

0

#13 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 06. Dezember 2016 - 10:56

Hallo,

vielen Dank für die Hilfe und die Links.

Ich werde die Treiber ausprobieren.

Nochmals vielen Dank dafür.

Gruß
Denis
Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

#14 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 28. Dezember 2016 - 16:52

Hallo,

ich probierte die Treiber aus, jedoch lässt der Laufwerkstreiber Symdisk.sys sich nicht laden. Er erkennt die Festplatte nicht und gibt die Meldung "Symdisk not loaded. No devices found." aus.
Ich trug die Treiber in der korrekten Reihenfolge in der Config.sys ein - erst den Controllertreiber Aspi8xx.sys und dann den Laufwerkstreiber Symdisk.sys - jedoch erkennt Symdisk die Festplatte nicht.

Gruß
Denis
Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

#15 Mitglied ist offline   Denis K. 1985 

  • Gruppe: aktive Mitglieder
  • Beiträge: 46
  • Beigetreten: 13. September 15
  • Reputation: 0
  • Geschlecht:Männlich
  • Wohnort:Schleswig-Holstein

geschrieben 15. Januar 2017 - 11:06

Bitte löschen

Dieser Beitrag wurde von Denis K. 1985 bearbeitet: 28. Januar 2017 - 09:22

Meine Petition:

Petition für die Fortführung des Supports für Windows 7.
https://www.change.o...s-für-windows-7
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0