WinFuture-Forum.de: Bootloader geschrottet :( - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 10: Alle News, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 10 - Special informieren!
Seite 1 von 1

Bootloader geschrottet :(


#1 Mitglied ist offline   Winlux 

  • Gruppe: aktive Mitglieder
  • Beiträge: 91
  • Beigetreten: 12. März 16
  • Reputation: 6

geschrieben 12. März 2016 - 12:38

Grüße in die Runde.

Ich habe aktuell folgende Situation zu bewältigen und wäre für hilfreiche Ratschläge dankbar:

Mein Laptop hatte ursprünglich Windows 7 vorinstalliert, da ich zum reinen surfen und Musik hören nicht unbedingt ein riesen OS laden will, hab ich nebenbei noch Linux Mint installiert. Nach den Upgrade auf Windows 10 mußte ich noch mittels EasyBCD den Bootloadereintrag wieder korrigieren und das lief auch ne Weile prima. Kurz danach habe ich es sogar dann nochmal als frische Installation drauf gehauen, soll ja angeblich besser sein (wobei ich mich trotzdem schon des öfteren gefragt habe, warum mir manchmal die schwarz-weiße Betriebssystemauswahl angezeigt wurde und an anderen Tagen mich Win 10 gefragt hat, welches OS ich starten will).
Als Windows dann einige Macken zeigte (Startmenü klappte nicht mehr auf, gelegentliche "Hänger"), empfahl man mir, das Betriebssystem wieder zurückzusetzen. Ging auch erstaunlich komfortabel (da soll mal einer auf Microsoft schimpfen ^^ ).
Da ich nun Linux beim booten nicht mehr auswählen konnte, wollte ich den schon mal eingeschlagenen Weg über EasyBCD gehen und Linux vom Programm automatisch erkennen und in den Bootmanager eintragen lassen. Irgendwas scheine ich dabei allerdings voll versemmelt zu haben. Jetzt startet nämlich nichts mehr :( Kurz nach der BIOS-Anzeige kommt gleich ne Fehlermeldung, das keine gültigen Einträge im Bootloader existieren und ich solle das über den Original-Datenträger reparieren.

Problem ist nur:
- die Disk mit Windows 7 habe ich nicht mehr
- die von Windows 10 auch nicht, weil ich nach dem Upgrade eine ISO geladen und dann auf nem USB-Stick installiert habe um die Neuinstallation zu beschleunigen
- den Stick habe ich mittlerweile anderweitig mißbraucht und stehe jetzt quasi ohne ein Original Windows da (mal abgesehen von dem auf der Festplatte installierten, das nicht startet

Die Partitionen von Windows und Linux sind alle noch da. Die bisherigen Lösungen im Internet haben mich noch nicht weitergebracht. Wäre es unter Umständen möglich, die Linuxpartitionen zu löschen (da habe ich eh nichts wichtiges gespeichert), es neu zu installieren und dann darüber den Bootloader zu reparieren, damit ich beim Start wieder beide OS angezeigt bekomme? Wenn ja, wie mache ich das? Das Linux installieren bekomme ich ja noch allein hin, aber ich weiß ehrlich gesagt nicht, wie ich dann Windows wieder zum laufen bekomme.
Geschrieben habe ich den Text hier mit Hilfe einer Live-CD wo unter anderem Linux Mint und PartedMagic drauf ist. Hab ich mir extra heute noch besorgt.

SCHÖN, wenn einem sowas zum Wochenende passiert, wo man ja eh NICHTS anderes vor hat -.-


Danke schon mal für die Hilfe. Voll nett und so.
0

Anzeige



#2 Mitglied ist offline   Q 1 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.088
  • Beigetreten: 11. Januar 14
  • Reputation: 135
  • Geschlecht:Männlich

geschrieben 12. März 2016 - 14:14

Sobald Linux wieder läuft, brennst Du Dir damit eine Windows-7- oder Windows-10-DVD und reparierst damit den Bootmanager. Vorher sicherst Du Dir die linux.bin

http://www.linux-com...r-von-Windows-7

und bindest später Linux in den Windows-Bootmanager ein. :)
0

#3 Mitglied ist offline   Sturmovik 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.776
  • Beigetreten: 10. Januar 08
  • Reputation: 445
  • Geschlecht:unbekannt
  • Wohnort:In Reichweite der Kaffeemaschine
  • Interessen:IT, Luftfahrt, historische Technik

geschrieben 12. März 2016 - 14:39

Warum so aufwändig? Grub in den MBR installieren, mit dem OS-Prober die Windowse erkennen lassen und fertig.
«Geschichte wiederholt sich nicht, aber sie reimt sich» (Mark Twain)

Unix won't hold your hand. You wanna shoot your foot, Unix reliably delivers the shot.

True Cloudstorage
0

#4 Mitglied ist offline   Winlux 

  • Gruppe: aktive Mitglieder
  • Beiträge: 91
  • Beigetreten: 12. März 16
  • Reputation: 6

geschrieben 13. März 2016 - 09:15

So, ich hab das Problem mittlerweile gelöst. Auch wenn es mich Nerven und Zeit gekostet hat. Ich habe Mint von der Live-DVD installiert (war eh eine neuere Version als die vorhandene) und mir dann die ISO-Datei von Windows 10 runtergeladen. Nach langem Suchen habe ich auch noch einen Rohling zum Brennen gefunden. Dann hab ich einfach die Reparatur-Funktion genutzt. Jetzt kann ich wieder beide Systeme starten. Ich habe allerdings immer noch nicht begriffen, warum ich manchmal nur die schwarz-weiße Bootauswahl angezeigt bekomme und gelegentlich Windows 10 vor dem Login auch nochmal fragt, welches Betriebssystem ich starten möchte. Jemand diesbezüglich vielleicht ne Idee? Stört mich nicht weiter, aber kurios finde ich es schon.
0

#5 Mitglied ist offline   Samstag 

  • Gruppe: aktive Mitglieder
  • Beiträge: 4.958
  • Beigetreten: 14. Juli 07
  • Reputation: 297
  • Geschlecht:unbekannt

geschrieben 13. März 2016 - 09:30

Könnte am hybriden Standby von Windows 10 liegen, der bei Dualboot-Umgebungen aber sowieso dringend deaktiviert werden sollte.

heise.de sagte:

Aufgrund der neuen Schnellstart-Funktion in Windows 8 ist die Integrität des Dateisystems gefährdet, wenn man mit anderen Betriebssystemen auf Windows-Partitionen schreibt. Insbesondere bei einer Dual-Boot-Konfiguration von Linux und Windows 8 droht Datenverlust.

Da ist jetzt zwar nur von 8 die Rede, bei Windows 10 ist es aber nicht anders.
Quelle.

Dieser Beitrag wurde von Samstag bearbeitet: 13. März 2016 - 09:31

0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0