WinFuture-Forum.de: Windows 7 Installation Zerstört Versteckte Primärpartition - WinFuture-Forum.de

Zum Inhalt wechseln

Alle Informationen zum Thema Windows 7 in unserem Special. Windows 7 Download, FAQ und neue Funktionen im Überblick.
  • 2 Seiten +
  • 1
  • 2

Windows 7 Installation Zerstört Versteckte Primärpartition


#1 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 27. Juni 2010 - 10:51

Hi Leute,
bei meinem ersten Versuch, Windows 7 zu installieren, bin ich gewaltig auf die Nase gefallen.

Ich hatte ein System mit wahlweise XP (32-Bit) und XP (64-Bit). Beide Installationen in jeweils einer primären Partition. Die Auswahl erfolgte über den Bootmanager Boot-US, der immer die jeweils nicht laufende OS-Partition versteckte.

Ich wollte nun XP64 durch W7 (64-Bit) ersetzen. Damit XP32 ja nichts passiert, startete ich die Installation mit dem Zustand: XP32=versteckt, XP64=sichtbar.

Während der Installation gab ich dann die sichtbare XP64-Partition als Ziel an.
Und was ist schlussendlich passiert:
- W7 wurde in die gewünschte Partition installiert
- Es gibt einen Ordner Windows.old mit den Daten der alten Installation (für XP64 erwartet)
Aber im Ordner Windows.old finde ich auch die Daten der ehemaligen XP32 reingemischt.
- Die primäre Partition von XP32 wurde komplett gelöscht!

Wie ist so ein schiefes Verhalten zu erklären?
Es kann doch nicht angehen, dass die W7-Installation versteckte Partitionen vernichtet!

Zum Glück hatte ich vorher ein Image von XP32 erstellt. Aber wie soll ich jetzt vorgehen?
Zuerst beide Primärpartitionen komplett löschen, W7 in eine davon installieren und danach das vorhandene XP32-Image in die andere zurückspielen?

epwf
0

Anzeige



#2 Mitglied ist offline   Spiderman 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.672
  • Beigetreten: 23. November 06
  • Reputation: 26

geschrieben 27. Juni 2010 - 13:02

Beitrag anzeigenZitat (epwf: 27.06.2010, 11:51)

Wie ist so ein schiefes Verhalten zu erklären?
Es kann doch nicht angehen, dass die W7-Installation versteckte Partitionen vernichtet!

Zum Glück hatte ich vorher ein Image von XP32 erstellt. Aber wie soll ich jetzt vorgehen?
Zuerst beide Primärpartitionen komplett löschen, W7 in eine davon installieren und danach das vorhandene XP32-Image in die andere zurückspielen?

Bei Windows muß man mit allem rechnen, Windows wir für DAUs entwickelt, Experten müssen sehen wie sie das System wie gewünscht hin bekommen.

Also zuerst überlegen, was brauche ich, was ist sinnvoll.

1) eine extra Boot Partition ist bei mehr als einem OS sinnvoll

2) für jedes OS eine eigene primäre Patition

3) eine Partition für Daten

Da ist man schon bei 4 Partitionen, die kann man alle als primäre Partition anlegen.

Alle Partitionen löschen ist richtig, bei der W7 Installation hat man ja auch einen Partition Manager.

Ich würde also 4 primäre Partitionen anlegen:
- die erste "Boot" nennen, Größe installierter RAM + 2 GB
- dann die "Windows 7" Partition, die Größe hängt von vielen Dingen ab, ich würde sagen min. 16 GB Basis + RAM wegen Ruhezustand + 4 GB je Spiel + 8 GB für Anwendungen
- dann die "XP" Partition, Größe wie bei W7 als Basis reichen dort 4 GB
- den Rest bekommt die "Daten" Partition

Die Auslagerung wird für beide OS in Boot gemacht, das ist sicherer, besser beim Defragmentieren und spart Zeit/Platz.

Nach der W7 Installation kann du das XP Image aufspielen.


Gruß
Spiderman
0

#3 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 27. Juni 2010 - 13:47

Danke für die Antwort.

Die prinzipielle Aufteilung hatte ich mir schon im früheren System überlegt.
Ich hatte wie bereits gesagt jeweils eine Primärpartition für die beiden OS, immer nur eine davon aktiv.
Momentan habe ich Platz für 16GB (XP) und 32GB (W7) Danach gibt es eine Partition D:, in die ich TEMP und Auslagerungsdatei geschoben hatte.
Anwendungsprogramme hatte ich auf E: installiert, ausgenommen natürlich die absoluten Standardprogramme wie Office, Acrobat etc.. Ich will C: möglichst klein halten, um schnell mit TrueImage ein Image erstellen zu können, bevor man eine gröbere Änderung vornimmt.
Dahinter kommen schlussendlich die Datenpartitionen.

Beitrag anzeigenZitat (Spiderman: 27.06.2010, 14:02)

Bei Windows muß man mit allem rechnen, ..

Dem entnehme ich, dass du auch keine wirklich schlüssige Erklärung für das Löschen der versteckten Partition hast.
Wenn man im Netz sucht, gibt es durchaus viele Berichte, dass man W7 ganz einfach neben XP in eine eigene Primärpartition installieren kann und der sich automatisch installierende W7-Bootmanager dann die Auswahl steuert.
Ich vermute fast, die W7-Installation hat es geworfen, als die Mixtur aus XP32 und XP64 erkannt wurde.

Zitat

Experten müssen sehen wie sie das System wie gewünscht hin bekommen.

Ist ja ok, wenn man sich etwas damit spielen muss, einen Bootmanager lauffähig zu bekommen etc. etc.
Aber ein komplettes Rauskicken einer versteckten Partition hat für mich weniger damit zu tun, dass man den Focus auf den DAU-Betrieb legt. Nein, für mich ist das ein krasser Fehler in der Installationsroutine!

epwf
0

#4 Mitglied ist offline   Spiderman 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.672
  • Beigetreten: 23. November 06
  • Reputation: 26

geschrieben 27. Juni 2010 - 15:19

Beitrag anzeigenZitat (epwf: 27.06.2010, 14:47)

Dem entnehme ich, dass du auch keine wirklich schlüssige Erklärung für das Löschen der versteckten Partition hast.

Das verstecken von Partitionen ist eine Erfindung, das gibt es eigentlich nicht, daher kann W7 die Partition auch als defekt erkannt haben.

Boot-US legt noch einen drauf, und erfindet "Echtes verstecken" und verändert auch etwas am Boot Sektor.

Zitat

Some partition type codes are used to hide a partition's contents from various operating systems. However, if an OS or some partitioning tool has been programmed to also examine the boot sectors of any partition, then its file system may no longer remain hidden.

Quelle: http://en.wikipedia....ion_(computing)

oder http://de.wikipedia....rtitionstabelle

Da kann MS also nix dafür, das hat Boot-US verbockt, aber der Windows Installer ist schon für einige Überraschungen gut, die Dateien des OS werden oft sogar auf mehrere Festplatten verteilt.

Gruß
Spiderman
0

#5 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 27. Juni 2010 - 15:58

Beitrag anzeigenZitat (Spiderman: 27.06.2010, 16:19)

Das verstecken von Partitionen ist eine Erfindung, das gibt es eigentlich nicht, daher kann W7 die Partition auch als defekt erkannt haben.

War es bei Windows 9x früher nicht so, dass nur eine primäre Partition eingerichtet werden konnte? Da war das Verstecken doch die einzig mögliche Maßnahme und wohl kaum eine Erfindung, die es eigentlich nicht gibt.
Außerdem könnte man W7 sagen, wenn du etwas nicht verstehst, dann halt die Klappe und lass das Zeugs so liegen wie es ist!

Zitat

Da kann MS also nix dafür, das hat Boot-US verbockt, aber der Windows Installer ist schon für einige Überraschungen gut, die Dateien des OS werden oft sogar auf mehrere Festplatten verteilt.

Schlussendlich kann es aber nicht daran gelegen haben, dass W7 die versteckte Partition als defekt erkannt hat. Warum sonst hätte die Installationsroutine dann Daten daraus ziehen sollen, um sie im Windows.old Ordner mit den XP64-Daten zu mischen?

epwf
0

#6 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.053
  • Beigetreten: 08. Juli 04
  • Reputation: 389
  • Geschlecht:Männlich

geschrieben 27. Juni 2010 - 16:12

Hmm, also ich fahre seit jahren so, und die Vista/W7 installation hat bei mir noch nie die versteckte XP Partition zerstossen.

Ich hab BootUs sogar auf der Pagefile Partition (Fat32) hinter den beiden Betriebssystemen XP (8GB) und 7 (15GB)

Hast du im Setup die XP64 Partition vielleicht gelöscht statt nur zu formatieren? Das könnte mir das Verhalten erklären. Sicher, daß du unter bootUs auch die Haken richtig gesetzt hast?

Also ich mach die "da soll 7 drauf" Partition erstmal komplett leer.

Boote XP
Installiere den Bootmanager mit Boot US
Partitionen individuell verstecken
Lasse für 7 alle Partitionen sichtbar, (D)aten, (E)igene, (P)agefile mit BootUS, ausser eben der xp Partition (Damit man unter 7 BootUs wieder bequem reaktivieren kann)
Starte neu
Wähle die Win7 Partition aus -> Enter nicht vergessen (Jetzt ist XP versteckt)
Reset
W7 Setup von der CD
Partition angeben
Muss funktionieren.

Ich habe noch keine angeblichen Windows Ungereimtheiten und Verschwörungen wie andere meinen, erlebt

Dieser Beitrag wurde von Candlebox bearbeitet: 27. Juni 2010 - 16:22

»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

#7 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 27. Juni 2010 - 17:08

Beitrag anzeigenZitat (Candlebox: 27.06.2010, 17:12)

Hast du im Setup die XP64 Partition vielleicht gelöscht statt nur zu formatieren? Das könnte mir das Verhalten erklären. Sicher, daß du unter bootUs auch die Haken richtig gesetzt hast?

Also ich mach die "da soll 7 drauf" Partition erstmal komplett leer.

Wollte ich im Prinzip auch so machen, aber bei der W7-Installation habe ich vergeblich auf die Auswahl formatieren gewartet, die Installation ging nach Auswahl der XP64-Partition praktisch von alleine los.
Für weitere Versuche weiß ich jetzt natürlich, dass ich die Partition vorher mit dem DiskDirector platt mache.
Es war halt meine erste Erfahrung mit W7 und ich ging einfach davon aus, dass es im Zuge des Installationsdialogs die Abfrage nach der Formattierung gibt.

Boot-Us war sicher richtig konfiguriert. Ich hatte zuvor sogar XP64 ganz hochlaufen lassen, d.h. XP32 war definitiv versteckt und nicht andersrum.

Übrigens, beim Versuch, Boot-Us in W7 wieder in Betrieb zu nehmen, bekam ich die Fehlermeldung, dass Adminrechte fehlen. Letztere waren aber definitiv vorhanden, da außer dem Admin-Account noch nichts anderes eingerichtet war. Scheinbar geht Boot-Us nicht mit W7-64. Macht aber nichts aus, man kann sich ja mit dem DiskDirector die XP32-Installation aktiv schalten und dann von dort aus Boot-Us wieder einschalten. Ist zumindest die Theorie, ich habe noch keinen weiteren Installationsversuch mit W7 probiert.

Aber so wie du deine problemlosen Installationen beschreibt, wird es wohl daran gelegen haben, dass XP64 nicht leer war, warum auch immer dies zu diesem Effekt führte.

epwf
0

#8 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.053
  • Beigetreten: 08. Juli 04
  • Reputation: 389
  • Geschlecht:Männlich

geschrieben 27. Juni 2010 - 17:51

Versuch es einfach nochmal.

Besser als mit nem richtigen Bootmanager wie z.B BootUs kann man Dualboot nicht betreiben, wäre zu schade, wenn Du es nicht zum laufen bekämst. Da du das Grundprinzip wie es gehört, schon richtig angehst.

Ob es jetzt an 7 64Bit lag kann ich nicht beantworten. Denke ich aber nicht.
Aber Du mußt unter 7 die BootUs.exe -> Rechtsklick mit Administratorrechten ausführen, (oder das integrierte Administratorkonto aktivieren und es darin ausführen) dan sollte es auch unter 7 64Bit klappen.

Adminkonto bedeutet nicht mehr Adminrechte unter 7 wie unter XP.

Viel Glück.

Dieser Beitrag wurde von Candlebox bearbeitet: 27. Juni 2010 - 17:54

»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

#9 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 27. Juni 2010 - 18:03

@Candlebox:
Vielen Dank für die nochmalige Antwort!

Das mit dem Rechtsklick beim Start von Boot-Us ist natürlich der richtige Tipp!
Tja mit W7 muss ich mich wohl erstmal einige Zeit beschäftigen.

Eigentlich hatte ich mir vorgenommen, bei XP solange zu bleiben, bis es verfault. Aber aufgrund von Programmanforderungen komme ich leider nicht mehr drum rum.

epwf
0

#10 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.053
  • Beigetreten: 08. Juli 04
  • Reputation: 389
  • Geschlecht:Männlich

geschrieben 27. Juni 2010 - 18:32

Beitrag anzeigenZitat (epwf: 27.06.2010, 19:03)

Eigentlich hatte ich mir vorgenommen, bei XP solange zu bleiben, bis es verfault.

:blush: Ich zu Vista Zeiten am Anfang auch.
Naja, NT6.x ist aber wirklich ein nicht von der Hand zu weisender Fortschritt.

Wenn man mit einem eingeschränkten Konto unterwegs ist (was man eigentlich immer sein sollte, ab Vista ist man mit einem Adminkonto auch nicht mehr mit Administratorrechten gesegnet) ist das Administrieren in einem eingeschränkten Benutzerkonto weitaus angenehmer als unter XP, weil man nicht immer an "Ausführen als" denken muß, die UAC "denkt" da zumeist mit.
Unter Vista/7 wird dann eben ein Administratorpasswort abgefragt, welches weitaus sinnvoller ist als wenn man im Adminkonto die UAC nur bestätigen muß.

Spiel’ dein XP 32 Image zurück mach’ dieXPx64/7x64 platt/leer und versuche es erneut.
»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

#11 Mitglied ist offline   Murmel 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.857
  • Beigetreten: 11. Februar 05
  • Reputation: 0
  • Geschlecht:Männlich

geschrieben 28. Juni 2010 - 06:58

Beitrag anzeigenZitat (epwf: 27.06.2010, 11:51)

Damit XP32 ja nichts passiert, startete ich die Installation mit dem Zustand: XP32=versteckt

Das war definitiv ein Fehler. Windows 7 hätte die XP Partition in den eigenen Bootmanager eingebunden und da das wohl auch die aktive Partition ist dort seine Bootdateien abgelegt.

Über Dualboot Installationen findet man ja mittlerweile nun genug Infos im Internet.
0

#12 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 28. Juni 2010 - 16:05

Beitrag anzeigenZitat (Murmel: 28.06.2010, 07:58)

Das war definitiv ein Fehler. Windows 7 hätte die XP Partition in den eigenen Bootmanager eingebunden und da das wohl auch die aktive Partition ist dort seine Bootdateien abgelegt.

Verstehe ich aber nicht ganz. Warum hat dann W7 die Daten von der versteckten Partition nach Windows.old geschoben und danach die Ursprungspartition vernichtet? Und aktive Partition war zum Installationszeitpunkt die 2. primäre mit XP64 drauf.

Zitat

Über Dualboot Installationen findet man ja mittlerweile nun genug Infos im Internet.

Ja, ich hatte auch schon zuvor ein bisschen das große G im Netz angeworfen. Soviele Infos es auch gibt, es gibt auch nahezu ebenso viele verschiedene Lösungsvarianten und immer wieder unvorhersehbare Probleme.

Es ist ja auch beileibe nicht der erste Multiboot-Rechner, den ich aufziehen will. Es war nur noch nie so, dass mir eine nebendran liegende versteckte Partition zermüllt wurde. Dass ich mit meiner Vorgehensweise anschließend das Bootsystem selbst neu aufziehen muss, bin ich schon lange gewohnt. Dafür ist aber boot-us eine schönes Tool.

epwf
0

#13 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.053
  • Beigetreten: 08. Juli 04
  • Reputation: 389
  • Geschlecht:Männlich

geschrieben 28. Juni 2010 - 16:19

Beitrag anzeigenZitat (epwf: 28.06.2010, 17:05)

gibt auch nahezu ebenso viele verschiedene Lösungsvarianten und immer wieder unvorhersehbare Probleme.

Weil diese Variante einfach nur die denkbar schlechteste Möglichkeit ist, Dualboot wenigstens zu betreiben. von richtig keine Spur.
Grub2 nähert sich diesem Blödsinn auch immer mehr an, und erkennt sogar versteckte Betriebsysteme und bindet diese einfach ein. Das ist noch schlimmer

Beitrag anzeigenZitat (epwf: 28.06.2010, 17:05)

Dafür ist aber boot-us eine schönes Tool.


Kenne auch nichts besseres, Bootmagic war noch toll, kommt aber mit neueren Platten z.T. nicht mehr zurecht.
Das es mit BootUs geht, beweisen mir hier 4PCs und zahlreiche Neuinstallationen, ohne mir Gedanken um irgendwelche windows bootmanager machen zu müssen.

Naja kann schon sein, daß sie dich hier noch kleinkriegen und überzeugen, daß der Windows Bootmanager das Nonplusultra ist.
»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

#14 Mitglied ist offline   epwf 

  • Gruppe: aktive Mitglieder
  • Beiträge: 40
  • Beigetreten: 30. Januar 09
  • Reputation: 0

geschrieben 28. Juni 2010 - 16:52

Zitat

Naja kann schon sein, daß sie dich hier noch kleinkriegen und überzeugen, daß der Windows Bootmanager das Nonplusultra ist.

Dieser Zug ist gerade abgefahren :( Erfolg!!!
Ich habe jetzt praktisch das gleiche Vorgehen gewählt wie beim ersten Versuch, nur die Partition, wo W7 rein soll, wurde zuvor komplett gelöscht. Die alte XP32 wurde wiederum auf versteckt geschaltet.

Die Installation lief einwandfrei durch, es gibt auch keinen Windows.old Ordner mehr.
Boot-Us ließ sich von W7 aus starten (nochmals danke für den Hinweis mit der rechten Maustaste) und schon läuft alles wie früher auch.

Jetzt muss ich erst noch die Laufwerksbuchstaben umbiegen. Aus welchem Grund auch immer hat W7 meine 2. Datenplatte ganz am Anfang ab D: hingehängt.

Im Prinzip also genau der Installationsverlauf, wie ich es von früheren Multi-Boots kannte. Bloß durch die fehlende Formatierabfrage bei der W7-Installation bin ich wohl in die Probleme gelaufen, weil die alte XP64-Installation nicht platt war.

BTW: Macht es Sinn, auch bei einem Desktopsystem die hiberfile.sys zu behalten? Bei 8GB RAM glaube ich eher nicht.

Jedenfalls nochmals danke für eure Unterstützung!

epwf
0

#15 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.053
  • Beigetreten: 08. Juli 04
  • Reputation: 389
  • Geschlecht:Männlich

geschrieben 28. Juni 2010 - 18:13

Beitrag anzeigenZitat (epwf: 28.06.2010, 17:52)

Dieser Zug ist gerade abgefahren :( Erfolg!!!


Sauber! :D

Beitrag anzeigenZitat (epwf: 28.06.2010, 17:52)

BTW: Macht es Sinn, auch bei einem Desktopsystem die hiberfile.sys zu behalten? Bei 8GB RAM glaube ich eher nicht.

epwf

hiberfil.sys ist die Ruhezustandsdatei. Du meinst wahrscheinlich die Auslagerungsdatei.
Ruhezustand, wenn du ihn nicht brauchst, kannst du mit

"Startknopf" -> cmd oder ausf ins Suchfeld eingeben
Rechtsklick -> als Administrator ausführen
powercfg -h off
deaktivieren.

Bei der Auslagerungsdatei (pagefile.sys) scheiden sich die Geister, da gibt es bestimmt bessere Tipps von anderen hier als von mir.
Bei 8 GB Arbeitsspeicher würde ich weiterhin meine bestehende Pagefile Partition mit 4300MB nutzen und diese auf 4100MB setzen

Bei Dualboot nutze ich eine pagefile.sys auf einer eigenen Partition für beide Windows Betriebssysteme.
»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

Thema verteilen:


  • 2 Seiten +
  • 1
  • 2

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0