WinFuture-Forum.de: Suse Und W-lan - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Linux
Seite 1 von 1

Suse Und W-lan karte aktiviert sich nicht


#1 Mitglied ist offline   Only-P 

  • Gruppe: aktive Mitglieder
  • Beiträge: 112
  • Beigetreten: 19. September 06
  • Reputation: 0
  • Wohnort:Merseburg

geschrieben 10. November 2006 - 16:32

Hallo!

Ich habe nach vielen, vielen Versuchen gestern eine Linux-Distri gefunden, die meine (exotische?) GPU bzw. ACPI fuer mein Notebook unterstützt - und zwar Suse10.1. Trotz dass es mein erster Linux-Versuch ist kam ich bis jetzt recht gut zurecht.
Doch meine interne WLAN-Karte bereitet mir Sorgen, da ich sie unter Yast auf beim Systemstart (oder war es beim booten?) aktivieren gestellt habe und sie sich trotzdem nicht aktiviert. Woran kann das liegen, denn sie wird einwandfrei erkannt?! Oder wie kann ich sie zum Starten überreden?

Mein Sys.:
"Acer Extensa 4101WLMI"
Centrino 1,6GHz
1GB RAM
Radeon Mobility X700pro
Intel Pro/Wireless 2200BG <- <- <-
...rest ist ja egal

Wenn ich einmal hier bin:
Welche Formatierung sollte die Linux-Platte denn eurer Meinung nach haben haben (Heimanwender: Office,Internet,Multimedia)?

So, reicht erstmal :)
Danke schonmal im Vorraus!!! :)
MfG Olli

HÖFLICHKEIT IST KEIN VERBRECHEN
0

Anzeige



#2 Mitglied ist offline   Only-P 

  • Gruppe: aktive Mitglieder
  • Beiträge: 112
  • Beigetreten: 19. September 06
  • Reputation: 0
  • Wohnort:Merseburg

  geschrieben 14. November 2006 - 07:55

....mh, hat da keiner Ahnung oder ähnliche Probleme? Oder kann jemand (falls dem so ist) bitte einen Grund angeben wieso ich ignoriert werde, damit ich weiss was ich falsch mache?

So, noch mal genauere Infos zu mir:
Ich habe bis jetzt immer mal wieder versucht verschiedene Linux-Versionen auszuprobieren, aber meist frieren die schon beim booten ein. Soweit ich das beurteilen kann lag das bis jetzt entweder an der GPU oder am ACPI-Mangment (bei Suse 9.X natürlich an USB ;) ). Das einzige was mal lief war Slackware 9.1, aber zu dem Zeitpunkt (hatte nicht mal DSL) war es natürlich auch schnell wieder weg (zwecks zoggn ;) ). Naja, ich habe wieder mal den inneren Schweinehund überwunden und mir SUSE LINUX 10.1 (mit Gnome) als zweites OS (neben XP MCE) gekönnt. Und - TaTaa - bis auf das WLAN läuft alles! Nur darüber muss ich ins Netz da Ich 2 Etagen über dem Router wohne.

Wieso ich überhaupt zu LINUX wechseln will?
Erstmal entspricht die MS-Politik nicht ganz meinen Bedürfnissen und Interessen, auch wenn ich diese Art der Politik verstehe *wegduck*. Ich will mir SPÄTER, also wenn ichs denn mal kann, mein eigenes auf mich zugeschnittenes BS haben. Ich glaube ich habe auch Glück dass ausgerechnet Suse bei mir "Out Of The Box" läuft, so kann ich mich mit der sehr guten GUI einarbeiten und dann immer mehr (gaaahnz langsaaahm) zur Shell übergehen.

Mein WLAN-Problem:
Im Yast/NetworkManager (ja, ich weiss... :D ) wird der Name "bis aufs Gramm genau" angegeben, und ich kann auch alles einstellen (SSID, Verbindungsdaten zum/fürn Router). So habe ich auch eingestellt dass die Karte beim Systemstart aktiviert werden soll, aber sie aktiviert sich nicht (wuerde ich am Notebooklämpchen sehen). Hardwareseitig ist alles bestens.
Natürlich hab ich mich auch andersweitig versucht kundig zu machen. So habe ich erfahren dass es generell Probleme mit Centrino-WLAN gibt. Und das Ndiswrapper helfen könnte aber recht viel Leistung flöten geht. Irgendwie hoffe ich da noch auf bessere Hilfe, wegens Leistungsverlust.
Wie kann man die Karte manuell starten? Vielleicht hilft das.

Na gut, ich warte und hoffe auf Post (bzw Posts)...
MfG Olli

HÖFLICHKEIT IST KEIN VERBRECHEN
0

#3 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 14. November 2006 - 11:54

Zitat

....mh, hat da keiner Ahnung oder ähnliche Probleme? Oder kann jemand (falls dem so ist) bitte einen Grund angeben wieso ich ignoriert werde, damit ich weiss was ich falsch mache?


Zunächst einmal ist ein Forum kein Realtime-Medium und du hast (hier) keinen Anspruch auf Hilfe. Darüber hinaus kann es durchaus mal vorkommen, dass die Leute die Ahnung haben, mal grade keine Zeit oder Lust haben, dir zu helfen. Ich habe das Topic zwar gestern Abend noch entdeckt, aber, da dass hier freiwillig ist und ich müde war, bin ich erstmal schlafen gegangen.
[EDIT:Datum falsch gelesen]
Darüber hinaus, hättest du die Boardregeln gelesen, wäre dir bekannt, dass du gegen sie verstoßen hast, weil Pushing erst nach dem Ablauf von mindestens 24 Stunden gestattet ist.
[/EDIT]

So, nun aber zum Problem:

Zitat

So habe ich erfahren dass es generell Probleme mit Centrino-WLAN gibt. Und das Ndiswrapper helfen könnte[...]


Keine Ahnung, aus welchem Archiv du das gezogen hast, aber erstens sind die IPW-Treiber mittlerweile äusserst stabil und bieten annähernd alle Funktionen - selbst der für Kismet wichtige Monitor-Mode ist schon seit langem implementiert und meine IPW2200 läuft seit über einem Jahr gut und stabil.
Zum Thema ndiswrapper sage ich nur soviel, dass ich am liebsten jeden verhauen würde, der diesen nutzt, obwohl Treiber für *nix existieren, einfach deswegen, weil man damit den Druck von den Herstellern nimmt und sich eventuell noch andere Probleme einhandelt.

So, weiter im Text.

Dass SUSE die Karte erkennt, muss nicht heissen, dass kann jede Distribution bzw. jeder Kernel. Ob allerdings wirklich die Treiber dafür auch mitgeliefert werden ist fraglich, da die IPW-Treiber mindestens eine ClosedSource-Komponente enthalten und viele Distributionen ausschließlich freie Software/Treiber mitliefern, um sich vor eventuellen Regressansprüchen zu schützen.

Du solltest mal eine Shell öffnen, keine Ahnung, ob du dich damit schon auskennst, deswegen:

Wenn du in Gnome oder KDE bist, drücke ALT+F2, gebe in das erscheinende Fenster xterm ein und bestätige mit Return.
Nun sollte ein Konsolenfenster erscheinen, wo du folgendes eingibst:
lsmod

Darauf hin werden dir sämtliche Module gelistet, welche aktuell geladen sind. Durchsuche die Ausgabe und schaue, ob du den Eintrag "ipw2200" siehst.
Sollte kein solcher Eintrag vorhanden sein, mach das folgende:
su -
***root-Passwort***
modprobe ipw2200

Sollte keine Fehlermeldung ausgespuckt werden, wurde der Treiber erfolgreich geladen, was du wiederum durch
lsmod
überprüfen kannst.
Wenn der Treiber geladen ist, kannst du mit "iwconfig" und "ifconfig" die gewünschten Settings vornehmen, alternativ auch via einer GUI deiner Wahl.

Sollte der Treiber nicht zu laden sein, weil a) gemeckert wird, dass das Modul nicht existiert, dann begebe dich entweder auf die Herstellerhomepage und lade den Treiber herunter und installiere ihn von Hand oder versuche dein Glück und schaue, ob der Treiber via YaST verfügbar ist. Kommt hingegen b) eine Fehlermeldung, die darauf schließen läßt, dass das Modul zwar vorhanden ist, aber nicht geladen werden konnte, dann poste hier bitte 1) die Fehlermeldung im Wortlaut und 2) die Ausgabe von
dmesg | tail -n 20
.

Ich hoffe mal, dass dir das schon mal weiterhilft, ansonsten solltest du dich vielleicht eher an den Linux Club wenden, was ein auf SUSE spezialisiertes Forum ist.

cheers,
ph

EDIT:
Noch ein paar Kleinigkeiten :D

Zitat

(bei Suse 9.X natürlich an USB )

Ich benutze SUSE zwar nur hin und wieder Testweise, ja ich hasse es, aber man muss ja auf dem aktuellen Stand bleiben, aber USB inkl. 2.0 hat bei mir schon bei der 8.2 ohne Probleme funktioniert.

Zitat

so kann ich mich mit der sehr guten GUI einarbeiten und dann immer mehr (gaaahnz langsaaahm) zur Shell übergehen.


Freut mich, dass du anscheinend den Sinn einer Shell verstehst und diese nicht wie viele andere von vorneherein verschmähst.

Dieser Beitrag wurde von ph030 bearbeitet: 14. November 2006 - 13:00

0

#4 Mitglied ist offline   blue32 

  • Gruppe: aktive Mitglieder
  • Beiträge: 625
  • Beigetreten: 28. Juli 05
  • Reputation: 0

geschrieben 14. November 2006 - 12:04

@ph030: Sei mal nicht ganz so hart :D Vergleiche mal die Daten seiner letzten beiden Posts.
These guys are the best surfers in the world.
No surfboard, no wetsuit, no worries.

Phil, speaking about dolphins
0

#5 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 14. November 2006 - 12:17

Ups, sorry, Datum falsch gelesen ;)

Aber dafür musst du zugeben, dass ich mit dem Rest mal nett war? Oder ODER :D

Dieser Beitrag wurde von ph030 bearbeitet: 14. November 2006 - 12:18

0

#6 Mitglied ist offline   sn00b 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.242
  • Beigetreten: 07. November 05
  • Reputation: 0
  • Geschlecht:Männlich

geschrieben 14. November 2006 - 12:30

hi! :D
habe zwar keinen plan von linux, aber mir schwebt in erinnerung mal was gelesen zu haben das es sein kann das man im bios was einstellen muß! bei w-lan irgendwas so in die richtung last-state oder enable!
ich hoffe mal das es bei mir nicht so schwer wird wenn ich mit linux anfange! ;)
0

#7 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 14. November 2006 - 12:42

Zitat

habe zwar keinen plan von linux, aber mir schwebt in erinnerung mal was gelesen zu haben das es sein kann das man im bios was einstellen muß! bei w-lan irgendwas so in die richtung last-state oder enable!


Das kann zwar sein, trifft dann aber meistens auf diese Billignotebooks zu, die keinen Hardwareschalter sondern einen Softwareschalter haben, der, wie könnte es anderst sein, natürlich nur unter Windows so funktioniert wie er soll.
0

#8 Mitglied ist offline   blue32 

  • Gruppe: aktive Mitglieder
  • Beiträge: 625
  • Beigetreten: 28. Juli 05
  • Reputation: 0

geschrieben 14. November 2006 - 12:45

@Only-P: In der Suse Hardwaredatenbank ist unterstüzte Hardware aufgelistet. Welche Probleme hast du eigentlich mit der GPU? Meinst du die Grafikkarte? Welche ist denn verbaut?

Über "iwconfig" kannst du die drahtlose Netzwerkschnittstelle per Shell ansprechen.


@ph030: Joo, klang gut :D Es bringt ja auch nichts nur Brocken hinzuwerfen, wie das in NGs so der Fall ist, zumal wenn Leute vorgeben, sich ernsthaft und sinnvoll in Linux einarbeiten zu wollen.
These guys are the best surfers in the world.
No surfboard, no wetsuit, no worries.

Phil, speaking about dolphins
0

#9 Mitglied ist offline   Only-P 

  • Gruppe: aktive Mitglieder
  • Beiträge: 112
  • Beigetreten: 19. September 06
  • Reputation: 0
  • Wohnort:Merseburg

  geschrieben 14. November 2006 - 13:13

Wow, soviel Interesse hätte ich garnicht erwartet. Danke :D !

Unter lsmod finde ich die Karte:
ipw2200  92980(size)  0(use)
sowie firmware_class  9856  2  pcmcia,ipw2200


Doch mit dmesg kam die "Erleuchtung" ;) :
ipw2200: module not supported by Novell,setting U taint flag
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.10
ipw2200: Copyright(c) 2003-2005 Intel Corporation


...sowie etwas weiter unten:
ACPI: PCI Interrupt 0000:06:03.0[A] -> GSI 17 (level, low) -> IRQ 177
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.4-boot.fw load failed: Reason -2
ipw2200: unable to load firmware: -2
ipw2200: failed to register network device
ipw2200: probe of 0000:06:03.0 failed with error -5


Mit modprobe wurde nix rumgemeckert oder so, es standen dann nur 2mal die unteren Einträge der Diagnose.

Was bewirkt
tail -n 20
genau? Bei mir tat sich da nix, ausser dass die Verzeichnisstruktur wegging (bin halt Noob)?

So, ich werde versuchen mich direkt an den Router (LAN) zu stöpseln und Suse zu aktualisieren. Vielleicht finde ich auf der Suse-Seite auch einen deutschen Suse-Guide, damit ich ein bisschen Bildung betreiben kann.
Und auf jeden Fall suche ich mal wie in der Konsole "Copy&Paste" funktioniert, damit ich nicht sinnlos schreiben muss (erst auf Papier, dann unter WinXP hier ins Forum)... ;) ;) ;)
MfG Olli

HÖFLICHKEIT IST KEIN VERBRECHEN
0

#10 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 14. November 2006 - 13:18

tail -n X


tail gibt dir die letzten Zeilen aus, z.B. wie in diesem Fall von einer Log-Datei.
-n X setzt dabei die gewünschte Zeilenanzahl. Natürlich hättest du auch die ganze dmesg nehmen können, aber das wären mindestens 100 Zeilen gewesen, die uns bezüglich des Topics gar nicht interessieren ;)

Die Pipe (|) leitet übrigens die Ausgabe von einem Befehl an die Eingabe des nächsten Befehls weiter.

Bezüglich deines C&P-Wunsches, markiere einfach den gewünschten Text in der Shell mit der Maus - also Linksklick, halten, markieren, loslassen - wechsele in das gewünschte Fenster, wo der Text hinsoll und drücke dort die mittlere Maustaste - tada :D

Ansonsten hatte ich wohl recht mit der mangelnden Unterstützung, ich schau mal grad, ob ich was passendes finde.

EDIT:
Eine Oberflächliche Suche bringt schonmal dieses Howto - gut, nicht mehr ganz aktuell, aber das Prinzip sollte klar werden. Wenn das nicht reicht, bitte ich dich, dort im Forum weiter zu suchen, da gibt's genug Threads - auch aktuelle - aber da das ja dein Problem ist und du was lernen sollst, möchte ich hier nicht alles bis ins kleinste Detail vorkauen ;)

hth,
ph

EDIT2:
Hier gibt's noch ein etwas aktuelleres Howto, bezogen auf SUSE 10.0.

Dieser Beitrag wurde von ph030 bearbeitet: 14. November 2006 - 13:26

0

#11 Mitglied ist offline   Only-P 

  • Gruppe: aktive Mitglieder
  • Beiträge: 112
  • Beigetreten: 19. September 06
  • Reputation: 0
  • Wohnort:Merseburg

geschrieben 14. November 2006 - 18:32

Hallo!

Hier mal eine Zwischenmeldung von mir:
Der Link von ph030 war richtig vielversprechend, aber... Naja es läuft halt trotzdem nix ich bekomme immer bei "make" und demzufolge auch bei "make install" Fehlermeldungen
Checking in /lib/modules/2.6.16.13-4-default for ieee80211 components...
grep: /lib/modules/2.6.16.13-4-default/build//.config: No such file or directory
grep: /lib/modules/2.6.16.13-4-default/build//include/linux/autoconf.h: No such file or directory
make -C /lib/modules/2.6.16.13-4-default/build M=/home/OnlyP/Downloads/ieee80211-1.2.15 modules
make[1]: Entering directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make: *** [modules] Error 2

Ich bin schon am überlegen ob ich mal versuche die fehlenden Daten per Hand zu kopieren und schaue was dann passiert. Aber da werd ich mich vorher nochmal ans Suse-Forum wenden, weil dass scheinbar ein Suse-typisches Problem ist. Danke an alle!

@blue32:
In der Datenbank steht sie nicht (wlan)
GPU->Grafikkarte, es ist eine ATI Mobility X700pro

@Master.Max:
Im Bios finde ich nix, und normalerweise wird die Karte per Hardwareschalter am Notebook aktiviert/deaktiviert.
...und ja, die Karte ist normalerweise an ;)

@all die es noch nicht wussten und NICHT wissen wollen:
Der [CD]-Befehl im Shell ist doch etwas anders als im DOS, aber wenn mans geschnallt hat ists auch leicht :blink: ;) ;)
MfG Olli

HÖFLICHKEIT IST KEIN VERBRECHEN
0

#12 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 14. November 2006 - 19:45

Hast du die zu deinem Kernel passenden Sourcen und Header installiert? Die werden benötigt, um das Modul zu übersetzen.
0

#13 Mitglied ist offline   Only-P 

  • Gruppe: aktive Mitglieder
  • Beiträge: 112
  • Beigetreten: 19. September 06
  • Reputation: 0
  • Wohnort:Merseburg

geschrieben 15. November 2006 - 13:22

Guten Morgen ;) !

Ja, die Sources hab ich. Die Sources sind in der Version 2.6.16.13-4 und Der Systemkernel die Nummer 2.6.16.13-4-smp. Da ich keine vergleichbare Kernel-Source (also mit smp hinten) finde denke ich mal dem ist so OK.
Dafür kommt jetzt bei
make
eine neue schöne Meldung:
OnlyP@noname:~/Downloads/ieee80211-1.2.15> sudo make
/bin/sh: cc: command not found
...
also da kommen schon noch die typischen ;) Ausgaben inklusive Error 2...

make check_old
hat leider auch nichts geholfen.
Mh, irgendwo hab ich gelesen ich brauche evtl. die
packman repositories
, aber die find ich natürlich (noch) nicht. Nur das Spiel, andere Sysprogs, oder auch mal ne Herstellerseite... Und dabei soll das eigentlich aufm Installationsmedium sein...

Na gut, ich pack das schon! Drückt mir einfach die Daumen... ;)
MfG Olli

HÖFLICHKEIT IST KEIN VERBRECHEN
0

#14 Mitglied ist offline   blue32 

  • Gruppe: aktive Mitglieder
  • Beiträge: 625
  • Beigetreten: 28. Juli 05
  • Reputation: 0

geschrieben 15. November 2006 - 13:50

Only-P sagte:

Ja, die Sources hab ich. Die Sources sind in der Version 2.6.16.13-4 und Der Systemkernel die Nummer 2.6.16.13-4-smp. Da ich keine vergleichbare Kernel-Source (also mit smp hinten) finde denke ich mal dem ist so OK.

Haben die neueren Centrinos jetzt schon mehrere Kerne?


Only-P sagte:

Dafür kommt jetzt bei
make
eine neue schöne Meldung:
OnlyP@noname:~/Downloads/ieee80211-1.2.15> sudo make
/bin/sh: cc: command not found
...

AFAIK ist "sudo" eine Implementation, die auschließlich in Ubuntu (und Derivaten) Anwendung findet. Ein "su" sollte ausreichen, um als root zu agieren.
These guys are the best surfers in the world.
No surfboard, no wetsuit, no worries.

Phil, speaking about dolphins
0

#15 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.132
  • Beigetreten: 14. Juli 04
  • Reputation: 36
  • Geschlecht:unbekannt

geschrieben 15. November 2006 - 18:04

Zitat

AFAIK ist "sudo" eine Implementation, die auschließlich in Ubuntu (und Derivaten) Anwendung findet. Ein "su" sollte ausreichen, um als root zu agieren.


sudo gibt's überall, ob es allerdings mitgeliefert und eingerichtet ist, ist fraglich. sudo ist zwar praktisch, aber gleichzeitig auch alles andere als ungefährlich.

@Only-P (nicht hauen, aber irgendwie lese ich da immer Olli P. :P )

Den gcc hast du aber schon installiert, denn afaik ist der zwar standardmäßig auf der Installations-DVD zu finden, im System selbst aber nicht installiert.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0