WinFuture-Forum.de: Kann mit keiner msi Datei installieren - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 10: Alle News, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 10 - Special informieren!
Seite 1 von 1

Kann mit keiner msi Datei installieren


#1 Mitglied ist offline   daghaedd 

  • Gruppe: aktive Mitglieder
  • Beiträge: 295
  • Beigetreten: 09. Mai 09
  • Reputation: 2

geschrieben 23. August 2016 - 18:33

Hallo,
kann seit einiger Zeit keine msi Datei starten bzw. mit ihr installieren. Es kommt sofort die Meldung, Zugriff verweigert. Ich habe das Annyversary Update in Verdacht. Von da an funktionierten die Installation mit msi Dateien nicht mehr.
Bei den Diensten ist Windows Installer auf manuell eingestellt, müsste aber wohl auf automatisch eingestellt sein. Wenn ich nachsehe, ist er immer beendet. Starte ich ihn, funktioniert der Windows Installer trotzdem nicht.
Dann habe ich Windows-Installer 4.5 runter geladen. Der lässt sich nicht installieren. Nach einer gewissen Zeit kommt eine Meldung, dass nicht genug Speicherplatz vorhanden sei. Ich habe 4 GB Speicher.
Kennt jemand diesen Fehler und kann mir weiterhelfen?

Win10 64 bit
Version 1607 (Build 14393.51)
0

Anzeige



#2 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 23. August 2016 - 22:48

Du bräuchtest auch die Version 5.0 zumindest.

msiexec kann protokollieren. Schau Dir mal die Befehlszeilenoptionen an (einfach msiexec ausführen ohne Parameter) und dann protokolliert starten.

Zum Beispiel als

msiexec -i setup.msi -licewarmup "%temp%\msi_test_log.txt"


sodaß Du hinterher im Temp-Ordner die Protokolldatei findest. Da drin sollte dann stehen, was das Problem ist.

- Vollständig loggen geht mit -l*v+ (kleines L wie 'log'). Aber aufpassen, das wird sehr schnell sehr viel.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#3 Mitglied ist offline   daghaedd 

  • Gruppe: aktive Mitglieder
  • Beiträge: 295
  • Beigetreten: 09. Mai 09
  • Reputation: 2

geschrieben 25. August 2016 - 13:27

Bei MSIESEX war ich schon.Da kommt ein Menü mit Text, der aber so umfangreich ist, das ich nicht schlau daraus werde.
Gebe ich MIESEX mit Deinen Paramtern ein, kommt eine Fehlermeldung, die ich hier mal als Screenshot anfüge.
Einen DL für Windows Installer 5.0 finde ich nicht.

Habe soeben als ADMIN mit CMD die Befehle msiexec /regserver und msiexec /unregister und danach sfc /scannow ausgeführt.
Bekomme die Meldung: Der Windows-Ressourcenschutz konnte den Reparaturdienst nicht starten.

Gruß,
Dag

Angehängte Miniaturbilder

  • Angehängtes Bild: MSIESEX Meldung.png

Dieser Beitrag wurde von daghaedd bearbeitet: 25. August 2016 - 14:14

0

#4 Mitglied ist offline   daghaedd 

  • Gruppe: aktive Mitglieder
  • Beiträge: 295
  • Beigetreten: 09. Mai 09
  • Reputation: 2

geschrieben 11. September 2016 - 20:26

Hallo,
ist hier jemand mit ein bisschen Erfahrung, der mir weiterhelfen kann? Bei den Diensten steht der Windows Installer auf manuell starten. Wahrscheinlich muss er auf automatisch stehen. Gibt es eine Möglichkeit, bei den Diensten auf automatisch umzustellen?
Gruß,
Dag
0

#5 Mitglied ist online   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.479
  • Beigetreten: 19. August 04
  • Reputation: 1.371
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 11. September 2016 - 20:32

Der Dienst sollte auf 'Manuell' stehen, da er nur benötigt wird, wenn eine Setup läuft. Ansonsten ist er überflüssig und blockiert u.U. das Setup, wenn er permanent läuft.

Als Du die Zeile von Ralph eingeben hast, hast Du da setup.msi durch den Namen Deiner *.msi Datei ersetzt (einschließlich Pfad)?

Ansonsten 'Zugriff Verweigert' klingt nicht nach einem technischen Problem, sondern einfach nach einem Rechteproblem. Du hast keine Rechte, die *.msi auszuführen.
Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
0

#6 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 12. September 2016 - 05:09

"Konnte den Reparaturdienst nicht starten"? :unsure:

Hast Du da mal Tuningtools rüberlaufen lasen?

- Daß Du den Windows Installer 4.x nicht installiert kriegst ist normal. Windows 10 bringt selber einen mit und der ist bis auf weiteres vermutlich neuer.

- Versuch Dich mal an einem Auffrischen. Vorher aber möglichst noch ein Backup erstellen, für den Fall, daß auch das nicht mehr richtig funktioniert.

- Probier mal, den bewußten MSI-Befehl mit Adminrechten auszuführen. Nur für den Fall, daß Dein Benutzer keine Leserechte auf der Datei hat.

- Aber ich würde vorsichtig sagen, daß da inzwischen eine Neuinstallation angezeigt ist (hoffentlich reicht der Refresh).
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0