WinFuture-Forum.de: USB als Stromversorung und USB für eine Maus, einschalten des PC - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Peripherie & Komplett-PCs
Seite 1 von 1

USB als Stromversorung und USB für eine Maus, einschalten des PC


#1 Mitglied ist offline   Lastwebpage 

  • Gruppe: aktive Mitglieder
  • Beiträge: 515
  • Beigetreten: 26. Dezember 07
  • Reputation: 46

geschrieben 01. November 2015 - 13:00

Hallo,
ich habe da mal eine vielleicht etwas seltsame Frage.

Gegeben sind folgende Geräte und diese sind auch angeschlossen, beide Akkus werden also geladen:
1) Eine Maus, eBookReader, mp3 Walkman usw. mit Akku, die über ein USB Kabel geladen wird. Diese Geräte verfügen über eingebaute Software und werden beim einstecken von Windows erkannt.
2) Ein Gerät mit eingebauten Akku, welches über keinerlei Software verfügt, was aber über einen USB Port geladen werden kann.

Jetzt wird der PC neu gestartet. Ergebnis:

A) Die Geräte unter 1) werden weiterhin geladen.
B) Der USB Anschluss wo 2 dran hängt ist abgeschaltet. Auch ein Gerät von 1) wird nicht erkannt. Nur ein erneuter Neustart (über "Windows neu starten" oder Resetknopf) aktiviert diesen USB Port wieder.

Die Frage ist jetzt, wird dieser USB Port vom Motherboard abgeschaltet oder von Windows?
(Die Anzeige am Gerät ist leider nicht so gut, ich kann den Ladevorgang im Einschaltmoment des PCs nicht beobachten.)

Peter
0

Anzeige



#2 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 01. November 2015 - 13:20

Was passiert denn, wenn Du die ganze Gerätschaft umsteckst? Wandert der "inaktive" USB-Port dann mit dem Gerät?

- Wobei. Verstehe ich das richtig, daß dieses fragliche unbekannte Gerät kein... "Datengerät" ist? Also eines, welches keine Daten austauscht, sondern so ziemlich genau NUR den Strom nutzt? :unsure:

- In dem Fall wäre das Windows, was da deaktiviert, bzw genauer: der Treiber. USB-Port gescannt => kein Gerät gefunden (weil es sich ja nicht meldet/melden kann) => Port inaktiv geschaltet.

Dasselbe Verhalten gibt's aber auch, wenn der USB-Port einen eigenen proprietären Treiber will (sei es für den Port selber oder für die Geräteklasse des angesteckten Gerätes) und der aber nicht da ist. In dem Fall initialisiert die Firmware den Port, beim Bootvorgang wird dann die Kontrolle ans Betriebssystem übergeben und das kann aber den Port mangels Treiber nicht ansprechen => Port inaktiv.

Richtig "USB" ist das dann allerdings nicht, wenn das Gerät nicht antworten kann. Für sowas bräuchte man dann USB-Ports, die nicht "stumm"geschaltet werden, wenn nichts dranhängt, zB entsprechende Ladeports am PC oder direkt am Netzteil.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#3 Mitglied ist offline   Wiesel 

  • Gruppe: aktive Mitglieder
  • Beiträge: 5.886
  • Beigetreten: 09. Mai 06
  • Reputation: 524
  • Geschlecht:unbekannt
  • Wohnort:Punxsutawney, 742 Evergreen Terrace
  • Interessen:Mein Schneckenhaus

geschrieben 01. November 2015 - 17:30

@ralph: Die 5V dürften aber nicht abgeschaltet werden, denn dann würde ja auch ein neues Gerät nicht erkannt werden wenn man es einsteckt. Ich vermute hier eher die Hardware, dass hier eine Sicherheitsfunktion aktiv ist. So wie ich das sehe wird hier von den USB Anschlüssen sehr viel Leistung abverlangt. Ich kenne das so dass einige USB Anschlüsse vom Board deaktiviert werden können wenn die Stromaufnahme zu hoch ist/wird oder dass man einzelnen USB Anschlüssen im BIOS Dauerspannung (also auch im ausgeschaltetem Zustand) zuweisen kann.

Ich kann es nicht empfehlen die USB Anschlüsse als stetige Ladestation zu benutzen, ein externes USB Ladegerät verrichtet hier wesentlich bessere Arbeit.
around the world
0

#4 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.803
  • Beigetreten: 20. Juli 07
  • Reputation: 1.121
  • Geschlecht:Männlich
  • Wohnort:Zuhause
  • Interessen:Ja

geschrieben 01. November 2015 - 19:33

Gut möglich, ja. Schwer zu beurteilen, ohne zu wissen, was denn dieses ominöse Gerät genau ist.

- Dachte das war nur 5VSB, was da online blieb? :unsure: Vielleicht verwechsel ich da was.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#5 Mitglied ist offline   Lastwebpage 

  • Gruppe: aktive Mitglieder
  • Beiträge: 515
  • Beigetreten: 26. Dezember 07
  • Reputation: 46

geschrieben 02. November 2015 - 00:34

Ja dieses Gerät verwendet nur die USB Spannung zum Laden des geräteinternen Akkus, mehr nicht und bei Wechseln des USB Ports, wandert dieses Verhalten auch mit.
Dieses ominöse Gerät ist ein Akku für e-Zigaretten, hat aber keine updatebare Firmware oder so.

@Wiesel, ich bin etwas faul. Ich habe die Logitech Maus G700. Die hat 2 Mignon Akkus, die man entweder separat laden kann oder eben über ein USB Kabel mit Ministecker.
Das meistens ungenutzte, aber am PC eingesteckte, USB Kabel liegt also sowieso auf meinem Schreibtisch rum (Nein, es besteht kein Zusammenhang damit, dass ich über dieses Kabel auch manchmal die Maus lade).
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0