WinFuture-Forum.de: "linux" Freezed (windows Nicht^^) - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Linux
Seite 1 von 1

"linux" Freezed (windows Nicht^^) egal welche Distro, egal ob "acpi=off"


#1 Mitglied ist offline   Astorek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.144
  • Beigetreten: 28. Juli 07
  • Reputation: 42
  • Geschlecht:Männlich

geschrieben 13. September 2009 - 23:13

Hi @ all,

ich habe in letzter Zeit mit meinem treu gedientem Laptop - einem IBM Thinkpad R50 - welches seit Jahren unter Linux problemlos seinen Dienst tat, seit Neuestem das Problem, dass es sporadisch einfach so komplett einfriert und absolut nix mehr geht (auch kein Fernzugriff per SSH oder irgendwelche Magic-SysRequests). Das Problem tritt zu äußerst verschiedenen Zeiten ein von denen es kein Muster zu geben scheint (mal hängt alles schon beim Laden von Modulen, mal unter Volllast auf dem Desktop, mal beim Idlen in der Konsole), auch der Zeitpunkt ist arg zufällig (mal keine 2 Minuten nachdem das System hochgefahren ist, mal nach 6 Stunden), lediglich das verursachte Problem ist immer gleich:
- Der Bildschirm aktualisiert garnix mehr
- Die LEDs am unteren Ende des Laptops nehmen keine Änderungen mehr wahr (z.B. LED für Caps Lock)
- Es werden keinerlei Eingaben mehr verarbeitet (as say, auch keine SysRQ)

Auch diverse Parameter in der menu.lst der Grub-Config (insgesamt durchprobierte Parameter in allen Kombinationen: "acpi=off noapic nolapic hpet=disable") bringen keinerlei Wirkung. Sogar LiveCDs unterschiedlicher Distros schaffen es, mitten im Betrieb einen Freeze zu verursachen (durchprobiert habe ich Archlinux, Ubuntu, Fedora und Gentoo). Nach einem Neustart versuche ich, aus so ziemlich allen Logdateien in /var/log irgendwelche Infos und Errors auszulesen, vergeblich - es gibt keine Errors.

Ausschließen kann ich zudem:
- Fehler beim GraKa-Treiber (Problem passiert auch mit "vesa"-Treibern)
- Fehler der HDD (S.M.A.R.T.-Werte sind OK, auch eine Durchjagd von "dd if=/dev/sda of=/dev/zero" verlief einwandfrei)
- Fehler im Dateisystem (as say, sogar mit LiveCDs gibts Probleme)
- Fehler im RAM (Memtest lief eine ganze Nacht ohne Fehler durch)
- Probleme mit Temperaturen (selbst unter Volllast, die der Laptop maximal vier, fünf Minuten erreicht, liegt die Temperatur aller Komponenten generell zwischen 50-60°, im Idle zwischen 25-40°)

Am System habe ich absolut nichts verändert. Vor ca. 9 Monaten, seit ich mir den Läppi kaufte, bis vor ca. 10 Tagen lief Linux darauf einwandfrei.

Das Seltsamste ist allerdings, dass ein parallel installiertes Windows XP überhaupt keine Probleme hat (wenn es das hätte, hätte ich dann auch noch auf einen HW-Fehler geschätzt). Ich habe XP in den letzten beiden Wochen genauso intensiv getestet wie die darauf installierten Linuxe, aber nur unter Linux bekam ich Freezes...

---

Tjoar, bin gespannt, ob jemand für SO einen Mist Problemlösungen parat hat, derjenige hat auf alle Fälle meine vollständige Dankbarkeit^^.
0

Anzeige



#2 Mitglied ist offline   Internetkopfgeldjäger 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.718
  • Beigetreten: 29. Januar 04
  • Reputation: 1
  • Geschlecht:Männlich
  • Interessen::-)

geschrieben 13. September 2009 - 23:36

Noch müsstest Du ja auf das Gerät Garantie haben,
also falls dein Thinpad doch von der Flexing Krankheit betroffen sein sollte
wärs wohl gut, das vor Ablauf einer Garantie noch reklamieren zu können:
http://thinkpad-wiki...p?title=Flexing
0

#3 Mitglied ist offline   Astorek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.144
  • Beigetreten: 28. Juli 07
  • Reputation: 42
  • Geschlecht:Männlich

geschrieben 15. September 2009 - 20:42

Hm, danke für den Tipp. Ich habe den Laptop mal den ITler meines Vertrauens gegeben, mal sehen, was er herausfinden kann... Finde es zwar trotzdem merkwürdig, dass das Einfrieren beim Test ausschließlich unter Linux passierte, aber einen wirklich dummen Zufall kann man ja auch nicht anschließen...

Mal sehen, was sich ergibt, ggf. update ich den Thread dann :wacko:
0

#4 Mitglied ist offline   Kirill 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.590
  • Beigetreten: 04. Dezember 06
  • Reputation: 121
  • Geschlecht:Männlich
  • Wohnort:BT

geschrieben 08. Oktober 2009 - 16:04

Ich hatte mal was Ähnliches, und zwar Dauerfreezer mit Windows aber nicht mit Linux. Des Problems Lösung war eine abstruse Inkompatibilität, die zutage tratt, wenn sich das BIOS, Windows XP und die Grafikkarte trafen. Ein BIOS-Update war die Lösung. Vll hilft das Beispiel.
Most rethrashing{
DiskCache=AllocateMemory(GetTotalAmountOfAvailableMemory);}
0

#5 Mitglied ist offline   Astorek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.144
  • Beigetreten: 28. Juli 07
  • Reputation: 42
  • Geschlecht:Männlich

geschrieben 08. Oktober 2009 - 18:38

BIOS- und sonstige Updates waren alle aktuell. Der ITler hat mir das Gerät freundlicherweise mit eineausgetauscht, sodass das Problem nun mehr oder weniger behoben ist. Er wusste auch nicht, woran es lag, konnte das Problem aber bestätigen... War recht nett, hätte nicht gedacht dass ich nach nun fast 10 Monaten noch ein Neugerät im Garantiefall erhalten würde^^.

Also, das Problem ist also - mehr oder weniger - behoben...
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0