WinFuture-Forum.de: [erledigt] Webdav Zugriff Nur Teilweise Möglich - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Netzwerk
Seite 1 von 1

[erledigt] Webdav Zugriff Nur Teilweise Möglich

#1 Mitglied ist offline   prunkster 

  • Gruppe: aktive Mitglieder
  • Beiträge: 265
  • Beigetreten: 22. Mai 08
  • Reputation: 5

geschrieben 03. Juli 2009 - 22:23

Abend liebe Winfuture-Gemeinde!
So, mein erster Thread, in dem ich mal Hilfe brauche ;)

Ich sitze derzeit zu Lernzwecken daran, mir einen kleinen Home Server auf Basis von Debian (Etch) aufzusetzen. Dieser soll als DHCP- & DNS-Server sowie als Samba-PDC mit zentraler Benutzerverwaltung über OpenLDAP dienen. Für den Test habe ich dieses in einer virtuellen Maschine realisiert. Dieses funktioniert bisher auch, ich konnte den ersten Client erflogreich in meine Domäne einbinden.

Jetzt wollte ich eigentlich noch einen WebDAV-Zugang über SSL einrichten, bei dem die Benutzer ebenfalls über LDAP authentifiziert werden. Dies will mir jedoch nicht ganz gelingen. Die Module dav und dav_fs für Apache sind bereits aktiv, ein eigener VirtualHost für's WebDAV ist erstellt, jedoch kann ich weder über "Orte->Verbindung zu Server..." in Ubuntu noch in Windows mittels "Netzwerkressource hinzufügen" auf das WebDAV zugreifen. Ich werde bei beiden noch nach meinen Benutzerdaten gefragt, bei Windows zusätzlich, ob ich das selbst unterschriebene SSL-Zertifikat bestätigen will (musste ein Wildcard-Zertifikat erstellen, da auf 'nem anderen VirtualHost noch Management-Interface läuft).

Danach ist jedoch bei beiden kein Zugriff möglich. Windows meldet

Zitat

Die Dokumente in diesem Ordner sind nicht verfügbar. Möglicherweise wurde der Ordner verschoben oder gelöscht, oder die Verbindung zum Server ist aufgrund von Netzwerkproblemen nicht möglich."

und Ubuntu schmeisst mir direkt nach dem Verbinden

Zitat

>>davs://webdav.localdomain.com/<< konnte nicht angezeigt werden
Fehler: Kein WebDAV-fähiger Speicher
Bitte wählen Sie einen anderen Betrachter und versuchen Sie es erneut


Lustig ist: Versuche ich in Ubuntu über cadaver auf das WebDAV zuzugreifen, funktionierts wunderbar, zumindest Ordner erstellen, weiter hab ich noch nichts probiert... Auch über den Browser kann ich ohne Probleme darauf zugreifen...

Anbei mal meine VHost Konfiguration:
   ServerName webdav.localdomain.com
   ServerAdmin Administrator@localdomain.com

   SSLEngine on
   SSLCertificateKeyFile ssl/server.key
   SSLCertificateFile ssl/server.crt
   SSlProtocol all
   SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:
+SSLv2:+EXP:+eN$

   DocumentRoot /var/www/webdav/
   <Directory /var/www/webdav/>
	  Options Indexes MultiViews
	  AllowOverride None
	  Order allow,deny
	  allow from 192.168.0.0/24
	  SSLRequire %{SSL_CIPHER_USEKEYSIZE} >= 128
   </Directory>

   #DAVLockDB /var/lib/apache2/DAVLockDB
   Alias /webdav /var/www/webdav

   <Location /webdav>
	  DAV On
	  AuthType Basic
	  AuthName "WebDAV"
	  AuthBasicProvider ldap
	  AuthLDAPURL "ldap://127.0.0.1/ou=Users,dc=localdomain,dc=com"
	  AuthLDAPRemoteUserIsDN off
	  ForceType text/plain
	  Require valid-user
	  Require ldap-filter &(uid=*)

   </Location>

   ErrorLog /var/log/apache2/webdav_error.log
   CustomLog /var/log/apache2/webdav_access.log combined
   LogLevel warn

</VirtualHost>


Liegt in der Konfiguration irgendwo der Wurm, oder wo kann sich der Fehler noch befinden?

Vielen Dank für eure Antworten im Voraus!

Mfg prunkster

//Edit:
Hat sich erledigt... Bei Windows hat mir einfach nur die Desktop Firewall dazwischengefunkt... Was nun aber bei Ubuntu ist, kann ich nicht genau sagen, über "Orte->Verbindung zu Server..." will es weiterhin nicht (zeigt immer noch den selben Fehler an), jedoch wenn ich in Nautilus die URL direkt eingebe, funktioniert es... Von daher...

Vielen Dank dennoch an alle die hier reingeschaut und mitgegrübelt haben!

Dieser Beitrag wurde von prunkster bearbeitet: 04. Juli 2009 - 13:35

Eingefügtes Bild <--- Workstation@Home

My Blog: hier
0

Anzeige

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0