WinFuture-Forum.de: Upgrade: Kann aus Linux keine Dateien mehr auf der W10 Festplatte spei - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 10: Alle News, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 10 - Special informieren!
Seite 1 von 1

Upgrade: Kann aus Linux keine Dateien mehr auf der W10 Festplatte spei


#1 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 04. Juli 2020 - 14:38

Ich habe vor kurzem das upgrade zur Version 2004 gemacht.

Aber jetzt kann ich nicht mehr aus Linux auf der Windows 10 HDD Dateien speichern.

Bei der vorherigen Windows 10 Version konnte ich das beheben, indem ich Fastboot deaktiviert hatte.
Ich dachte, vielleicht hat das Upgrade "Fastboot" wieder automatisch aktiviert. Deshalb habe ich die Einstellung kontrolliert.
Ergebnis: Das Kontrollkästchen neben "Fastboot" ist immer noch deaktiviert.
Trotzdem kann ich nicht von Linux auf die Festplatte schreiben.

Gibt es dafür eine Lösung.

Im voraus besten Dank.

Gruss
Verprida

Angehängte Miniaturbilder

  • Angehängtes Bild: blockierte HD Windows 10.png

Dieser Beitrag wurde von Verprida bearbeitet: 04. Juli 2020 - 14:39

0

Anzeige



#2 Mitglied ist offline   Sarek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 681
  • Beigetreten: 16. April 18
  • Reputation: 214
  • Geschlecht:Männlich

geschrieben 04. Juli 2020 - 15:07

Haben sich denn die Schreibrechte auf der Win10 HDD verändert?
Da würde ich mal bei den entsprechenden Ordnern unter Win10 nachschauen.
_________________________
Arbeitstier 1: i5 9400f (6x2,9 GHz), 32 GB RAM, 512 GB SSD, 2 TB HDD, 1.44 MB FDD
Arbeitstier 2: Xeon E3 1230 V3 (4x3,0 GHz), 16 GB RAM, 512 GB SSD, 2 TB HDD
Arbeitstier 3: Intel Xeon E5450 (4x3 GHz), 16 GB DDR3, 120 GB SSD, 500 GB HDD
Arbeitstier 4: T61 mit T9500 (2x2,6 GHz), 8 GB RAM, 120 GB SSD


Alle mit Windows 10
1

#3 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 04. Juli 2020 - 15:59

Hallo @Sarek.

Danke für Deinen Beitrag.

Ja, irgendwie scheint es schreibgeschützt zu sein.
Printscreen aus dem Windows 10 Explorer:
Angehängtes Bild: Schreibgeschützt.PNG

(?)

Fastboot ist draussen:
Angehängtes Bild: Fastboot aus.PNG

Dieser Beitrag wurde von Verprida bearbeitet: 04. Juli 2020 - 16:46

0

#4 Mitglied ist offline   thielemann03 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.350
  • Beigetreten: 28. Januar 19
  • Reputation: 187
  • Geschlecht:Männlich
  • Wohnort:Marksuhl
  • Interessen:Garten, Simson Vogelserie, CAD, Kaninchenzucht(rheinische Schecken)

geschrieben 04. Juli 2020 - 20:49

Dann nimm doch den Schreibschutz raus und alles sollte wieder wie früher sein. Ich habe für Daten eine eigene Plattte, da die Windowspartition nur relativ klein ist und 2 Spiele schon sehr viel Platz brauchten. Das macht dann bei Upgrades nix an den anderen Festplatten.
Niemand ist so gut, wie ich sein könnte.
0

#5 Mitglied ist offline   Sarek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 681
  • Beigetreten: 16. April 18
  • Reputation: 214
  • Geschlecht:Männlich

geschrieben 04. Juli 2020 - 21:18

Beitrag anzeigenZitat (Verprida: 04. Juli 2020 - 15:59)

Hallo @Sarek.

Danke für Deinen Beitrag.

Ja, irgendwie scheint es schreibgeschützt zu sein.
Printscreen aus dem Windows 10 Explorer:
Anhang Schreibgeschützt.PNG

(?)

Hier im Reiter "Sicherheit" mal nachschauen, wer alles darauf Zugriff hat. Sofern nicht vorhanden oder nur mit Lese-Rechte: Teste mal bei einem Ordner mit der "jeder" Berechtigung und gib dieser alle Lese-Schreibrechte
_________________________
Arbeitstier 1: i5 9400f (6x2,9 GHz), 32 GB RAM, 512 GB SSD, 2 TB HDD, 1.44 MB FDD
Arbeitstier 2: Xeon E3 1230 V3 (4x3,0 GHz), 16 GB RAM, 512 GB SSD, 2 TB HDD
Arbeitstier 3: Intel Xeon E5450 (4x3 GHz), 16 GB DDR3, 120 GB SSD, 500 GB HDD
Arbeitstier 4: T61 mit T9500 (2x2,6 GHz), 8 GB RAM, 120 GB SSD


Alle mit Windows 10
0

#6 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.511
  • Beigetreten: 19. August 04
  • Reputation: 1.375
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 04. Juli 2020 - 21:52

Es wäre interessanter zu wissen, wie Linux in Zusammenhang mit NTFS eingerichtet wurde und um welches Linux es überhaut geht.

Wichtig wäre zu wissen, mit welchem Parametern das NTFS Volumen gemountet wird.

Prinzipiell interessiert sich Linux nicht für die Berechtigungen von NTFS, außer man richtet das ein. Dann geht das irgendwie mehr oder weniger. Daher kann man ja auch Linux so gut dafür verwenden, Daten von NTFS Laufwerken zu sichern, da man eigentlich überall ran kommt, ohne sich um Besitz oder Rechte kümmern zu müssen.

Bei mir hat sich nach Upgrade auf die 2004 nichts verändert. Linux kommt immer noch überall ran und kann auch ohne Probleme auf das NTFS Laufwerk schreiben.
Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
2

#7 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 04. Juli 2020 - 22:11

(Bitte beachten: Mit Rechten kenne ich mich nicht aus. Ich habe zwar vor etwa 2 Jahren versucht durchzublicken, hat aber nicht geklappt und inzwischen habe ich alles wieder vergessen.)


Trotzdem habe ich jetzt folgendes gemacht:

Beitrag anzeigenZitat (Sarek: 04. Juli 2020 - 21:18)

Hier im Reiter "Sicherheit" mal nachschauen, wer alles darauf Zugriff hat.

Ergebnis (Gif-Animation):
Angehängtes Bild: REchte.gif

Beitrag anzeigenZitat (Sarek: 04. Juli 2020 - 21:18)

Sofern nicht vorhanden oder nur mit Lese-Rechte: Teste mal bei einem Ordner mit der "jeder" Berechtigung und gib dieser alle Lese-Schreibrechte


So?
Angehängtes Bild: Jeder, öffentlich.PNG


Zurück in Linux: Die Rechtevergabe im Ordner öffentlich hat aber nichts geändert, wenn ich in Linux bin:
Angehängtes Bild: Documetns Windows.png

------------------------------------------------------------------------------------------------------------

Kann man wirklich durch Veränderung der Rechte in Windows 10 erreichen, dass Linux dann auf diese HD schreiben kann?


Zitat

Dann nimm doch den Schreibschutz raus und alles sollte wieder wie früher sein.

Ich kann in Win10 nur auf einzelne Ordner Rechtsklicken und dann mir die Rechte anschauen. Wenn ich also wissen möchte, ob jeder einzelne Ordner schreibgeschützt ist, müsste ich jeden Ordner anklicken.

Aber es scheint so zu sein, dass alle Ordner auf Laufwerk c: Schreibgeschützt sind.

Aber trotzdem kann ich in diesen Ordnern speichern, wenn ich mich in Windows 10 befinde. Sollte dann eben nicht gerade das auch unmöglich sein?


Zitat

Dann nimm doch den Schreibschutz raus und alles sollte wieder wie früher sein.

Wie kann ich das machen?
Wenn ich einen Rechtsklick auf c: mache, dann kann ich dort keinen Schreibschutz aktivieren/deaktivieren.


Und letztlich noch die Frage:
Ist beim Upgrade etwas schief gelaufen, dass das jetzt so ist?





Edit:
@DK2000: Sorry Crosspost.

Ich werde mich gleich noch mit Deinem Beitrag befassen.

Dieser Beitrag wurde von Verprida bearbeitet: 04. Juli 2020 - 22:11

0

#8 Mitglied ist offline   thielemann03 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.350
  • Beigetreten: 28. Januar 19
  • Reputation: 187
  • Geschlecht:Männlich
  • Wohnort:Marksuhl
  • Interessen:Garten, Simson Vogelserie, CAD, Kaninchenzucht(rheinische Schecken)

geschrieben 04. Juli 2020 - 22:26

Du machst einen Rechtsklick auf den Ordner oder das Laufwerk und gehst dann auf Eigenschaften. Im, sich öffnenden Fester siehst du dann das Kontrollkästchen mit dem schwarzen Quadrat bei schreibgeschützt, klicke das an und es sollte weg sein. Dann auf OK und wenn gefragt wird auf Änderungen übernehmen.
(n vergessen)

Dieser Beitrag wurde von thielemann03 bearbeitet: 04. Juli 2020 - 22:27

Niemand ist so gut, wie ich sein könnte.
0

#9 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 04. Juli 2020 - 22:31

Beitrag anzeigenZitat (DK2000: 04. Juli 2020 - 21:52)

Es wäre interessanter zu wissen, wie Linux in Zusammenhang mit NTFS eingerichtet wurde und um welches Linux es überhaut geht.


MX Linux 19.
Wie gesagt: Vor dem Upgrade (ohne Fastboot) kein Problem. Linux konnte überall schreiben.
Linux ist auf SATA 0 und Windows 10 auf SATA 1. (2 Festplatten).
Windows hatte einen eigenen Bootsektor, so dass Windows notfalls problemlos auch gestartet werden kann, wenn Linux (SATA 0) nicht am PC hängt. Zusätzlich komme ich aber beim Start von Linux in ein Menü, wo ich wählen kann, ob ich Windows 10 oder Linux starten will.

Wie ich das Upgrade gemacht habe:
Um genau zu sein, habe ich 2 Versuche gebraucht, um Windows 10 upzugraden.

-Beim ersten Versuch hing während dem upgrade natürlich auch die Festplatte von Linux intern am Computer. Es kann sein, dass auch noch ein USB Stick während dem Upgrade am PC hing.
Jedenfalls hat er Version 2004 installiert, und blieb bei 99% hängen. Also habe ich nach 1 oder 2h das Upgrade abgebrochen.

Der PC liess sich dann wieder normal mit Windows 10 starten (also mit der Version vor 2004).
Aber könnte es ev. sein, dass bereits nach dieser Prozedur das Schreibschutz Problem aufgetaucht ist? Leider weiss ich das nicht, weil ich während dieser Zeit nicht versucht habe, von Linux aus etwas auf dei Festplatte zu schreiben.


-Beim 2ten Versuch, habe ich die Linux Festplatte ausgesteckt und den USB Stick vom PC entfernt.
Diesemal klappte das Upgrade, wie man es erwarten würde.



Beitrag anzeigenZitat (DK2000: 04. Juli 2020 - 21:52)

Wichtig wäre zu wissen, mit welchem Parametern das NTFS Volumen gemountet wird.

Wie finde ich das raus? In thunar klicke ich einfach auf meine Windows 10 Partition, dann fragt mich Linux nach dem Linux root Passwort. Das gebe ich ein, und dann kann ich durch die Platte browsen.



Beitrag anzeigenZitat (DK2000: 04. Juli 2020 - 21:52)

Prinzipiell interessiert sich Linux nicht für die Berechtigungen von NTFS, außer man richtet das ein. Dann geht das irgendwie mehr oder weniger. Daher kann man ja auch Linux so gut dafür verwenden, Daten von NTFS Laufwerken zu sichern, da man eigentlich überall ran kommt, ohne sich um Besitz oder Rechte kümmern zu müssen.

Ich habe nichts spezielles eingerichtet in Bezug auf Berechtigungen.



Beitrag anzeigenZitat (DK2000: 04. Juli 2020 - 21:52)

Bei mir hat sich nach Upgrade auf die 2004 nichts verändert. Linux kommt immer noch überall ran und kann auch ohne Probleme auf das NTFS Laufwerk schreiben.

Gut zu wissen. Das scheint also doch kein neues Microsoft "Feature" zu sein. :lol:
0

#10 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 19.511
  • Beigetreten: 19. August 04
  • Reputation: 1.375
  • Geschlecht:Männlich
  • Wohnort:Oben auf dem Berg
  • Interessen:Essen, PC, Filme, TV Serien...

geschrieben 04. Juli 2020 - 22:33

@thielemann03:

Das Kästchen "Schreibschutz" bei Ordnern hat weder unter Windows noch unter Linux irgendeine Wirkung in Verbindung mit Schreibschutz. Das betrifft nur die Dateien im Ordner, wenn man es ändert. Bei Ordner hat das Attribute nur Bedeutung in Verbindung mit dem Attribut "System", um z.B. eine Desktop.ini im Ordner auszuwerten. Ein Schreibschutz für den Ordner lässt sich damit nicht realisieren.

@Verprida:

Wenn Du mal im Linux Terminal mount eingibst, suche mal in der Liste die NTFS Partition heraus und was steht da in der Zeile?

Und wenn Du ntfs-3g eingibst, was wird da als Version angegeben?
Ich bin kein Toilettenpapier-Hamster.
---
Ich bin ein kleiner, schnickeldischnuckeliger Tiger aus dem Schwarzwald.
Alle haben mich ganz dolle lila lieb.
2

#11 Mitglied ist offline   thielemann03 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.350
  • Beigetreten: 28. Januar 19
  • Reputation: 187
  • Geschlecht:Männlich
  • Wohnort:Marksuhl
  • Interessen:Garten, Simson Vogelserie, CAD, Kaninchenzucht(rheinische Schecken)

geschrieben 04. Juli 2020 - 22:36

Danke für den Hinweis.
Niemand ist so gut, wie ich sein könnte.
0

#12 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 05. Juli 2020 - 07:31

Danke.

$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=3997008k,nr_inodes=999252,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=805808k,mode=755)
/dev/sda4 on / type ext4 (rw,noatime)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
pstore on /sys/fs/pstore type pstore (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5805900k)
/dev/sda6 on /home type ext4 (rw,noatime)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
cgroup on /sys/fs/cgroup type tmpfs (rw,relatime,size=12k,mode=755)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/run/cgmanager/agents/cgm-release-agent.systemd,name=systemd)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=805804k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdb2 on /media/D-Konto/Windows 10 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

sdb2 ist die Win10 Partition.



$ ntfs-3g /dev/sdb2
ntfs-3g: No mountpoint is specified.

ntfs-3g 2017.3.23AR.3 integrated FUSE 28 - Third Generation NTFS Driver
		Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2017 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage:    ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options:  ro (read-only mount), windows_names, uid=, gid=,
          umask=, fmask=, dmask=, streams_interface=.
          Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information:  http://tuxera.com



$ ntfs-3g /dev/sdb2 /mnt/windows
Error opening read-only '/dev/sdb2': Keine Berechtigung
Failed to mount '/dev/sdb2': Keine Berechtigung
Please check '/dev/sdb2' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged


Dieser Beitrag wurde von Verprida bearbeitet: 05. Juli 2020 - 07:38

0

#13 Mitglied ist offline   erazor84 

  • Gruppe: aktive Mitglieder
  • Beiträge: 67
  • Beigetreten: 06. September 16
  • Reputation: 16

geschrieben 05. Juli 2020 - 12:13

Deine Windows Platte wird in Linux nur mit RO (ReadOnly) gemountet. Du kannst unter Windows mal probieren in einer Admin CMD "powercfg -h off" einzugeben und dann anschließend das einbinden unter Linux nochmal zu probieren.

Oder im Terminal die Windows Partition manuell mit RW (Read/Write) zu mounten und schauen was passiert, bzw. was die Fehlermeldung dazu ist.

Dieser Beitrag wurde von erazor84 bearbeitet: 05. Juli 2020 - 12:14

PC: AMD Ryzen 3 3200G, 16GB DDR4 3000mhz Corsair, ASUS Prime A320M-K, Manjaro KDE / Win10 PRo. Laptop: Intel Pentium N3710 4GB RAM, Manjaro KDE. MINI-TV-PC: Intel Celeron j4105 - 4GB RAM - Manjaro KDE
2

#14 Mitglied ist offline   Verprida 

  • Gruppe: aktive Mitglieder
  • Beiträge: 232
  • Beigetreten: 13. Juni 16
  • Reputation: 4

geschrieben 06. Juli 2020 - 07:30

Danke @erazor84.

Zitat

Oder im Terminal die Windows Partition manuell mit RW (Read/Write) zu mounten und schauen was passiert, bzw. was die Fehlermeldung dazu ist.


$ sudo mkdir /mnt/ntfs
[email protected]:~
$ sudo mount -t ntfs-3g /dev/sdb2 /mnt/ntfs/
Windows is hibernated, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
Could not mount read-write, trying read-only
[email protected]:~


Wieso Hibernation? Mein Windows habe ich nicht in den Ruhezustand versetzt. Ich habe es normal heruntergefahren. Und Fastboot ist auch deaktiviert.
(?)


Edit:

Zitat

Du kannst unter Windows mal probieren in einer Admin CMD "powercfg -h off" einzugeben ...

Nach dem Durchführen von
powercfg -h off

funktioniert der Schreibzugriff in Linux auf die Windows 10 Partition.

Der Fall ist gelöst. Vielen Dank an Euch!

-----------------------------------------------------------------------

Es reicht also nicht, Windows 10 nicht in den Ruhezustand zu versetzten, sondern man muss zusätzlich auch den Ruhezustand herausnehmen?

Ich bin nicht ganz sicher, aber ich glaube in der Win10 Version vor Version 2004 war die Möglichkeit den Win PC in den Ruhezustand zu versetzen auch aktiviert, nur habe ich (genau wie jetzt auch) nicht davon Gebrauch gemacht. Trotzdem hatte ich keine Probleme mit dem Zugriff auf Win10 aus Linux.

(?)

Dieser Beitrag wurde von Verprida bearbeitet: 06. Juli 2020 - 07:54

0

#15 Mitglied ist offline   erazor84 

  • Gruppe: aktive Mitglieder
  • Beiträge: 67
  • Beigetreten: 06. September 16
  • Reputation: 16

geschrieben 06. Juli 2020 - 14:00

Ja, nur fastboot deaktiviert nicht die kompletten Funktionen für das "Parken" der Partitionen. Nur powercfg -h off schaltet alle Funktionen diesbezüglich aus und erlaubt den Zugriff aus Linux heraus, ohne das du Angst haben musst, Datenverlust zu erleiden bzw. dir die Partition zu schrotten.

Schön das es nun wieder funktioniert :)
PC: AMD Ryzen 3 3200G, 16GB DDR4 3000mhz Corsair, ASUS Prime A320M-K, Manjaro KDE / Win10 PRo. Laptop: Intel Pentium N3710 4GB RAM, Manjaro KDE. MINI-TV-PC: Intel Celeron j4105 - 4GB RAM - Manjaro KDE
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0