WinFuture-Forum.de: Defender <> Thunderbird Problem (IMAP extrem langsam) - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 10: Alle News, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 10 - Special informieren!
Seite 1 von 1

Defender <> Thunderbird Problem (IMAP extrem langsam)


#1 Mitglied ist offline   Rolf-Grisu 

  • Gruppe: Mitglieder
  • Beiträge: 4
  • Beigetreten: 04. Mai 20
  • Reputation: 0

geschrieben 04. Mai 2020 - 15:07

Hallo zusammen,

seit etwa 2 Wochen ist der Zugriff von Thunderbird 68.7.0 auf einen internen IMAP-Server (exim Port 143) extrem langsam. Jeder Programmstart oder Wechsel eines Ordner erzeugt eine Wartepause >30 Sekunden. Schalte ich "Windows Defender Firewall" für "Privates Netzwerk" ab, läuft Thunderbird wieder normal.

Was habe ich bereits getan:
  • Firewall Ausnahme "Alle Programme" in "Allen Netzen" auf "Allen Schittstellen" und "Allen Ports" eingehende und ausgehend eingerichtet -> keine Veränderung
  • "Viren und Bedrohungsschutz" Ausnahme Prozess thunderbird.exe -> keine Verbesserung
  • "Viren und Bedrohungsschutz" Ausnahme Datei "[Pfad]\thunderbird.exe -> keine Verbesserung
  • "Viren und Bedrohungsschutz" Ausnahme Ordner "[Pfad]\Thunderbird -> keine Verbesserung
  • "Viren und Bedrohungsschutz" Ausnahme Ordner "[Pfad]\Thunderbird\Profiles\[Profilname] -> keine Verbesserung
  • Zugriff über eine externe Adresse (DynDNS) mit eingeschaltetem Defender -> funktioniert tadellos
  • "Überwachter Ordnerzugriff" abgeschaltet -> keine Verbesserung
  • Aktivierung des Logfiles der Firewall -> keine besondere Eintragung in pLogfile.txt
  • Thunderbird-Forum recherchiert -> keine Erkenntnis


Innerhalb Thunderbird scheitert bei eingeschalteten Defender bereits die Einrichtung des Kontos (Einstellungen des Servers werden nicht gefunden). Schalte ich Defender ab, klappt das ohne Zeitverzögerung. Schalte ich Defender wieder zu, scheitert auch die Passwort-Überprüfung.

Die Situation ist hier auf allen Win10/Thunderbird-Installationen reproduzierbar. Für Tests wurde ein leeres Mailkonto auf dem Server eingerichtet, d.h. alle Mailordner sind nahezu leer. Die Netzanbindung ist stabil mit >900MBit/Sek (iperf-Test).

Der Mailserver soll "nach außen" wieder geschlossen werden. Aktuell ist Defender für "privaes Netzwerk" dauerhaft deaktiviert (sonst kann man TB nicht verwenden), das soll natürlich auch wieder revidiert werden.

Hat jemand einen Tipp? Vor allem wie ich das weiter diagnostizieren kann?

Danke und Grüße

Rolf
0

Anzeige



#2 Mitglied ist offline   DanielDuesentrieb 

  • Gruppe: aktive Mitglieder
  • Beiträge: 9.146
  • Beigetreten: 15. Januar 06
  • Reputation: 223
  • Geschlecht:Männlich
  • Wohnort:Iserlohn - NRW

geschrieben 04. Mai 2020 - 17:13

Exchange Online / Office365 und weg mit IMAP und Thunderbird und alle sind glücklich. Kostet auch keine Unmengen an Geld. Ich weiß, dass das keine Hilfe ist aber einer der Standards, der sich durchgesetzt hat und der sehr günstig und flexibel ist.
1

#3 Mitglied ist offline   expat 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.269
  • Beigetreten: 23. März 08
  • Reputation: 111
  • Geschlecht:unbekannt
  • Interessen:Ja

geschrieben 04. Mai 2020 - 17:20

Stell doch mal um auf pop und hör nicht auf den MS-Vertreter.
Wer nicht weiß, dass er nicht weiß, glaubt zu wissen. Der Fahrplan der Maßnahmen
0

#4 Mitglied ist offline   Rolf-Grisu 

  • Gruppe: Mitglieder
  • Beiträge: 4
  • Beigetreten: 04. Mai 20
  • Reputation: 0

geschrieben 04. Mai 2020 - 17:24

geht leider nicht. Auf das Postfach sollen mehrere Clients zugreifen können.
0

#5 Mitglied ist offline   DanielDuesentrieb 

  • Gruppe: aktive Mitglieder
  • Beiträge: 9.146
  • Beigetreten: 15. Januar 06
  • Reputation: 223
  • Geschlecht:Männlich
  • Wohnort:Iserlohn - NRW

geschrieben 04. Mai 2020 - 17:25

Zitat

Auf das Postfach sollen mehrere Clients zugreifen können.
Exchange :ph34r:

Bin kein MS-Vertreter. Ich weiß, was funktioniert.

Im Übrigen hat IMAP sicherlich auch einen Sinn im Gegensatz zu POP :lol: - wie Rolf schön erklärt hat. Toller Tipp :thumbup:!

Dieser Beitrag wurde von DanielDuesentrieb bearbeitet: 04. Mai 2020 - 17:27

0

#6 Mitglied ist offline   expat 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.269
  • Beigetreten: 23. März 08
  • Reputation: 111
  • Geschlecht:unbekannt
  • Interessen:Ja

geschrieben 04. Mai 2020 - 17:38

Ich habe 4 E-Mai-Accounts und auf allen Thunderbird mit pop. die frage ich von 5 verschiedenen Computern mit 10 Acoounts ab, wenn ich will. Ich gebe aber zu, dass ich den Unterschied zwischen imap und pop nicht verstanden habe.
Wer nicht weiß, dass er nicht weiß, glaubt zu wissen. Der Fahrplan der Maßnahmen
0

#7 Mitglied ist offline   Rolf-Grisu 

  • Gruppe: Mitglieder
  • Beiträge: 4
  • Beigetreten: 04. Mai 20
  • Reputation: 0

geschrieben 04. Mai 2020 - 18:22

Beitrag anzeigenZitat (DanielDuesentrieb: 04. Mai 2020 - 17:25)

Exchange :ph34r:

Bin kein MS-Vertreter. Ich weiß, was funktioniert.


ich habe selbst ca. 25 Jahre 1st-Level-Support im Umfeld Exchange und MS-Clients (aller Coleur) geleistet. Das war oft kein Zuckerschlecken. Vor allem als die 0-cost-Provider mit Postfachgrößen im GB-Bereich um sich warfen. Vieles was ein Privatmann über seinen Provider umsonst serviert bekam konnte Exchange im Firmen-Umfeld nicht leisten. 2001 bin ich mit meinem pers. Konto auf IMAP umgestiegen und kann auch heute noch problemlos auf Mails aus diesem Zeitraum zugreifen - ohne dass ein Server oder Client in die Knie geht.

Beitrag anzeigenZitat (expat: 04. Mai 2020 - 17:38)

Ich habe 4 E-Mai-Accounts und auf allen Thunderbird mit pop. die frage ich von 5 verschiedenen Computern mit 10 Acoounts ab, wenn ich will. Ich gebe aber zu, dass ich den Unterschied zwischen imap und pop nicht verstanden habe.


M.E. war POP3 immer ein Protokoll zum Downloaden der Mails auf den lokalen PC. Der "Point of Presence" war damit immer ein Einzelgerät. IMAP wurde als Protokoll zu Datenspeicherung auf dem Server später nachgereicht.

Beitrag anzeigenZitat (Rolf-Grisu: 04. Mai 2020 - 15:07)

seit etwa 2 Wochen ist der Zugriff von Thunderbird 68.7.0 auf einen internen IMAP-Server (exim Port 143) extrem langsam.


Das Problem wurde gelöst. Der Mailserver wurde neuerdings mit einer Funktion ident-callback eingerichtet. Weil die Clients nicht korrekt im DNS versorgt waren, verzögerte offensichtlich der Server den Zugriff.
0

#8 Mitglied ist offline   Sarek 

  • Gruppe: aktive Mitglieder
  • Beiträge: 523
  • Beigetreten: 16. April 18
  • Reputation: 158

geschrieben 04. Mai 2020 - 19:27

Beitrag anzeigenZitat (expat: 04. Mai 2020 - 17:38)

Ich habe 4 E-Mai-Accounts und auf allen Thunderbird mit pop. die frage ich von 5 verschiedenen Computern mit 10 Acoounts ab, wenn ich will. Ich gebe aber zu, dass ich den Unterschied zwischen imap und pop nicht verstanden habe.


IMAP erlaubt ein Handeln von verschiedenen PCs etc. aus. D. H. lösche ich an PC A etwas, wird es auf dem Server und auf PC B bis Z ebenfalls gelöscht. Ein Beispiel ist die Redaktions-Emailadresse, die von vielen Redakteuren genutzt wird. Gleiches gilt z. B. auch bei gesendeten Mails. Diese werden synchronisiert in allen angemeldeten Konten in den Gesendet-Ordnern angezeigt.

Bei POP ist es standardmäßig so, dass E-Mails vom Server abgerufen und dort dann "gelöscht" werden. D. H. die sind dann nur auf dem PC, der die E-Mails abgerufen hat.

Bei POP kann man aber auch einstellen, dass eine Kopie der E-Mails auf dem Server gelassen wird (deine Einstellung vermute ich). D. h. ich kann an mehreren Konten die selben Mails auf dem Server abrufen. Was aber nicht geht: Von PC A gesendete E-Mails mit PC B bis Z synchronisieren.

Auch werden bei POP nicht die anderen Konten synchronisiert, wenn z. B. PC B eine E-Mail löscht. Diese wird dann vom PC B und vom Server gelöscht, jedoch nicht von PC A, C usw.

Daher wird bei mehreren Geräten (PC, Laptop, Tablet, Smartphone) IMAP bevorzugt. ->Weniger Arbeit die einzelnen Konten auf den gleichen Stand zu bringen.
_________________________
Arbeitstier 1: Intel Xeon E5450 (4x3 GHz), 16 GB DDR3, 120 GB SSD, 500 GB HDD
Arbeitstier 2: T61 mit T9500 (2x2,6 GHz), 8 GB RAM, 120 GB SSD
Arbeitstier 3: T400 mit X9100 (2x3,06 GHz), 8 GB RAM, 120 GB SSD + 320 GB HDD
Arbeitstier 4: T60 mit T7200 (2x2,0 GHz), 4 GB RAM, 120 GB SSD, 750 GB HDD

Alle mit Windows 10
0

#9 Mitglied ist offline   expat 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.269
  • Beigetreten: 23. März 08
  • Reputation: 111
  • Geschlecht:unbekannt
  • Interessen:Ja

geschrieben 04. Mai 2020 - 19:34

Danke, Sarek.
Wer nicht weiß, dass er nicht weiß, glaubt zu wissen. Der Fahrplan der Maßnahmen
0

#10 Mitglied ist offline   Candlebox 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.818
  • Beigetreten: 08. Juli 04
  • Reputation: 322
  • Geschlecht:Männlich

geschrieben 04. Mai 2020 - 20:21

Naja, bei 2 unbekannten, kenne ich ja nur die doppelte Verifizierung.

Vielleicht liegts ja am Port 143. Geht nicht 993?

Wie sähe das mit einer älteren TB Version aus? Ab welcher Version, wenn ja, träte der Fehler auf und davor nicht.
Wenn ältere Versionen keine Änderung erbringen:
Tritt das Problem erst nach einem Update/Featurupdate auf. wenn ja ab wann. Und dann eben noch ab wann in welcher Kombination.

Somit würde ich mit dem Kreis des Ausschlußes damit anfangen, was in diesen 2 Wochen geändert wurde und erstmal auf diesen Zustand zurückgehen und gegenprüfen - ob der Fehler da jetzt auch auftritt. Tut er das auch, kann man diese Sachen komplett ausschließen.
»Man kann die Realität ignorieren, aber man kann nicht die Konsequenzen der ignorierten Realität ignorieren.« ~Ayn Rand
0

#11 Mitglied ist offline   Rolf-Grisu 

  • Gruppe: Mitglieder
  • Beiträge: 4
  • Beigetreten: 04. Mai 20
  • Reputation: 0

geschrieben 05. Mai 2020 - 06:16

Wie geschrieben: das Problem ist gelöst. Der Mailserver versuchte "rückwärts" den Client zu identifizieren. Die IP-Adresse des PC war dem DNS nicht bekannt, somit lief der Test ins Leere und eine Verzögerung entstand am Server. Kam der Client über einen externen, mit DynDns versorgten Zugang, funktionierte die Identifikation und der Server Verzögerte nicht mehr.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0