WinFuture-Forum.de: Netzwerkprogrammierung - Vernetzwerkt! - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Entwicklung
Seite 1 von 1

Netzwerkprogrammierung - Vernetzwerkt! Problem mit Delphi (Socketkomponenten)


#1 _PelzigesWaldtier_

  • Gruppe: Gäste

geschrieben 09. Mai 2006 - 19:13

Hallo,

ich habe mit mit den Komponenten TClientSocket und TServerSocket ein kleines Progrämmchen geschrieben und natürlich vorher im LAN ausprobiert. Es klappte im Großen und Ganzen ganz gut. Nun habe ich aber einem Freund das Programm gegeben, der leider außerhalb meines LANs sitzt. Jetzt funktioniert das Programm aber nicht wie gewünscht. Ich werde mit Exceptions und asynchronen Fehlern überhäuft.

Wir besitzen beide einen Router. Ist das vielleicht eine Fehlerquelle? Andere Anwendungen funktionieren doch auch so ohne weiteres. Kurz um: "Wo kann mein Problem liegen?" und danach: "Wie kann ich es erreichen, dass nicht jeder Benutzer gleich die Welt auf den Kopf stellen muss, um mein Programm zu verwenden?".

Ich bedanke mich schonmal im Vorraus. :)

Grüße,
PelzigesWaldtier
0

Anzeige

#2 Mitglied ist offline   [U]nixchecker 

  • Gruppe: aktive Mitglieder
  • Beiträge: 347
  • Beigetreten: 17. Mai 05
  • Reputation: 0

geschrieben 09. Mai 2006 - 23:20

Tja ich könnte mir vorstellen, dass du von einem bzw beiden Programmen auf einen Port den das Programm gegenüber geöffnet hat connecten möchtest und du aber im Router kein Portforwarding für diesen Port konfiguriert hast.
0

#3 _PelzigesWaldtier_

  • Gruppe: Gäste

geschrieben 10. Mai 2006 - 15:25

Muss dies nur bei mir oder auch bei meinem Gegenüber aktiviert sein? Und: Warum funktioniert es denn auch nicht über die Standardports wie z.B. 80, die doch eigentlich freigeschaltet sein müssten?
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0