WinFuture-Forum.de: Kernel Nach Debianart Erstellt... - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Linux
Seite 1 von 1

Kernel Nach Debianart Erstellt... ... und zwei kleine Problemchen (die aber nicht stören)

#1 Mitglied ist offline   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.114
  • Beigetreten: 19. August 04
  • Reputation: 474

geschrieben 12. Oktober 2005 - 19:51

Ich habe mir einen Kernel mittels make-kpkg erzeugt, das klappte auch soweit ganz gut, bis auf zwei sachen, wo ich irgendwie nicht so genau weiß, was Sache ist:


Debian 3.1 stable
Kernel 2.6.13.4 von kernel.org

Beim Booten erscheint folgendes (der Rest ist normal):

...
...
umount: devfs: not mounted
mount unknown filesystem type 'devfs'
...
umount: devfs: not mounted
pivot_root: No such file or directory
INIT: version 2.86
null symbol found
null symbol found
...
...


Das System läuft zwar soweit, kann momentan nicht sehen, das irgendetwas fehlen würde. Dennoch würde mich das interessieren, was ich da übersehen habe. Beim orginam Kernel Image 2.6.8-2-k7 erscheinen diese mount/umount Meldungen nicht.

Ich habe schon google gefragt, aber das was ich fand, kann ich nicht wirklich anwenden, da auf dem anderen Rechner kein SATA existiert und ich auch keinen Kernel panic: Attempted to kill init! bekomme.

Falls irgendjemand einen Tipp hat, wäre ich da sehr dankbar.
Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
0

Anzeige

#2 Mitglied ist offline   ph030 

  • Gruppe: aktive Mitglieder
  • Beiträge: 4.675
  • Beigetreten: 14. Juli 04
  • Reputation: 35

geschrieben 12. Oktober 2005 - 20:01

Der Fehler bezüglich "devfs" wird wohl dadurch verursacht, dass mittlerweile "udev" der Standard im Kernel >2.6.13 ist -> folglich wohl ein fehlerhafter Eintrag in der "/etc/fstab".

"Pivot_Root" wird normalerweise genutzt, um verschlüsselte Partitionen beim booten zu entschlüsseln - überprüf mal deine Einstellungen diesbezüglich.

HTH,
ph030
0

#3 Mitglied ist offline   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.114
  • Beigetreten: 19. August 04
  • Reputation: 474

geschrieben 16. Oktober 2005 - 18:53

So, ich habe das ganze jetzt noch einmal versucht und jetzt sind die Meldungen bezüglich devfs weg :blink:

Das ganze lag daran, dass die initrd-tool nicht mehr zu Kernel >=2.6.13 passen, da dieser kein devfs mehr enthält. Da es noch keine saubere Lösung dafür gibt, habe ich die Verweise auf devfs in /usr/share/initrd-tools/init auskommentiert und jetzt ist ruhe.

Die Meldung mit "pivot_root" erscheint auch im original Debian-Kernel 2.6.8-2, also habe ich die nicht weiter verfolg.

Jedenfalls läuft der selbstgebackene Kernel 2.6.13.4 soweit ;)
Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0