WinFuture-Forum.de: Webdavlaufwerk per GPO hinzufügen - Webdav ist aber nicht an der Domän - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Windows Server
Seite 1 von 1

Webdavlaufwerk per GPO hinzufügen - Webdav ist aber nicht an der Domän


#1 Mitglied ist offline   ricky007 

geschrieben 29. Juni 2019 - 21:33

Hallo Leute,

drehe mich hier ein wenig im Kreis. Hab hier ne Domäne und lasse sämtliche Laufwerke per GPO einhängen. Funktioniert auch. Nun gibt es aber auch ein Webdavlaufwerk das zwar Anmeldung mit den gleichen Benutzerdaten hat, aber nicht die Domäne verlangt. Sprich "domain\user" der vordere Teil fällt weg. Wie kann ich das in der GPO eintragen das die Domäne weg gelassen wird? Clients sind Windows10.

Vielen Dank und glg
0

Anzeige



#2 Mitglied ist offline   Stef4n 

  • Gruppe: aktive Mitglieder
  • Beiträge: 155
  • Beigetreten: 20. August 18
  • Reputation: 15

geschrieben 29. Juni 2019 - 22:32

Wenn die Gruppenrichtlinie nur Authentifierung mit domäne\user zulässt kannst du das sicher nicht beeinflussen. Dann könntest du das Webdav Laufwerk sicher per logon skript verbinden und kannst dort die Anmeldedaten manuell hinterlegen wie du es brauchst.
0

#3 Mitglied ist offline   ricky007 

geschrieben 29. Juni 2019 - 22:35

Hallo,

danke für die Antwort, und ja, ich dachte mir schon das dies so ist. Wenn ich im Anmeldescript nur den User hinterlege, wird das Passwort vermutlich nicht vom Login geholt, sprich ich muss es reinschreiben. Gibt es ne Möglichkeit das Passwort auch verschlüsselt zu hinter legen?

glg :)
0

#4 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.725
  • Beigetreten: 20. Juli 07
  • Reputation: 1.086

geschrieben 30. Juni 2019 - 08:34

Was für Zugriffsmöglichkeiten gibt es denn auf den DAV-Server?

Möglicherweise könnt ihr das über (Client-)Zertifikate abwickeln.

Paßwörter in Scripts ist eine ganz schlechte Idee. Insbesondere, da effektiv jeder GPOs lesen kann.


Stefan: Die GPO läßt überhaupt keine Authentifizierung zu. Sie fällt einfach auf die darunterliegende Konfiguration zurück und der SMB-Client versucht immer erstmal die Anmeldung im Kontext des aktuell angemeldeten Benutzers. An der Stelle mittels Kerberos.
Funktioniert diese implizite Authentifizierung nicht, bekommt man keinen Zugriff auf die Freigabe. Explizite Authentifizierung wäre immer per Script abzuwickeln, aber da ist dann halt das Problem des hinterlegten Paßworts.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#5 Mitglied ist offline   ricky007 

geschrieben 30. Juni 2019 - 09:03

Danke RalphS, das hilft mir schon sehr weiter. Sprich wenn man sich bei der Webdavfreigabe mit Kerberos Authentifizieren kann, gehts. Dann wird das meine erste Arbeit sein. Das mit dem Clientzertifikat kann ich immer noch machen.

glg
:)
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0