WinFuture-Forum.de: Neuer Benutzerordner nach Winupdate - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 10: Alle News, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 10 - Special informieren!
Seite 1 von 1

Neuer Benutzerordner nach Winupdate


#1 Mitglied ist offline   Sheriff68 

  • Gruppe: aktive Mitglieder
  • Beiträge: 36
  • Beigetreten: 11. Dezember 07
  • Reputation: 1

geschrieben 29. Mai 2018 - 15:28

Hallo Zusammen

Seit dem Spring Creators Update befindet sich ein weiterer Ordner unter Benutzer.
Dieser Ordner mit dem Namen xxxxx.000 (xxxxx steht für meinen Benutzernamen) beinhaltet alle Unterordner meines eigentlichen Benutzerordners.
Mein eigentlicher Benutzerordner beinhaltet nur noch die Ordner Appdata und Bilder.
Der Ordner Appdata beinhaltet den Unterordner Roaming und dieser die Ordner Microsoft und Prozesslasso.
Im Ordner Microsoft liegt der Ordner Windows und in diesem der Unterordner Startmenü mit seinen Verknüpfungen.
Im Ordner Bilder liegt lediglich die Desktop.ini.

Wie bekomme ich den Ordner xxxxx.000 wieder weg und alles in den eigentlichen Benutzerordner hinein, ohne das Windows ärger macht?

Ich hoffe euch fällt was ein...
0

Anzeige

#2 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.255
  • Beigetreten: 20. Juli 07
  • Reputation: 945

geschrieben 29. Mai 2018 - 15:58

Du läßt es so. Niemand interessiert sich für den Namen des Profilordners, besonders, da dieser eh mit dem Namen des Kontos und nicht unter seinem tatsächlichen Pfad angezeigt wird.


Alles andere riskiert, mehr oder weniger zuverlässig, Dir das Profil zu zerlegen...


.... Was natürlich eine Option ist: einfach einen neuen Benutzer anlegen, der dann auch einen neuen Profilordner bekommt, und dann den alten Benutzer samt Profilordner löschen.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#3 Mitglied ist offline   Sheriff68 

  • Gruppe: aktive Mitglieder
  • Beiträge: 36
  • Beigetreten: 11. Dezember 07
  • Reputation: 1

geschrieben 29. Mai 2018 - 16:51

Hmmm...

Ich fürchte Du hast recht - den Unterordner Prozesslasso konnte ich nach einer Änderung der Programmeinstellungen aus dem eigentlichen Benutzerordner löschen.
Im Ordner Windows befinden sich 555 Dateien, die aber nicht zu sehen sind. Diese sind laut TreeSize im Ordner Recent.
0

#4 Mitglied ist online   DK2000 

  • Gruppe: Administration
  • Beiträge: 18.294
  • Beigetreten: 19. August 04
  • Reputation: 1.023

geschrieben 29. Mai 2018 - 17:34

Ich würde da nicht groß rumbasteln, da xxxx und xxxx.0000 u.U. eine Einheit bilden.

Aus irgendwelchen Gründen konnte das Setup während des Upgrades den ursprünglichen Ordner xxxx offensichtlich nicht vollständig löschen (vor Allem das Verzeichnis an sich) und hat daher den Ordner xxxx.0000 angelegt.

Wenn Du noch die Setupact.log der Upgrades hast, könnte man die mal analysieren und eventuell ermitteln, was das Setup zu dieser Aktion bewogen hat. Die Datei sollte sich in C:\Windows\Panther befinden, da das Upgrade ja eigentlich durchgelaufen ist.

Die saubere Methode, das in Griff zu bekommen, wäre ein Rollback zur vorherigen Windows Version, schauen, was mit dem Profilordner los ist und dann das Upgrade erneut versuchen.

Ansonsten halt neuen Benutzer anlegen, der bekommt auch ein neuen Profilordner, alles, was benötigt wird, aus dem alten Profilordner rüber ziehen und den alten Benutzer samt Ordner löschen.

Wenn Du das jetzt so lässt, dauert es nicht lange, bis einige Anwendungen darüber stolpern werden, da ein Benutzer mit zwei Profilordnern eine ganz schlechte Idee ist.
Nutella hat nur sehr wenig Vitamine.
Deswegen muss man davon relativ viel essen.
1

#5 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.255
  • Beigetreten: 20. Juli 07
  • Reputation: 945

geschrieben 29. Mai 2018 - 23:05

Mh? Wie kommst Du denn darauf?

Jedem Benutzer ist immer genau ein (1) Profilordner zugewiesen. Das ist auch keine Eigenschaft des Dateisystems (ob \Users\<wasweichich> existiert oder nicht) sondern ist eine Eigenschaft der Registry, wo jedem Schlüssel "Benutzer" ein Wert "Profilpfad" zugewiesen ist. Mehrere Schlüssel mit demselben Namen kann man nicht anlegen, also kann man auch nicht mehr als einen Profilordner zuweisen.


Probleme mit andersnamigen Profilordnern gibt es nur, wenn ein Entwickler seine Software -sorry- stümperhaft geschrieben hat und Pfade entweder hart oder falsch referenziert irgendwo reinschreibt, zB in die Registry oder in irgendwelche Konfigurationsdateien der Software.

Dann sollte man aber diese Entwickler kontaktieren, damit die das richtig machen. Profilordner können schnell mal anders heißen (wenn auch nicht so oft in "Privat-Konfigurationen"), sodaß "ja wird schon in C:\Users\%username% liegen" eben NICHT ausreicht.



Zu "erwarten" sind solche Problem aber nicht.

Dieser Beitrag wurde von RalphS bearbeitet: 29. Mai 2018 - 23:05

"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#6 Mitglied ist offline   Sheriff68 

  • Gruppe: aktive Mitglieder
  • Beiträge: 36
  • Beigetreten: 11. Dezember 07
  • Reputation: 1

geschrieben 30. Mai 2018 - 10:55

Also die einzige Datei, die sich jetzt noch im Benutzerordner xxxxx befindet, ist die Recent-Datei.
Die gehört bekanntermaßen zu Windows - und läßt sich nicht löschen.
Was die Benutzerprofile angeht, gibt es nur einen: Nämlich xxxxx.
Seit ich aus C:\Users\xxxxx\Appdata\Roaming den Unterordner Prozesslasso gelöscht und im Prog den Protokollordner nach xxxxx.000 geändert habe, startet ProzessLasso schneller.
Auch Windows startet schneller, seit ich C:\Users\xxxxx\Appdata\Roaming\Microsoft\Windows\ Startmenü gelöscht habe.
In der Registry gibt es noch eine Menge Verweise auf C:\Users\xxxxx. Aber die werden meines Wissens nach eh ignoriert.
0

#7 Mitglied ist online   DK2000 

  • Gruppe: Administration
  • Beiträge: 18.294
  • Beigetreten: 19. August 04
  • Reputation: 1.023

geschrieben 30. Mai 2018 - 11:39

Die sog. Recent-Datei ist keine Daeti, sondern ein Link im Dateisystem, welcher auf C:\Users\<Benutzername>\AppData\Roaming\Microsoft\ Windows\Recent verweist. Und wenn das nicht geändert wurde, dann bleibt das auch so. Den bekommst Du allenfalls mit mklink in der Konsole weg.

Und das sind ja die Probleme, die ich meinte. Prinzipiell hat jeder Benutzer nur ein Profilordner, da hat Ralph schon recht. Aber dank dieses seltsamen Bugs wurde aus unerfindlichen Gründen die Migration von <Benutzername> alt nach <Benutzername> neu nicht abgeschlossen und man verbleibt mit dem Ordnern <Benutzername> und <Benutzername>.000. Letzteren sollte es eigentlich nach erfolgreicher Migration überhaupt nicht mehr geben.

Daher wurde auch nichts in der Registry angepasst. Unzählige Pfadangaben zeigen immer noch auf C:\Users\<Benutzername>\~. Wenn irgendwer darauf zugreift, ist man wieder in C:\Users\<Benutzername>\~ und nicht in C:\Users\<Benutzername>.000\~. Und die werden auch nicht ignoriert. Nur solange da keiner zugreift, interessiert das auch Windows nicht wirklich.

Das ist wie mit Deinem ProzessLasso. Das hatte einen Verweis auf ProzessLasso C:\Users\<Benutzername>\~ und hatte dadurch Probleme. Erst nach manueller Änderung auf C:\Users\<Benutzername>.000\~ ging es wieder problemlos. Und das betrifft alle Registryeinträge, die noch auf C:\Users\<Benutzername>\~ verweisen. Solange keiner zugreift, interessiert es keinen, aber wenn, dann kommt es zu seltsamen Nebeneffekten.

Wie gesagt, dass ist ein Bug. Die Migration des Profilordners wurde nicht abgeschlossen, aber das hat das Setup nicht weiter gestört und hat weiter gemacht.
Nutella hat nur sehr wenig Vitamine.
Deswegen muss man davon relativ viel essen.
0

#8 Mitglied ist offline   Sheriff68 

  • Gruppe: aktive Mitglieder
  • Beiträge: 36
  • Beigetreten: 11. Dezember 07
  • Reputation: 1

geschrieben 30. Mai 2018 - 12:30

So.... Ich hab jetzt mal im Adminmodus den Inhalt von C:\Users\ gelöscht und er bleibt auch nach einem Neustart leer. Den leeren Ordner lass ich erstmal bestehen und schau mal, ob es im Laufe der nächsten Tage Probleme gibt. Sollte ich mich entschließen den Ordner komplett zu entsorgen, teile ich euch das Ergebnis mit. Bis dahin einstweilen vielen Dank für euer Feedback.
0

#9 Mitglied ist offline   Sheriff68 

  • Gruppe: aktive Mitglieder
  • Beiträge: 36
  • Beigetreten: 11. Dezember 07
  • Reputation: 1

geschrieben 31. August 2018 - 16:59

Hallo zusammen

Ich habe endlich Zeit gefunden mich nochmal mit dem Benutzerprofilordner zu befassen.
Der alte Profilordner ließ sich problemlos löschen... Probleme sind seitdem nicht aufgetreten.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0