WinFuture-Forum.de: Mit Pi-Hole unterschiedliche Browser Performance - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Netzwerk
Seite 1 von 1

Mit Pi-Hole unterschiedliche Browser Performance


#1 Mitglied ist offline   Vagabund 

  • Gruppe: aktive Mitglieder
  • Beiträge: 431
  • Beigetreten: 18. März 05
  • Reputation: 0

  geschrieben 06. Mai 2018 - 08:38

Hallo zusammen,

ich nutze in meinem Heimnetz Pi-Hole auf einem RaspberryPi3 als Add-Blocker. Dies funktioniert auch recht gut. Damit stelle ich aber beim Aufruf einiger Seiten einen erheblichen Performance Abfall fest, je nachdem welchen Browser man unter Windows nutzt. Ich nutze eigentlich immer den Firefox, bin aber inzwischen etwas genervt auf den Edge gewechselt. Wenn ich beispielsweise die Seite https://stadt-bremerhaven.de/ im Firefox aufrufe, dauert dies immer ca. 5 Sekunden bis sich überhaupt etwas tut. Dies ist nicht durchgägnig, manche Seiten öffnen sofort, z.B. https://www.youtube....om/?hl=de&gl=DE . Das hinzufügen zur Whitelist in Pi-Hole bringt keine Verbesserung. Mit dem Edge Browser unter Win 10 1803 (oder auch davor), geht jeder Aufruf immer rasend schnell. Wenn ich Pi-Hole temporär deaktivieren, gehen beide Browser schnell. Ich möchte eigentlich weder auf Pi-Hole noch auf Firefox verzichten. Gibt es eine Erklärung warum sich die Browser hier unterschiedlich verhalten, und eventuell eine Lösung? Danke schonmal.

Gruß
Michael

Dieser Beitrag wurde von Vagabund bearbeitet: 06. Mai 2018 - 08:39

0

Anzeige



#2 Mitglied ist offline   aabbcc__123 

  • Gruppe: aktive Mitglieder
  • Beiträge: 26
  • Beigetreten: 30. März 18
  • Reputation: 3

geschrieben 06. Mai 2018 - 09:10

Ich habe zwei Vorschläge für Dich:
1.) Hast Du es mal probiert, ob das Problem auch mit deaktivierten Add-ons bestehen bleibt? Am besten einfach den Firefox im abgesicherten Modus starten (https://support.mozi...sicherter-modus) und dann ausprobieren. Evtl. gibt es da Add-ons, die sich mit Pi-Hole beissen.
2.) Installiere Firefox neu. Ich nutze auch fast ausschliesslich den Firefox, aber von seiner Stabilität bin ich auch nicht so richtig überzeugt. Manchmal macht Firefox schon merkwürdige Sachen.
0

#3 Mitglied ist offline   Vagabund 

  • Gruppe: aktive Mitglieder
  • Beiträge: 431
  • Beigetreten: 18. März 05
  • Reputation: 0

geschrieben 06. Mai 2018 - 09:51

Windows 10 hatte ich per Clean Install neu installiert, ebenso Firefox. Addons nutze ich keine. Es handelt sich bei Firefox um eine frische Installation. Daran sollte es also nicht liegen. Ich vermute das liegt irgendwie daran wie die Browser Seiten anfordern, und warten wenn keine Antwort kommt. Hier im Falle von Werbeseiten.
Übrigens, wenn ich die oben erstgenannte Seite aufrufe, sehe ich unten links im Browser die ganzen geblockten Seiten die einer nach der anderen aufgerufen wird. Die eigentliche Seite wird aber erst nicht aufgebaut.

Dieser Beitrag wurde von Vagabund bearbeitet: 06. Mai 2018 - 09:54

0

#4 Mitglied ist offline   ndeath 

  • Gruppe: aktive Mitglieder
  • Beiträge: 547
  • Beigetreten: 10. September 07
  • Reputation: 9

geschrieben 06. Mai 2018 - 23:24

Hallo!

Ich kann das was du - Vagabund - schreibst bestätigen - allerdings nur unter Windows.
Der Firefox unter Linux (verschiedene Distributionen) ist immer schnell.

Ich meine auch, dass bei *einem* Win-Notebook unseres Haushalts die Firefox Geschwindkeits-Problematik nicht besteht, bei meinem Desktoprechner allerdings massiv.

Ich kann mir keinen Reim draus machen, wollte mit meinem Post nur sagen, dass es wohl kein Einzelphänomen ist.
0

#5 Mitglied ist offline   guardian@geißenweide 

  • Gruppe: aktive Mitglieder
  • Beiträge: 165
  • Beigetreten: 20. Dezember 05
  • Reputation: 9

geschrieben 07. Mai 2018 - 11:00

Hallo,

auch ich setze zu Hause piHole ein und habe keine Probleme unter Windows und verschiedenen Browsern.

Eventuell macht es Sinn die Konfiguration (piHole, Windows, Browser) abzugleichen? Mein Heimnetz / PiHole arbeitet z.B. nur mit IPv4 (als DHCP-Server).

Nachtrag:
Vielleicht auch einen Blick wert: https://discourse.pi...-to-fix-it/6945

Dieser Beitrag wurde von guardian@geißenweide bearbeitet: 07. Mai 2018 - 11:32

"Es gibt keine Zauberei – nur Illusion. Die Dinge verändern sich nur, wenn wir sie verändern. Aber man muss es geschickt tun – im Verborgenen. Dann wirkt es wie Zauberei."
0

#6 Mitglied ist offline   Vagabund 

  • Gruppe: aktive Mitglieder
  • Beiträge: 431
  • Beigetreten: 18. März 05
  • Reputation: 0

geschrieben 13. Mai 2018 - 07:32

Kleines Update! Inzwischen gibt es ja die Version 60 vom Firefox, habe damit also einen weiteren Versuch gestartet. Basis war hier wieder ein System auf dem bisher kein Firefox installiert war. FF60 also installiert, und die oben erwähnte Seite aufgerufen. Leider gab es wieder keine Veränderung, der Aufruf dauert immer ca. 5 Sekunden. Der Vorschlag von Guardian die ipV6 Einstellung im PiHole zu deaktivieren hat keine Veränderung gebracht. Bin dann aber mal den anderen Weg gegangen, und habe in der Fritzbox ipV6 aktiviert, und ebenso im Pi-Hole. Jetzt kann ich keine Verzögerung mehr feststellen :D . Als Anbieter nutze ich übrigens Congstar ADSL mit folgenden DNS-Server:
217.237.148.102
217.237.151.115
Eventuell weiß jemand ob hier ein zusammenhang besteht, und kann diesen erklären.

Nachtrag: Leider muß ich sagen das es doch nicht geholfen hat. Ich hatte vergessen den ipV6 DNS Server in der Fritzbox zu übernehmen. Das hatte dazu geführt das der Pi-Hole nicht genutzt wurde, und alles durchgelassen wurde. Nach dem eintragen der ipV6 Adresse des RaspberryPi geht es gefühlt noch etwas langsamer.

Gruß
Michael

Dieser Beitrag wurde von Vagabund bearbeitet: 13. Mai 2018 - 10:34

0

#7 Mitglied ist offline   guardian@geißenweide 

  • Gruppe: aktive Mitglieder
  • Beiträge: 165
  • Beigetreten: 20. Dezember 05
  • Reputation: 9

geschrieben 13. Mai 2018 - 18:16

Wie schon oben geschrieben, verwende ich meinen Router nicht als DHCP-Server und muss daher auch keinen DNS-Server eintragen.

Probiere das Ganze doch mal so:
- nur IPv4 nutzen (auch bei mir ist mit aktiviertem IPv6 alles um einiges langsamer),
- DHCP-Server der FB deaktivieren, im PiHole aktivieren,
- Upstream DNS Servers vom PiHole sind bei mir auf OpenDNS eingestellt.

Weitere Möglichkeit wäre unter Windows IPv4 manuell einstellen.
"Es gibt keine Zauberei – nur Illusion. Die Dinge verändern sich nur, wenn wir sie verändern. Aber man muss es geschickt tun – im Verborgenen. Dann wirkt es wie Zauberei."
0

#8 Mitglied ist offline   Vagabund 

  • Gruppe: aktive Mitglieder
  • Beiträge: 431
  • Beigetreten: 18. März 05
  • Reputation: 0

geschrieben 14. Mai 2018 - 16:56

Hallo guardian, danke für deinen Vorschlag, aber ich verstehe nicht was das deaktivieren von DHCP in der FB da bringen soll. Außerdem verlangt mein Logitech Harmony Hub DHCP, diese Option fällt also flach. Ich möchte auch nochmal erwähnen, das Microsoft Edge/Google Chrome/iPad Safari keine Gedenksekunden benötigen um die Seiten aufzurufen, nur FF macht hier etwas anders als die anderen. DNS Server nutze ich die von Congstar vorgegebenen, da diese kleinere Pingzeiten haben als die Server von Google, OpenDNS ist da nochmal langsamer. IPv6 habe ich in der FB und im Pi-Hole wieder deaktiviert, hat ja sowieso nichts gebracht, und wird von Congstar nicht angeboten.
0

#9 Mitglied ist offline   schmiddi19xx 

  • Gruppe: Mitglieder
  • Beiträge: 1
  • Beigetreten: 30. Mai 18
  • Reputation: 0

geschrieben 30. Mai 2018 - 00:59

hallo,

hab das gleiche problem wie du. hab die hilfeforen von pi hole durch. nix hat geholfen. nur ipv6 deaktiveren is die lösung wenn du nen schnellen firefox haben willst. scheint aber mit FF zusammenzuhängen. auf dem handy alles top. microsoft edge funzt auch wunderbar. nur der FF spackt rum. entweder nutzt du mit ipv6 den abdlock dazu( dann gehts auch) oder deaktivierst das was für mich als 1&1 kunde keine option is, da ich dual stack habe.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0