WinFuture-Forum.de: HP Compaq Pro 6300 MT - von NVMe booten - WinFuture-Forum.de

Zum Inhalt wechseln

Alle Informationen zum Thema Windows 7 in unserem Special. Windows 7 Download, FAQ und neue Funktionen im Überblick.
Seite 1 von 1

HP Compaq Pro 6300 MT - von NVMe booten HP Compaq Pro 6300 MT - von NVMe booten - wie?


#1 Mitglied ist offline   Mondragor 

  • Gruppe: aktive Mitglieder
  • Beiträge: 366
  • Beigetreten: 22. Februar 12
  • Reputation: 42

geschrieben 12. Februar 2018 - 09:08

Hallo allerseits,

Ich habe einen HP Compaq Pro 6300 MT.
Für eine Neuinstallation habe ich noch eine PCIe-Karte mit M.2-Anschluss, darauf eine Samsung XP941.
Im laufenden Windows 7 wird diese problemlos erkannt, allerdings kann ich nicht windows 7 neu darauf installieren. Das löschen der darauf vorhandenen Partitionen während der Installation war zwar möglich,
aber das installieren von Windows 7 oder das neu Anlegen von Partitionen nicht. Unten drunter stand dann
der Vermerk, dass das wahrscheinlich im Bios nicht unterstützt wird.
Ein Bios-Update auf die aktuellste Version habe ich bereits gemacht.
Leider habe ich danach keine weitere Option mehr gefunden, um das im Bios freizuschalten und weiß auch ehrlich
gesagt nicht, wonach ich da suchen müsste.
Es ist ja möglich, Windows bei der Installation per Datenträger Treiber für bestimmte Hardware zuladen zu lassen. Die Frage ist nun, was für Treiber dafür notwendig sind.

Wäre über jede Hilfe dankbar!

Grüße,
Mondragor
0

Anzeige



#2 Mitglied ist offline   da^saber 

  • Gruppe: aktive Mitglieder
  • Beiträge: 602
  • Beigetreten: 24. Juli 11
  • Reputation: 47

geschrieben 12. Februar 2018 - 12:27

Ich könnt mir vorstellen das der den PciE-Boot noch gar nicht beherrscht.

Welchen Adapter benutzt du denn ?
Hab bisher keine sonderlich guten Erfahrungen machen können mit so 08/15-Adaptern.
Einzig der von ASUS mitgelieferte hat bisher immer tadellos funktioniert.

Eingefügtes Bild
0

#3 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 18.340
  • Beigetreten: 19. August 04
  • Reputation: 1.033

geschrieben 12. Februar 2018 - 13:36

Das müsste man zuerst sicherstellen, ob der Rechner überhaupt davon booten kann. Das ist bei älteren Geräten nicht immer der Fall. Meisten benötigt man einen Adapterkarte, welche eine entsprechende BIOS Erweiterung mit sich bringt.

Erscheint denn die SSD im BIOS über die Bootauswahl?

Desweiteren Windows 7 SP1 unterstützt von Haus aus kein NVMe. Hier müsste man zwei Sachen machen, entweder oder:

https://support.micr...indows-7-and-wi

Dieses Update muss man sowohl in die Boot.wim als auch in die Install.wim integrieren, damit Windows 7 SP1 mit NVMe etwas anfangen kann.

Alternativ muss man den NVMe Treiber von Samsung organiesieren und diesen dann während der Installation verwenden. Allerdings für die XP941 finde ich da auf die Schnelle keinen.

Und hier bin ich schon etwas verwundert. Normaler Weise sieht man die NVMe SSD unter Windows 7 überhaupt nicht, solange nicht das Update integriert wurde oder der passende Treiber geladen wurde.

Da Du die SSD im Setup und im laufenden Betrieb offensichtlich siehst, lässt den Schuss zu, dass der NVMe Support in der DVD bereits integriert wurde oder, was auch wahrscheinlich ist, die SSD läuft im AHCI Modus.

Und so, wie ich das gerade lese, unterstützt die XP941 auch nur AHCI. Würde auch erklären, warum ich keine Treiber finde.

Bleibt also nur das Bootproblem übrig. Und wie schon gesagt, ohne entsprechenden BIOS Support wird das nichts.
Nutella hat nur sehr wenig Vitamine.
Deswegen muss man davon relativ viel essen.
0

#4 Mitglied ist offline   Mondragor 

  • Gruppe: aktive Mitglieder
  • Beiträge: 366
  • Beigetreten: 22. Februar 12
  • Reputation: 42

geschrieben 12. Februar 2018 - 13:56

Hallo und danke für die Antwort.

Der Rechner und Windows erkennen die Karte / M.2 SSD aber ich kann darauf nicht installieren, sagt windows.
Das Gerät ist im Bios nicht als Bootoption auswählbar, das stimmt.
Wenn ich aber ein Windows starte, auf ner anderen SATA- SSD / HDD, kann ich von dort ohne zusätzliche Treiber auf die NVMe-SSD schreiben.
Ich hatte bereits eine Installer-usb-Anpassung mit den USB3-Treibern und dem Treiber für die SSD gebastelt, hat auch alles geklappt aber trotzdem kann windows darauf nicht installiert werden...
Angezeigt wird sie, Partitionen löschen ging auch.
Dann habe ich den Samsung-Teiber nochmal manuell von USB dazu geladen, aber auch das half nix.

Dementsprechend ist vermutlich einfach die Hardware / das Mainboard zu alt, sodass das Booten von diesem Datenträger an sich nicht unterstützt wird, denke ich dann mal.
Bios-Update hab ich schon gemacht.
Noch jemand eine Idee?

@da^Saber

Ich nutze den Adapter von DeLock.
Wir nutzen die in allen möglichen älteren MacPros, die schon PCIe 3 haben. Da musste man gar nix machen, nur Karte rein und lief. Auf wie Weise konnten wir die deutlich beschleunigen und viele sind dann irgendwann den Grafikkarten-Tot gestorben. Die rendern jetzt noch 3D per CPU...
Da dachte ich, das ginge bei PCs auch ^^ Schließlich sind die ersten Macs, auf denen das läuft, noch älter als der PC.

Grüße,
Mondragor

Dieser Beitrag wurde von Mondragor bearbeitet: 12. Februar 2018 - 13:57

0

#5 Mitglied ist offline   DK2000 

  • Gruppe: Administration
  • Beiträge: 18.340
  • Beigetreten: 19. August 04
  • Reputation: 1.033

geschrieben 13. Februar 2018 - 15:21

Beitrag anzeigenZitat (Mondragor: 12. Februar 2018 - 13:56)

Der Rechner und Windows erkennen die Karte / M.2 SSD aber ich kann darauf nicht installieren, sagt windows.

Du könntest schon installieren, nur benötigst Du dann eine zweite SATA-SSD/HDD, auf welche Windows seinen kleine Systempartition schreiben kann (Bootmanager und so). Die Startpartition mit der eigentlichen Windows Installation kann dann auch auf die M.2 SSD.

Beitrag anzeigenZitat (Mondragor: 12. Februar 2018 - 13:56)

Das Gerät ist im Bios nicht als Bootoption auswählbar, das stimmt.

Ja und das erkennt das Windows Setup. Dann kommt dann diese tolle Meldung, dass das Booten u.U. vom System nicht unterstützt wird. Das macht er auch, wenn die Platte zwar erkannt wird, aber im BIOS Bootmanager nicht als Bootlaufwerk eingetragen ist.

Beitrag anzeigenZitat (Mondragor: 12. Februar 2018 - 13:56)

Wenn ich aber ein Windows starte, auf ner anderen SATA- SSD / HDD, kann ich von dort ohne zusätzliche Treiber auf die NVMe-SSD schreiben.

Das ist so oder so witzlos, da die XP941 kein NVMe unterstützt. Das kam bei Samsung erst später. Die SSD läuft nur im AHCI Modus und ggf. noch im IDE Modus.

Daher gibt es auch für die Platte keine NVMe Treiber von Samsung. Den Treiber, welche Du da vermutlich verwendest, ist nur für die 950er und 960er Serie gedacht.

Beitrag anzeigenZitat (Mondragor: 12. Februar 2018 - 13:56)

Dementsprechend ist vermutlich einfach die Hardware / das Mainboard zu alt, sodass das Booten von diesem Datenträger an sich nicht unterstützt wird, denke ich dann mal.

So sieht es leider aus. Das BIOS kann die M.2 SSD als Bootlaufwerk nicht bereitstellen, da die entsprechende Unterstützung fehlt.

Beitrag anzeigenZitat (Mondragor: 12. Februar 2018 - 13:56)

Wir nutzen die in allen möglichen älteren MacPros, die schon PCIe 3 haben. Da musste man gar nix machen, nur Karte rein und lief.

Die MacPros kommen ja eigentlich alle schon mit EFI daher und hier sieht das ja schon alles wieder anders aus. Schätzungsweise wäre es auch kein Problem, beim PC von der M.2 SSD zu booten, wenn der PC anstelle des eingeschränkten BIOS UEFI verwenden würde.

Wie gesagt, wenn Du noch irgendwo eine kleine SATA SSD/HDD rumfliegen hast, dann einfach diese mit einbauen und im BIOS als Bootlaufwerk festlegen. Das Windows Setup legt dann dort seine Systempartition an, währen man das eigentlich Windows auch auf einem anderen Laufwerk installieren kann, in Deinem Falle dann die M.2 SSD.
Nutella hat nur sehr wenig Vitamine.
Deswegen muss man davon relativ viel essen.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0