WinFuture-Forum.de: ADATA SSD lassen sich nicht Flashen (FW Update) - WinFuture-Forum.de

Zum Inhalt wechseln

Alle Informationen zum Thema Windows 7 in unserem Special. Windows 7 Download, FAQ und neue Funktionen im Überblick.
Seite 1 von 1

ADATA SSD lassen sich nicht Flashen (FW Update)


#1 Mitglied ist offline   Hobbyperte 

  • Gruppe: aktive Mitglieder
  • Beiträge: 178
  • Beigetreten: 05. April 08
  • Reputation: 4

geschrieben 03. Januar 2016 - 08:06

Es geht um zwei SSD von ADATA, Modell SP900 (ASP900S3 128GM). Auf beiden ist die Firmware 5.0.2a drauf und sollen nun auf den aktuellen Stand 5.8.2a gebracht werden. Ja ich weiß das dabei sämtliche Daten verloren gehen, jedoch sind die Partitionen eh schon gelöscht, die Laufwerke möchte ich vorbereiten für die weitere Verwendung ...

Das Mainboard: Intel DZ77GA-70K, enthält den "Intel 7 Series / C216 Chipset Family SATA AHCI Controller" und zusätzlich einen "Marvell 91xx SATA 6G Controller" onboard. Das OS: Windows 7 Ultimate 64 bit.

Zunächst versuchte ich das Update mit dem SF Fieldupdater 1.3.6, der mit den Update-Files mitgeliefert wird. Der erkannte die Laufwerke nicht, egal an welchem der beiden Controller sie angeschlossen werden. Alternativ kann die "SSD Toolbox" von ADATA das Update durchführen, diese erkennt die Laufwerke, jedoch nur am Intel-Controller (AHCI Modus) und sagt "das Firmware Update sei nicht im IDE/Raid Modus möglich" die Meldung erscheint auch dann wenn sich der Controller bereits im AHCI Modus befindet. Das Tool flasht dann auch nicht und bringt im Anschluß die Meldung das die aktuellste Firmware bereits vorhanden sei... nach dem Aus- und wieder Einschalten des PC liest das Tool dann natürlich auch wiederum die Version 5.0.2a aus. Wie auch Crystal Disk Info ...

Der Fieldupdater erkennt die SSD am Intel-Controller, wenn dieser in den IDE Modus umgeschaltet wurde. Bei einem der beiden SSD schien das Update dann auch zu gelingen, was durch einen grünen Haken angezeigt wurde. Bei der zweiten SSD kommt nach einer gewissen Zeit ein rotes Kreuz. Bei beiden SSD wird jedoch nicht wirklich geflasht! Crystal Disk liest nach wie vor 5.0.2a aus ...

Schlussendlich habe ich ein Diskimage von meiner ganz frischen Windows-Installation auf eine leere Festplatte wieder hergestellt und damit erneut alle Versuche mit den selben Ergebnissen wiederholt. Es kann also nicht an irgendwelcher Software liegen die sich auf meinem Arbeitssystem befindet. Auch habe ich die Intel und Marvel- SATA-Treiber auf dem System der Testfestplatte gelöscht und Windows seine Microsoft Treiber installieren lassen, jeweils für AHCI oder eben IDE-Modus ... auch damit erhalte ich die bereits bekannten Ergebnisse.

Schlussendlich änderte es auch nichts, das Hotplugging für den SATA-Port an welchem geflasht werden soll zu deaktivieren.

Nun bin ich ziemlich ratlos was man noch machen kann? Eine Anfrage bei ADATA funzt bei mir irgendwie nicht, kann da verschiedene Pflicht-Optionen wie z.B. das Herkunftsland nicht Auswählen, weil die Ausahl keine wählbaren Optionen enthalten. Auch wenn Adblocker und Ghostery deaktiviert sind ... Mit dem IE das selbe Problem! Die wollen wohl gar keinen Kundensupport geben ...

Hat irgendwer eine Idee warum das mit dem Flashen bei mir nicht klappen will? Was man noch Ausprobieren könnte? Abgesehen von der Verwendung eines anderen PC ... vielleicht übersehe ich irgendwas? Eventuell weitere BIOS-Optionen ?
0

Anzeige

#2 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 8.249
  • Beigetreten: 20. Juli 07
  • Reputation: 943

geschrieben 03. Januar 2016 - 09:49

Hast Du schon mal geschaut, ob es was hilft, wenn Du eine davon abklemmst? Nicht daß sich die Erkennungsroutine daran stört, daß mehr als eine davon verbaut ist.

- Ansonsten wunder ich mich grad über "dabei gehen alle Daten verloren". :huh: Echt? Das dürfte eigentlich nicht sein. Von einem Speichermedium würde ich jetzt tatsächlich *erwarten*, daß die Daten da erhalten bleiben (haben sie zumindest bei meiner Intel SSD und bei einer betroffenen WD-Festplatte).

- Wie sieht es denn mit einem startbaren Medium aus, von wo aus die Firmware ggf. geflasht warden könnte? Egal ob auf Linux- oder (Free-)DOS-Basis, soweit es der Hersteller anbietet?

- Und schließlich: gibt es irgendeinen Grund fürs Firmware-Update? Und bist Du auch sicher, daß die neue Firmware auch genau zur SSD paßt? Nicht daß Du jetzt irgendwie die neue Firmware durch die Hintertür da reinschiebst und hinterher Deine SSDs als Briefbeschwerer verwenden mußt, weil sie sich zu nix anderem mehr eignen.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#3 Mitglied ist offline   Hobbyperte 

  • Gruppe: aktive Mitglieder
  • Beiträge: 178
  • Beigetreten: 05. April 08
  • Reputation: 4

geschrieben 03. Januar 2016 - 18:49

Beitrag anzeigenZitat (RalphS: 03. Januar 2016 - 09:49)

Hast Du schon mal geschaut, ob es was hilft, wenn Du eine davon abklemmst? Nicht daß sich die Erkennungsroutine daran stört, daß mehr als eine davon verbaut ist.

Mein Gehäuse hat eine integrierte "Disk Station" wo man 2,5" oder 3,5" SATA-Platten lose reinstecken kann, diese ist intern an einem der Ports vom Intel-Controller.
Die beiden Ports des zusätzlichen Marvel-Controllers sind mit Wechselschächten verbunden, leider keine wo man die Disks einfach lose rein stecken kann, sondern mit einem Schuber mit dem sie jeweils erst verschraubt werden müssen.
Für meine Versuche war insgesamt jeweils nur eine der fraglichen SSD am System.

Beitrag anzeigenZitat (RalphS: 03. Januar 2016 - 09:49)

- Ansonsten wunder ich mich grad über "dabei gehen alle Daten verloren". :huh: Echt? Das dürfte eigentlich nicht sein. Von einem Speichermedium würde ich jetzt tatsächlich *erwarten*, daß die Daten da erhalten bleiben (haben sie zumindest bei meiner Intel SSD und bei einer betroffenen WD-Festplatte).

Jedenfalls steht das so in der beigefügten Anleitung zum Flashen der ADATA-SSDs und ich habe das auch so in Erinnerung, damals beim Update von 5.0.1 auf 5.0.2a ... ein Backup schadet ja außerdem nie. In dem Falle jetzt aber überflüssig, weil ...

Beitrag anzeigenZitat (RalphS: 03. Januar 2016 - 09:49)

- Und schließlich: gibt es irgendeinen Grund fürs Firmware-Update? Und bist Du auch sicher, daß die neue Firmware auch genau zur SSD paßt? Nicht daß Du jetzt irgendwie die neue Firmware durch die Hintertür da reinschiebst und hinterher Deine SSDs als Briefbeschwerer verwenden mußt, weil sie sich zu nix anderem mehr eignen.

Der Grund eben der ist, das die SSD's gerade "frei" geworden sind und bevor ich die für weitere Zwecke benutze, soll das Update gleich durchgeführt werden. So ein Update, ist gerade bei SSD's in sich begründet, da bei den Dingern in den letzten Jahren immer wieder mal Bugs und Inkompatibilitäten Aufgetreten sind und nicht zuletzt auch die Performance oder gar die Lebensdauer mit Updates häufig gesteigert wurde. Warum also kein Update machen? Nur weil sie auch ohne Funktionieren (never change ...) ist in dem Falle kein Argument.

Die passende Firmware ... ja das ist bei ADATA wirklich kompliziert gemacht. Man startet dieses FieldUpdater Tool und - sofern der eine ADATA SSD erkennt - bekommt dann eine Disk-Signatur angezeigt. Die mitgelieferten Files haben entsprechende Dateinamen, man muss dann selber die Datei mit dem der Signatur entsprechenden Dateinamen auswählen und dann geht es los ... na jedenfalls sollte es das. Bin also 1000% sicher das ich die richtigen Files habe.

Beitrag anzeigenZitat (RalphS: 03. Januar 2016 - 09:49)

- Wie sieht es denn mit einem startbaren Medium aus, von wo aus die Firmware ggf. geflasht warden könnte? Egal ob auf Linux- oder (Free-)DOS-Basis, soweit es der Hersteller anbietet?

ADATA stelle nur den FieldUpdater, den man ohne Installation unter Windows startet zur Verfügung, oder ein Exemplar für Linux (welches ich nun noch nicht Ausprobiert habe, da solche Linux-Experimente für mich dann immer einen Staatsakt gleich kommen). Oder man kann mit der neuerdings verfügbaren SSD-Toolbox flashen, die muss Installiert werden und steht nur für Windows zur Verfügung. Ein simples Tool für DOS haben die leider nicht im Programm.


Tja - die Fragen waren sicherlich berechtigt. Mir kam im laufe des Tages noch in den Sinn, das ich den Raid-Modus des Intel-Controllers in Verbindung mti dem FieldUpdater noch nicht probiert habe.
Mir geht aber auch nicht aus dem Kopf, das die SSD-Toolbox im AHCI-Modus drüber meckert, das Flashen im IDE und Raidmodus nicht möglich sei ... kann es sein das das Tool den Modus falsch detektiert? Das da vlt. im Windows irgendwas verbogen ist? Aber das ist doch eine ganz frische, saubere installations-Konserve, da kann doch noch gar nix "verpfuscht" sein ... verstehe das alles nicht!

Na wenigsten ist es nicht eilig, mit dem Projekt wofür die beiden SSD künftig vorgesehen sind, dauert es noch ein paar Wochen ...

Achso - noch 'ne Idee von mir. Einer der Gründe warum ich letztlich auf die saubere Installation zurück gegriffen habe, war auch das da kein Virenscanner oder irgendwas ähnliches drauf ist! Es soll ja Software geben, die zum Schutz vor Schädlingen das Flashen von Hardware verhindert ... womöglich gibt es auch solche BIOS-Optionen? Werde ich gleich mal nachschauen ...

Update:
Nein im BIOS gibt es bei mir keine solche Option.

Der Raid-Mode funktioniert gar nicht. Da bei diesem der Intel-Controller im Gerätemanager bei den SCSI-Speichercontrollern erscheint, wie auch der Marvel-Controller. Das SSD Tool findet dann gar nichts und startet überhaupt nicht.

So dann nochmal das SSD-Tool absichtlich benutzt während der IDE Modus aktiviert war. Und es erkennt und flasht vermeintlich eine der SSD's, nach dem Neustart des PC wird aber wiederum die alte FW angezeigt! Wäre ja auch zu schön gewesen ...

Habe auch nochmal auf der Webseite nachgesehen, da gibt es zwei neuere Varianten der SP900 SSD's. Für die eine gibt es gar kein FW-Update für die andere eine Version 6.xx, eine explizit andere Firmware als für die vorliegenden "alten" Modelle! Habe also schon die richtigen Sachen runtergeladen.

Dieser Beitrag wurde von Hobbyperte bearbeitet: 04. Januar 2016 - 08:19

0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0