WinFuture-Forum.de: Frage zu Java SE Runtime? - WinFuture-Forum.de

Zum Inhalt wechseln

Windows 8: Alle News, ein umfangreiches Windows 8 FAQ, der Download sowie zahlreiche Screenshots und Videos zum neuen Betriebssystem von Microsoft. Jetzt im WinFuture Windows 8 Special informieren!
Seite 1 von 1

Frage zu Java SE Runtime?

#1 Mitglied ist offline   Scoty30 

  • Gruppe: aktive Mitglieder
  • Beiträge: 225
  • Beigetreten: 20. Dezember 04
  • Reputation: 1

  geschrieben 07. September 2014 - 06:34

Ich verwende nach wie vor noch die Java SE Runtime 7.x aber es gibt ja auch schon eine weile die 8er und 9er wobei alle 3 Versionen immer Updates bekommen. Allerdings scheint mir das die 7er immer weniger Updates bekommt und die 8er und 9er regelmäßig. Hat es einen Nachteil wenn ich auf die 8er oder 9er wechsele und weiß jemand warum es 3 Versionen gibt? Welche Version verwendet ihr?
PC: Eingefügtes Bild
0

Anzeige

#2 Mitglied ist offline   evil.baschdi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.637
  • Beigetreten: 11. Februar 07
  • Reputation: 56

geschrieben 07. September 2014 - 07:32

Die 7er Runtime ist die aktuell im Java Umfeld noch weit verbreitetste, jre 8 ist immer mehr am kommen. Version 9 befindet sich noch in der Entwicklung, deshalb sind hier sämtliche Updates mit dem Zusatz "DEV" vermerkt.

Aufgrund der Tatsache, dass die offiziell aktuellste Version also 8 ist, meint man be Oracle wohl, die Version 7 nicht mehr so häufig mit Updates versorgen zu müssen.

Nen Rat, welche Version du verwenden solltest, kann ich dir leider nicht wirklich geben, da ich mir nicht sicher bin, ob es - ähnlich dem .Net Framework - wirklich die Version voraussetzt, in der eine Java Anwendung geschrieben wurde, oder ob die aktuellste Version hierzu ausreichend ist.
Aktuell habe ich deshalb auch Versionen 7 und 8 installiert.
Eingefügtes Bild

"
Heute code ich, morgen debug ich und übermorgen caste ich die Königin auf int!"
P.S. Ich leiste keinen Support per PN. Wer ein Problem hat, ab damit ins Forum!

0

#3 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 7.765
  • Beigetreten: 20. Juli 07
  • Reputation: 859

geschrieben 07. September 2014 - 09:37

Durchaus möglich, daß eine *konkrete* JAVA-Version vorausgesetzt wird - manchmal berechtigt, manchmal nicht.

Hast Du JAVA-Anwendungen auf dem Rechner? Wenn ja: diese auflisten, JRE7 deinstallieren, schauen ob es mit der JRE8 noch so funktioniert, wie es soll. Gegebenenfalls muß man im jeweiligen Programm noch die Konfiguration so abändern, daß die neuere JRE verwendet wird (per Angabe des Programmpfades zur JRE zum Beispiel).

Falls nicht, kannst Du die alte(n) JRE(s) bedenkenlos deinstallieren (ältere Revisionen derselben Version sowieso - wenn Du JRE7u67 instaliert hast, kann JRE7u60 weg usw).

Sicherheitshalber kannst Du ja noch den Offline Installer für JRE7 herunterladen. Falls irgendwas mit JRE8 nicht funktionieren sollte, hast Du dann die ältere Version noch parat (auch wenn sie ggf. nicht mehr bei Oracle bereitstehen sollte).

Für JAVA 9, denk ich, ist es noch zu früh. Klar kann man das parallel installieren und dann schauen, ob die eigenen Applets damit noch laufen oder nicht und ob man da noch etwas tun muß. Ansonsten sind mit JAVA9 momentan - wie mit jeder EA-Version - eher Probleme zu erwarten.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
Eingefügtes Bild
0

#4 Mitglied ist offline   Scoty30 

  • Gruppe: aktive Mitglieder
  • Beiträge: 225
  • Beigetreten: 20. Dezember 04
  • Reputation: 1

geschrieben 07. September 2014 - 09:38

Alles klar danke für die Infos.
PC: Eingefügtes Bild
0

#5 Mitglied ist offline   timmy 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.784
  • Beigetreten: 24. Juni 05
  • Reputation: 114

geschrieben 07. September 2014 - 12:16

Java und Oracel scheinen sich hier nicht ganz einig zu sein.
Oracel bietet die 8er als Download an.
Java sagt, die 8er ist noch in der Testphase, weshalb sie den Download nicht anbieten.
0

#6 Mitglied ist offline   wolf22 

  • Gruppe: aktive Mitglieder
  • Beiträge: 581
  • Beigetreten: 03. Januar 08
  • Reputation: 33

geschrieben 07. September 2014 - 17:25

Habe hier nun nach und nach alle Java-Installationen mit RevoPro deinstalliert und bis jetzt noch keine Probleme gehabt oder es haben sich Programme gemeldet, denen irgend etwas gefehlt hat.
Diese Umgebung wird heute kaum noch bei den Anwendungen gebraucht.
0

#7 Mitglied ist offline   timmy 

  • Gruppe: aktive Mitglieder
  • Beiträge: 2.784
  • Beigetreten: 24. Juni 05
  • Reputation: 114

geschrieben 07. September 2014 - 17:45

Sollte man doch mal das eine oder andere Programm erwischen (bei mir TVBrowser), kann man ja die portable Version von Java nehmen.
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0