WinFuture-Forum.de: usb stick plötzlich schreibgeschützt!? - WinFuture-Forum.de

Zum Inhalt wechseln

Alle Informationen zum Thema Windows 8 in unserem Special.
Seite 1 von 1

usb stick plötzlich schreibgeschützt!? spaceloop 32gb

#1 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 169
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 26. Januar 2013 - 12:38

moin, alle win8 user!

ich übertrage gerade meine dateien auf nem spaceloop 32gb-stick, damit ich mein system resetten kann. jetzt hab ich aber folgendes prob: erst bekam ich den fehlercode 0x8007045D und danach erschien eine meldung, in der stand, dass der usb stick schreibgeschützt ist!? ich hab auch schon das versucht:

Zitat

Eine Möglichkeit zum Aufheben des Schreibschutzes: Öffnen Sie die Registrierung (Menü Start/Ausführen, regedit eintippen und Enter drücken) und navigieren Sie zum folgenden Schlüssel:
HKEY_LOCAL_MACHINE\System\CurrentControlSet \Control\StorageDevicePolicies
Gibt es dort einen Eintrag «WriteProtect», stellen Sie sicher, dass dessen Wert «0» beträgt (die Ziffer Null, nicht der Buchstabe O). Dann ist der Schreibschutz inaktiv. Sollten Sie dort die Ziffer «1» vorfinden, doppelklicken Sie den Eintrag und ändern ihn auf Null.


...aber in der registry gibt es bei mir keinen ordner/eintrag "StoragerDevicePolicies".

wenn ich den usb stick erneut anschließe, bekomme ich eine meldung, dass das gerät eventuell beschädigt ist, und ich eine überprüfung ausführen muss. wenn ich das mache, bekomme ich wieder die berühmte meldung: gerät ist schreibgeschützt.

der usb stick an sich verfügt keinen schalter, wo man das einstellen kann.

Dieser Beitrag wurde von ::YC Tech:: bearbeitet: 26. Januar 2013 - 12:40

0

Anzeige

#2 Mitglied ist offline   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.344
  • Beigetreten: 19. August 04
  • Reputation: 501

geschrieben 26. Januar 2013 - 12:49

Den Pfad zu "StoragerDevicePolicies" müsstest Du anlegen, soweit er nicht existiert.

0x8007045D = I/O device error

Steht denn noch etwas in der Ereignisanzeige dazu?

Der Fehler geht meist in die Richtung, dass der Stick selber defekt ist oder das sich das Dateisystem auf dem Stick Probleme hat.

Mein letzter Stick mit dem Problem war ein Fall für die Mülltonne. Muss bei Dir jetzt nicht auch der Fall sein. Falls Windows Dich gar ncht mehr auf den Stick lässt (auch nicht in der Konsole in diskpart), dann müsstest Du das ganze mal unter Linux versuchen.

Und sicherheitshalber, alle Daten, welche noch lesbar sind, wieder vom Stick herunter kopieren.

An welchem USB Port hängt denn der Stick? USB 2.0 oder 3.0? Bei einigen Sticks kann das auch zu Problemen führen, wenn sie am vermeintlich "falschen" Port hängen.

Dieser Beitrag wurde von DK2000 bearbeitet: 26. Januar 2013 - 12:53

Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
0

#3 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 169
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 26. Januar 2013 - 13:02

also auf den usb-stick an sich komm ich ja drauf, nur ich kann halt dort nicht schreiben. unter linux werden ganz andere dateien als auf dem usb-stick gelistet (siehe screenshot). außerdem wird der name des sticks nicht angezeigt.
0

#4 Mitglied ist offline   RalphS 

  • Gruppe: VIP Mitglieder
  • Beiträge: 3.817
  • Beigetreten: 20. Juli 07
  • Reputation: 336

geschrieben 26. Januar 2013 - 14:06

Welches Dateisystem ist das denn? NTFS? :unsure:

Aber ich stimm DK2000 zu, das riecht ganz nach Defekt - entweder auf Dateisystemebene (was chkdsk hoffentlich kurieren kann) oder auf Hardware-Ebene (dann hilft gar nichts außer DK2000's Vorschlag, Daten zu retten solange es noch geht).

USB-Sticks steigen zumindest bei mir gerne aus, bis auf einen haben die noch alle innerhalb von ein paar Monaten die Hufe hochgemacht. Das mag bei Deinem sicher anders sein, aber *Vertrauen* hab ich in das Zeugs nicht.
"If you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."-- Anne Isabella Thackeray Ritchie

Eingefügtes Bild
0

#5 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 169
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 26. Januar 2013 - 15:19

also ich hab den stick auf fat32 formatiert.

allerdings hab ich den stick mehrmals formatiert und das auch mit windows und linux.
0

#6 Mitglied ist offline   halaX 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.270
  • Beigetreten: 29. Oktober 06
  • Reputation: 56

geschrieben 26. Januar 2013 - 20:50

Hallo ::YC Tech::,
Die Bitlocker ToGo Dateien unter Linux angezeigt,verraten:
Entweder bestand auf dem Stick eine Bitlocker ToGo Laufwerksverschlüsselung oder es wurde
eine solche auf dem Stick,bei Benutzung mit einem anderen Windows OS eingerichtet.Infolge
der diversen Format-Versuche könnte nun das Dateisystem beschädigt sein.Soweit alle Daten
vom Stick schon extern gesichert wurden,würde ich den Stick mit Gparted weiterbearbeiten
oder mit deinem bereits vorhandenem Linux,a l l e auf dem USB-Stick vorhandenen Partitionen
löschen.Dem USB-Stick anschließend mit Hilfe der Windows-Datenträgerverwaltung eine neue
primäre Partition über die gesamte Kapazität des Sticks erstellen.Diese neue Partition dann auf
NTFS formatieren (wegen Dateigrößenbeschränkung unter FAT 32,sofern du Dateibackups
kopierst,bei einzelner Datei >4GB,würde eine solche gesplittet unter FAT 32).
MfG.halaX
Happy WIN and TUX Computing by halaX
0

#7 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 169
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 27. Januar 2013 - 17:52

also, wenn ich versuche, die partition vom usb stick (mit gparted) zu löschen, bekomme ich diese meldung:
Eingefügtes Bild

gibt es auch einen anderen weg, den schreibschutz aufzuheben (z.b. mit terminal)?

Dieser Beitrag wurde von ::YC Tech:: bearbeitet: 27. Januar 2013 - 17:56

0

#8 Mitglied ist offline   halaX 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.270
  • Beigetreten: 29. Oktober 06
  • Reputation: 56

geschrieben 27. Januar 2013 - 20:47

@ ::YC Tech::,
Vielleicht hilft der Tip von CnMemory,ist schließlich vom Stick-Hersteller.
Vorher aber einen Systemwiederherstellungspunkt erstellen,
falls etwas schiefläuft.
MfG.halaX
Happy WIN and TUX Computing by halaX
0

#9 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 169
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 29. Januar 2013 - 15:09

also ich hab jetz den vorschlag ausprobiert, aber jetzt ist der stick komplett schreibgeschützt (einträge "neuer ordner" etc. sind nicht mehr im kontextmenü)
0

#10 Mitglied ist offline   halaX 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.270
  • Beigetreten: 29. Oktober 06
  • Reputation: 56

geschrieben 29. Januar 2013 - 22:16

@::YC Tech::,
Überprüfen,ob der Tip von CnMemorykorrekt ausgeführt wurde.
Bei abgezogenem USB-Stick,sowie nicht angeschlossener weiterer USB-Speichermedien wie
externe USB-Festplatten etc.
Starte "regedit" und suche den Schlüssel:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies]
"WriteProtect"=dword:0
ob dieser auch vorhanden ist,kontrolliere auch,ob unter "WriteProtect" der
"dword" Wert 1x die Null enthält,gegebenenfalls den Wert korrigieren.Anschließend den
USB-Stick wieder anstöpseln und auf Funktion überprüfen.
MfG.halaX
EDIT:
Wenn du alle 4 Seiten,also alle Beiträge des folgenden Threads liest,sollte eigentlich
das Problem lösbar sein.
HIER:Mein USB-Stick ist schreibgeschützt
Wenn die Einträge
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies]
"WriteProtect" in der Registry schon bestehen,dann soll im Fenster
für "Dword" eine Null"0",also nicht Buchstabe "O",eingetragen sein.

Dieser Beitrag wurde von halaX bearbeitet: 30. Januar 2013 - 04:10

Happy WIN and TUX Computing by halaX
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0