WinFuture-Forum.de: wpf: image wird nicht angezeigt - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Entwicklung
Seite 1 von 1

wpf: image wird nicht angezeigt

#1 Mitglied ist offline   ::YC Tech:: 

  • Gruppe: aktive Mitglieder
  • Beiträge: 168
  • Beigetreten: 01. Oktober 11
  • Reputation: 0

geschrieben 09. Januar 2013 - 16:49

moin, aller programmierer!

ich bastle grad an einem setup-programm (basierend auf wpf) für ein anderes programm. so sieht es gerade (nur im editor) aus:

Eingefügtes Bild
(am button bin ich noch am basteln)

aber wenn ich es starte, werden die bilder nicht angezeigt und es sieht so aus:

Eingefügtes Bild

ich hab schon andere threads mit dem gleichen problem gefunden, aber da hat mir nichts weitergeholfen.
hier ist der xaml-code:
<Window x:Class="MainWindow"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    Title="NµEdit Setup" Height="341.037" Width="524" BorderThickness="0" ResizeMode="NoResize">
    <Window.Background>
        <RadialGradientBrush>
            <GradientStop Color="#FF7EDDF9" Offset="0"/>
            <GradientStop Color="#FF009DE2" Offset="1"/>
        </RadialGradientBrush>
    </Window.Background>
    <Grid>
        <Grid.Triggers>
            <EventTrigger RoutedEvent="Grid.Loaded">
                <BeginStoryboard>
                    <Storyboard>
                        <DoubleAnimation From="100" To="0" Duration="00:00:01" 
               Storyboard.TargetName="thBlur" 
               Storyboard.TargetProperty="Radius" />
                        <DoubleAnimation From="100" To="0" Duration="00:00:02" 
               Storyboard.TargetName="tmBlur" 
               Storyboard.TargetProperty="Radius" />
                    </Storyboard>
                </BeginStoryboard>
            </EventTrigger>
        </Grid.Triggers>
        <Image Source="Resources/InstallerBackground.jpg" HorizontalAlignment="Stretch" VerticalAlignment="Top" />
        <Image Source="Resources/BannerLogo.png" Width="200" Height="70" HorizontalAlignment="Center" Margin="157,10,159,230" />
        <Label x:Name="HeadingLabel" HorizontalContentAlignment="Center" VerticalContentAlignment="Center" Content="Willkommen zum Setup!" HorizontalAlignment="Center" Margin="0,41,0,155" Width="516" FontSize="30" VerticalAlignment="Top" Height="114" FontFamily="Segoe UI Semibold">
            <Label.Effect>
                <BlurEffect x:Name="thBlur" Radius="0"/>
            </Label.Effect>
            <Label.Foreground>
                <LinearGradientBrush EndPoint="0.5,1" StartPoint="0.5,0">
                    <GradientStop Color="#FFD4D4D4" Offset="1"/>
                    <GradientStop Color="White"/>
                </LinearGradientBrush>
            </Label.Foreground>
        </Label>
        <Label HorizontalContentAlignment="Center" VerticalContentAlignment="Center" Content="Klicken Sie auf 'Weiter', um mit dem Set-Up von NµEdit zu Beginnen." HorizontalAlignment="Center" Margin="42,155,40,0" VerticalAlignment="Top" Foreground="White" FontSize="14">
            <Label.Effect>
                <BlurEffect x:Name="tmBlur" Radius="0"/>
            </Label.Effect>
        </Label>
        <Button x:Name="spNextBtn" Content="Weiter" HorizontalAlignment="Center" Margin="189,0,179,50" VerticalAlignment="Bottom" Width="150" Height="40" RenderTransformOrigin="0.727,0.525" BorderBrush="#FF009DE0" BorderThickness="1">
            <Button.Background>
                <LinearGradientBrush EndPoint="0.5,1" StartPoint="0.5,0">
                    <GradientStop Color="#FF009FE3" Offset="0"/>
                    <GradientStop Color="#FF6CD8F8" Offset="1"/>
                </LinearGradientBrush>
            </Button.Background>
        </Button>
    </Grid>
</Window>

0

Anzeige

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0