WinFuture-Forum.de: KB2698035 Update Fehlermeldung - WinFuture-Forum.de

Zum Inhalt wechseln

Weitere Informationen: WinFuture Update Pack
Seite 1 von 1

KB2698035 Update Fehlermeldung Patch konnte nicht installiert werden

#1 Mitglied ist offline   S.Gill 

  • Gruppe: Mitglieder
  • Beiträge: 15
  • Beigetreten: 09. Mai 12
  • Reputation: 0

geschrieben 14. November 2012 - 23:28

Hallo Forum!

Beim Installieren der aktuellen November-Updates
WinFuture_WinXPsp3_UpdatePack_3.49_November_2012-Upgrade.exe
bekam ich die Fehlermeldung
"KB2698035 konnte nicht installiert werden."

Ist über diesen Fehler eventuell schon etwas bekannt geworden, woran könnte es liegen?
(das ist übrigens die erste Fehlermeldung, die ich bei all den bereits installierten Updatepacks erhalten habe)

Gruß

PS, ich habe die Datei des o.g. Updates KB2698035
-> NDP1.0sp3-KB2698035-X86-Ocm-Deu.exe
manuell entpackt und erneut versucht zu installieren.
Die Fehlermeldung wird von diesem Update selbst herausgegeben und lautet erneut
"KB2698035 konnte nicht installiert werden."

Über dieses Update schreibt MS:
"MS12-074: Description of the security update for the .NET Framework 1.0 Service Pack 3 on Windows XP Service Pack 3 Tablet PC Edition and Windows XP Service Pack 3 Media Center Edition: November 13, 2012"

Könnte das bedeuten, dass mein PC mit XP-32Bit/SP3 weder eine "Tablet PC Edition" noch ein "Windows XP Service Pack 3 Media Center Edition" ist/sein soll-te?
Ein "Tablet" ist mein PC sicherlich nicht, aber mit dem Begriff "Media Center Edition" kann ich gerade nichts anfangen...

Oder gehört dieses KB2698035-Update womöglich gar nicht ins "Windows XP mit SP3 November (3.49)"-Upgrade-Pack?

Ich habe mich mit dem KB2698035 -> NDP1.0sp3-KB2698035-X86-Ocm-Deu.exe weiter bschäftigt und es bietet sich folgendes Bild:

- "KB2698035 konnte nicht installiert werden."

- KB2698035-Beschreibung: MS12-074: Description of the security update for the .NET Framework 1.0 Service Pack 3 on Windows XP Service Pack 3 Tablet PC Edition and Windows XP Service Pack 3 Media Center Edition: November 13, 2012

- .NET Framework 1.0 Service Pack 3 -> NDP1.0sp3-KB867461-X86-Deu.exe istalliert, Ergebnis: Klick!
Möglicherweise fehlt das Framework 1.0

- Framework 1.0 -> dotnetfx.exe heruntergeladen und versucht zu installieren, Ergebnis: Klick!
Installiert ist bei mir das Framework ab Version 1.1, was daran nicht kompatibel sein soll, erschließt sich mir nicht.

Irgendwas stimmt hier nicht mit dem KB2698035...

Dieser Beitrag wurde von Urne bearbeitet: 15. November 2012 - 05:13
Änderungsgrund: Beiträge verbunden. Urne

0

Anzeige

#2 Mitglied ist online   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.099
  • Beigetreten: 19. August 04
  • Reputation: 472

geschrieben 15. November 2012 - 02:17

.NET Framework 1.0 lässt sich auch nicht mehr installieren, wenn .NET Framework 1.1 installiert ist. Es wird praktisch von der 1.1 vollständig ersetzt.

KB2698035 ist ausschließlich für das .NET Framework 1.0 SP3 gedacht, welches in den beiden Editionen integriert ist:

Windows XP SP3 Tablet PC Edition
Windows XP SP3 Media Center Edition

Auf allen anderen Windows XP SP3 Editionen ist es nicht anwendbar bzw. es ist auch nicht auf diesen beiden Editionen anwendbar, wenn auf das .NET 1.1 upgedatet wurde.

Für alles andere gibt es eigene Versionen für das Problem unter Windows XP SP3:

.NET Framework 1.1 Service Pack 1 -> KB2698023
.NET Framework 2.0 Service Pack 2 -> KB2729450
.NET Framework 4 -> KB2729449, KB2737019

Dieser Beitrag wurde von DK2000 bearbeitet: 15. November 2012 - 02:54

Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
0

#3 Mitglied ist offline   S.Gill 

  • Gruppe: Mitglieder
  • Beiträge: 15
  • Beigetreten: 09. Mai 12
  • Reputation: 0

geschrieben 15. November 2012 - 04:59

Seit diesem Update bin ich mir nicht mehr sicher, was mein XP-32Bit denn nun eigentlich darstellt - ein XP mit oder ohne "Media Center Edition"...

Vielleicht lässt sich das ja klären - grundsätzlich mache ich für gewöhnlich folgendes:

- XP Professional installieren (+ Treiberkram usw.)
- Windows Installer V.4.5 (WindowsXP-KB942288-v3-x86.exe)
- SP3 (WindowsXP-KB936929-SP3-x86-DEU.exe, unter Umgehung des SP2 mittels SP3enable.reg)
- All in One Runtimes-Pack
- das aktuelle WinXP SP3 UpdatePack in der Vollversion

Soweit 'ne normale Angelegenheit.

Nun veröffentlicht MS neue Updates und das November-Upgrade überrascht mich mit einem "KB2698035 konnte nicht installiert werden"-Fehler.
Soweit die Faktenlage, die im Prinzip auch demjenigen Normaluser begegnen dürfte, der Windows normal installiert und nicht nach tieferen Ursachen forscht. Viel besser bin ich eigentlich auch nicht dran.

Die Runtime-Installationen übrigens zeigt das Softwaremenü dann so an: Klick!
Also kein Framework 1.0, ab Framework 1.1 das komplette Paket.
Im Microsoft.NET-Ordner ist demgegenüber aber sehr wohl ein installiertes Framework 1.0 zu sehen: Klick!

Die Frage lautet: Ist das OK, ignoriere ich die Fehlermeldung einfach?
Befriedigend wäre/ist das allerdings nicht. Vielleicht sollte dieses Problem FAQ-mäßig erfasst werden, sofern es sich nicht um einen individuellen Fehler handelt, den ich mir jedoch nicht erklären könnte.

Dieser Beitrag wurde von S.Gill bearbeitet: 15. November 2012 - 05:09

0

#4 Mitglied ist online   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.099
  • Beigetreten: 19. August 04
  • Reputation: 472

geschrieben 15. November 2012 - 14:42

Beitrag anzeigenZitat (S.Gill: 15. November 2012 - 04:59)

Seit diesem Update bin ich mir nicht mehr sicher, was mein XP-32Bit denn nun eigentlich darstellt - ein XP mit oder ohne "Media Center Edition"...

Nein. Du Schreibst ja selbst, dass Du XP Professional installiert hast.

Tablet PC Edition und Media Center Edition sind genau so wie die Home eigenständige Editionen, welche jeweils auf eigenen Installations CDs bzw. auf entsprechenden Geräten vorinstalliert ausgeliefert werden/wurden.

Beitrag anzeigenZitat (S.Gill: 15. November 2012 - 04:59)

Nun veröffentlicht MS neue Updates und das November-Upgrade überrascht mich mit einem "KB2698035 konnte nicht installiert werden"-Fehler.

Richtig. Weil Du ja auch XP Professional installiert hast und zusätzlich das .NET Framwork 1.1. Damit hat KB2698035 für Dich keinerlei Bedeutung.

Beitrag anzeigenZitat (S.Gill: 15. November 2012 - 04:59)

Im Microsoft.NET-Ordner ist demgegenüber aber sehr wohl ein installiertes Framework 1.0 zu sehen.

Richtig. Diesen Ordner gibt es immer, selbst unter Windows 8. Dieser wird aus Kompatibilitätsgründen mitgeschleppt. Er enthält aber nur dann das .NET Framwor 1.0, wenn dieses auch installiert wurde. Ansonsten enthält er neuere Dateien, welche die Abwärtskompatibilitat sicher stellen sollen. Allerdings teilweise mit mäßigem Erfolg.

Da das .NEt Framwork 1.0/1.1 praktisch keine Bedeutung mehr hat, sollte man es wirklich nur noch dann installieren, wenn man ältere Software verwendet, welche danach verlangt. Im Normal Fall reicht .NET Framwork 2.0 und neuer vollkommen aus.

Beitrag anzeigenZitat (S.Gill: 15. November 2012 - 04:59)

Die Frage lautet: Ist das OK, ignoriere ich die Fehlermeldung einfach?

Ja, ist OK, wenn Du diese Fehlermeldung ignorierst.

Aber halt nicht die Sicherheitslücke ignorieren, welche dadurch geschlossen werden soll. KB2698023, KB2729450, KB2729449 und KB2737019 musst Du installieren, da Du entsprechende .NET Framework Versionen installiert hast.

Das ist immer umständlich mit dem .NET Framework.
Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
1

#5 Mitglied ist offline   S.Gill 

  • Gruppe: Mitglieder
  • Beiträge: 15
  • Beigetreten: 09. Mai 12
  • Reputation: 0

geschrieben 15. November 2012 - 15:17

Wahnsinn... von solchen Zusammenhängen zwischen speziell XP Professional / Updates / (keine) Media Center Edition / alte, mitgeschleppte/neue .NET Framwork-Versionen hatte ich keinen blassen Dunst - Danke vielmals für die Aufkärung!

Nur der Zusammenhang der beiden folgenden Sätze ist mir noch nicht ganz klar geworden:

Zitat

Aber halt nicht die Sicherheitslücke ignorieren, welche dadurch geschlossen werden soll. KB2698023, KB2729450, KB2729449 und KB2737019 musst Du installieren, da Du entsprechende .NET Framework Versionen installiert hast.


Bedeutet das in diesem Fall (KB2698035-Fehlermeldung, XP Pro, Framework 1.1 ff., keine Media Center Edition), dass mit der Installation von KB2698023, KB2729450, KB2729449 und KB2737019 die Sicherheitslücke nicht ignoriert, sondern geschlossen wird?

Dieser Beitrag wurde von S.Gill bearbeitet: 15. November 2012 - 15:45

0

#6 Mitglied ist online   DK2000 

  • Gruppe: Moderation
  • Beiträge: 13.099
  • Beigetreten: 19. August 04
  • Reputation: 472

geschrieben 15. November 2012 - 16:05

Gneau.

Du hast ja .NET Framwork 1.1, 2.0 SP2. 3.0 SP2. 3.5 SP1 und 4.0 installiert. ;oz Ausnahme von 3.0 SP2 und 3.5 SP1 (nur Windows XP SP3) Weisen alle anderen eine Sicherheitslücke, das 4.0 sogar zwei, welche jeweils mit einem eigenen Fix geschlossen werden:

.NET Framework 1.1 Service Pack 1 -> KB2698023
.NET Framework 2.0 Service Pack 2 -> KB2729450
.NET Framework 3.0 Service Pack 2 -> XP SP3 nicht betroffen
.NET Framework 3.5 Service Pack 1 -> XP SP3 nicht betroffen
.NET Framework 4 -> KB2729449, KB2737019

Wenn Du diese vier Updates installiert hast, sind die Lücken bei Dir geschlossen.

Ja, ich weiß, ist kompliziert mit den .NET Framworks. Unter Windows 7 bzw. Windows 8 wird das sogar noch komplizierter, da hier diese Sicherheitslücke auch das 3.5.1, 4.0 und 4.5 betrifft.

Am Besten nach der Installation eines Update Packs das Windows Update aufrufen und überprüfen, ob dort keine weiteren sicherheitsrelevanten Updates angezeigt werden.

Dieser Beitrag wurde von DK2000 bearbeitet: 15. November 2012 - 16:10

Je früher man den Tag beginnt, desto mehr Bewegung hat man.
Ich darf nicht so viel Essen wie ich will.
0

#7 Mitglied ist offline   kasbah 

  • Gruppe: Administration
  • Beiträge: 528
  • Beigetreten: 09. April 06
  • Reputation: 9

geschrieben 15. November 2012 - 16:27

Das Update aus KB2698035 ist, wie DK2000 schon geschrieben hat, ausschließlich fuer das .NET Framework in der Version 1.0 relevant. Diese ist aber schon lange nicht mehr aktuell und komplett durch .NET in der Version 1.1 ersetzt worden.

Normalerweise merken die Updates fuer die verschiedenen .NET Versionen, wenn das zu aktualisierende .NET-Framework nicht installiert ist und beenden sich ohne Fehlermeldung. Im Falle dieses einen Updates taucht aber leider dieser Fehlerdialog auf. Die restlichen Updates werden aber trotz dieser Fehlermeldung ordnungsgemäß installiert. Sie kann also einfach ignoriert werden, wenn man .NET in der Version 1.0 nicht installiert hat.

Das ist mir schon beim Testen aufgefallen und ich hatte das Update auf Grund der sehr hohen Wahrscheinlichkeit, das .NET 1.0 nicht installiert ist, aus dem Pack herausgenommen. Leider ist in der Eile gestern Abend aber dann doch die falsche Version online gegangen. Die korrigierte Version steht jetzt zum Download bereit. Es ist aber nicht notwendig, die neuer Version noch mal herunter zu laden, da alle relevanten Updates ordnungsgemäß installiert werden, auch wenn der Fehler angezeigt wird.

Ich bitte um Entschuldigung für die entstandenen Unannehmlichkeiten!
1

#8 Mitglied ist offline   S.Gill 

  • Gruppe: Mitglieder
  • Beiträge: 15
  • Beigetreten: 09. Mai 12
  • Reputation: 0

geschrieben 15. November 2012 - 17:23

Also lag's am Patch selbst... (nach der manuellen Installation des NDP1.0sp3-KB2698035-X86-Ocm-Deu.exe dachte ich an diese Möglichkeit, bzw. dass dieser Patch besser nicht in die UpdatePacks gehört)

Wunderbar, Problem zur beiderseitigen Zufriedenheit gelöst!

Grüße
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0