WinFuture-Forum.de: SQL Server 2008 Express / Netzwerk - Fehler 26 - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Entwicklung
Seite 1 von 1

SQL Server 2008 Express / Netzwerk - Fehler 26


#1 Mitglied ist offline   der dom 

  • Gruppe: aktive Mitglieder
  • Beiträge: 312
  • Beigetreten: 14. Juni 12
  • Reputation: 29

geschrieben 18. Juni 2012 - 19:53

Hi,

ich hab ein kleines Problem mit einer SQL Server 2008 Express Instanz im Netzwerk.

Ich kann mit meinem C# Programm Datenbanken und Tabellen erstellen (Startup Assistent) - nun, wenn ich mit dem Hauptprogramm darauf zugreifen möchte zeigt er mir den Fehler 26 an (siehe Bild).

Ich habe keine Ahnung woran es liegen kann, Firewall ist für die TCP und UDP Ports freigegeben - mein Programm findet die Instanz auch und der Conn-String stimmt auch....jemand von euch eine Idee?

Angehängte Miniaturbilder

  • Angehängtes Bild: error.png

Mit allem, was du tust, machst du offenkundig, mit welcher Einstellung du durch's Leben gehst. -- Steffen Glückselig
0

Anzeige



#2 Mitglied ist offline   evil.baschdi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.637
  • Beigetreten: 11. Februar 07
  • Reputation: 56

geschrieben 18. Juni 2012 - 20:11

Also TCP Verbindung musst du freigeben und nochmal irgend nen Port öffnen. 1409 oder was das war. Warn aber drei Sachen, so weit ich mich erinnere.
Eingefügtes Bild

"
Heute code ich, morgen debug ich und übermorgen caste ich die Königin auf int!"
P.S. Ich leiste keinen Support per PN. Wer ein Problem hat, ab damit ins Forum!
Windows 10 - Windows Anleitungen
0

#3 Mitglied ist offline   der dom 

  • Gruppe: aktive Mitglieder
  • Beiträge: 312
  • Beigetreten: 14. Juni 12
  • Reputation: 29

geschrieben 18. Juni 2012 - 20:12

Das ist alles erledigt, sonst könnte ich per Netz ja keine Datenbanken erstellen.
Mit allem, was du tust, machst du offenkundig, mit welcher Einstellung du durch's Leben gehst. -- Steffen Glückselig
0

#4 Mitglied ist offline   evil.baschdi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.637
  • Beigetreten: 11. Februar 07
  • Reputation: 56

geschrieben 18. Juni 2012 - 20:23

achsooo, das geht? nun gut.

ports werden nicht durch die firewall blockiert? instanzname wird richtig als rechnername\sqlexpress (oder wie auch immer festgelegt) erkannt?
was passiert, wenn du das programm direkt auf dem rechner ausführst, auf dem der sql dienst läuft?
Eingefügtes Bild

"
Heute code ich, morgen debug ich und übermorgen caste ich die Königin auf int!"
P.S. Ich leiste keinen Support per PN. Wer ein Problem hat, ab damit ins Forum!
Windows 10 - Windows Anleitungen
0

#5 Mitglied ist offline   der dom 

  • Gruppe: aktive Mitglieder
  • Beiträge: 312
  • Beigetreten: 14. Juni 12
  • Reputation: 29

geschrieben 18. Juni 2012 - 20:38

Also was mir gerade aufgefallen ist...

Der Conn-String wird richtig in der Registry abgelegt - ABER das Problem ist dass er so ausgelesen wird:

DATA SOURCE = XXX\\SQLINSTANZ statt DATA SOURCE = XXX \ Datasource.

Hier mal mein Source dazu:

 public string readRegistry(string Key)
        {
            // read Values from the Subkey
            if (SubKeyExist("SOFTWARE\\WWSN-09.com\\Vereinsverwaltung"
))
            {
                RegistryKey myKey = Registry.CurrentUser.OpenSubKey("SOFTWARE\\WWSN-09.com\\
Vereinsverwaltung");
                string firstApp = (string)myKey.GetValue(Key);
                return firstApp;
            }
            else
                throw new Exception("Subkey does not exist!");
        }


Wie kann ich denn die Escape-Sequenz daraus bekommen?
Mit allem, was du tust, machst du offenkundig, mit welcher Einstellung du durch's Leben gehst. -- Steffen Glückselig
0

#6 Mitglied ist offline   evil.baschdi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.637
  • Beigetreten: 11. Februar 07
  • Reputation: 56

geschrieben 18. Juni 2012 - 20:53

das einfachste wäre einfach ein @"Software...

frag mich allerdings gerade, warum das überhaupt mit nem \\ und nicht mit nem \ ausgelesen wird
mal etwas im archiv wüüühlen

Edit:
ah, ok. ich escape das auch:
RegistryKey myKey = Registry.CurrentUser.OpenSubKey(@"Software\Mister-X\Programm"
, RegistryKeyPermissionCheck.ReadSubTree);
        	if (myKey != null)
... 

Dieser Beitrag wurde von mister-x bearbeitet: 18. Juni 2012 - 20:56

Eingefügtes Bild

"
Heute code ich, morgen debug ich und übermorgen caste ich die Königin auf int!"
P.S. Ich leiste keinen Support per PN. Wer ein Problem hat, ab damit ins Forum!
Windows 10 - Windows Anleitungen
1

#7 Mitglied ist offline   der dom 

  • Gruppe: aktive Mitglieder
  • Beiträge: 312
  • Beigetreten: 14. Juni 12
  • Reputation: 29

geschrieben 18. Juni 2012 - 21:05

Also das mit dem @ hat geholfen, hätte ich auch selber drauf kommen müssen.

Wie gesagt, die Frage ist warum das nicht ordentlich ausgelesen wird.....

Der String ist doch eindeutig.
Mit allem, was du tust, machst du offenkundig, mit welcher Einstellung du durch's Leben gehst. -- Steffen Glückselig
0

#8 Mitglied ist offline   nobido 

  • Gruppe: aktive Mitglieder
  • Beiträge: 205
  • Beigetreten: 20. April 07
  • Reputation: 9

geschrieben 19. Juni 2012 - 10:46

Hiho,

weil es mich doch arg interessiert: Wie sieht denn der connection-String GENAU aus? Magst du den code dazu mal posten? Oder werden da Firmengeheimnisse verraten?


Was das \\ angeht: Wenn nicht @ verwendet wird ist das doch vollig richtig. Weil, sonst dürfte es eine Fehlermeldung bzgl. nicht erkannter Escape-Sequenz geben. Oder irre ich?

greetz
joey


p.s. connectionstringbuilder nutzen? ich mochte den auch nie.
0

#9 Mitglied ist offline   der dom 

  • Gruppe: aktive Mitglieder
  • Beiträge: 312
  • Beigetreten: 14. Juni 12
  • Reputation: 29

geschrieben 19. Juni 2012 - 11:59

Connstring = "DATA SOURCE = SERVERNAME\INSTANZ; DATABASE = DATABASE; USER....; PASSWORD...;"

So steht er in der Registry. Und von da wird er gelesen. Er ist also nicht im Programm vorhanden sondern wird wie gesagt nur aus der Registry gelesen. Sonst würde ich dir da vollends zustimmen was das @ angeht.
Mit allem, was du tust, machst du offenkundig, mit welcher Einstellung du durch's Leben gehst. -- Steffen Glückselig
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0