WinFuture-Forum.de: Link verschwindert (Styles, Joomla) - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Entwicklung
Seite 1 von 1

Link verschwindert (Styles, Joomla) bei Positionierung verschwindet der Link

#1 Mitglied ist offline   Sepultura 

  • Gruppe: aktive Mitglieder
  • Beiträge: 621
  • Beigetreten: 18. September 05
  • Reputation: 6

geschrieben 07. Mai 2012 - 09:51

Hallo User,

bearbeite gerade Joomla Template.

Der erste Teil momentan sieht so aus
<?php if ($logo): ?>
 <div style="position:absolute; top:0px;left:900px;"><img src="<?php echo $this->baseurl ?>/<?php echo htmlspecialchars($logo); ?>"  alt="<?php echo htmlspecialchars($templateparams->get('sitetitle'));?>" /></div></br>
</br>
<p align="right">
 <?php echo JText::_('');?> <a href="index.php/de/"><img src="images/de.png" alt="DE" /></a>   <a href="index.php/en/"><img src="images/en.png" alt="EN"/></a>
                                        </p>
	<?php endif;?>


Wenn ich jetzt folgendes mache
 <?php if ($logo): ?>
<div style="position:absolute; top:0px;left:900px;"><img src="<?php echo $this->baseurl ?>/<?php echo htmlspecialchars($logo); ?>"  alt="<?php echo htmlspecialchars($templateparams->get('sitetitle'));?>" /></div></br>
</br>
<div style="position:absolute;top:75px;left:1090px;">
               <?php echo JText::_('');?> <a href="index.php/de/"><img src="images/de.png" alt="DE" /></a>   <a href="index.php/en/"><img src="images/en.png" alt="EN"/></a>
                                        </div>
	<?php endif;?>


Kommen zwar die Flaggen richtig unter das Logo rein, aber ich kann nicht mehr draufklicken, damit er den Link weiterverfolgt. Ich meine, er zeigt es so an, als ob das Bild kein Link hätte.

Habt ihr einen Vorschlag?

Mit freundlichen Grüßen
Benjamin

Dieser Beitrag wurde von Sepultura bearbeitet: 07. Mai 2012 - 12:50

Wer Japanische Produkte kauft, unterstützt den grausamen Walfang
Boykottiert JAPAN
0

Anzeige

#2 Mitglied ist offline   Lindheimer 

  • Gruppe: aktive Mitglieder
  • Beiträge: 264
  • Beigetreten: 28. Oktober 10
  • Reputation: 8

geschrieben 07. Mai 2012 - 13:42

ich kann den fehler bei mir nicht nachbilden, aber... was ist, wenn du das p-tag stehen lässt und das div zusätzlich mit angibst?

Zitat

Homer: „Warum passieren mir immer nur Dinge, die sonst nur dämlichen Menschen passieren?!“

Eingefügtes Bild
0

#3 Mitglied ist offline   Sepultura 

  • Gruppe: aktive Mitglieder
  • Beiträge: 621
  • Beigetreten: 18. September 05
  • Reputation: 6

geschrieben 07. Mai 2012 - 14:06

das klappt.

Ich bearbeite das Template Beez20 und das Resultat ist auch wie ich es wollte. danke. Eigentlich könnte auch das JText weg.
Wer Japanische Produkte kauft, unterstützt den grausamen Walfang
Boykottiert JAPAN
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0