WinFuture-Forum.de: [GELÖST] - JS-Problem - Nicht alle DIV-Container funktionieren per OnC - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Entwicklung
Seite 1 von 1

[GELÖST] - JS-Problem - Nicht alle DIV-Container funktionieren per OnC

#1 Mitglied ist offline   Stefan_der_held 

  • Gruppe: Offizieller Support
  • Beiträge: 11.450
  • Beigetreten: 08. April 06
  • Reputation: 322

geschrieben 14. Mai 2011 - 16:09

Folgendes ist der Code:

Bestehend aus: 6 "Minibildchen" und je 6 Großansichten....

<script type="text/javascript"> 
			function anzeigen(das){ 
			for(i=1;i<=6;i++) {			 
			document.getElementById(i).style.display='none';} 
			 
			   document.getElementById(das).style.display='block';} 
</script>


Bilder werden wie folgt dann eingesetzt:

<a href="#" onclick="anzeigen('1')"><img src="IMG/FOTOS/KLEIN/p_neu01k.gif" alt=""></a>
<a href="#" onclick="anzeigen('2')"><img src="IMG/FOTOS/KLEIN/p_neu02k.gif" alt=""></a>
<a href="#" onclick="anzeigen('3')"><img src="IMG/FOTOS/KLEIN/p_neu03k.gif" alt=""></a>
<a href="#" onclick="anzeigen('4')"><img src="IMG/FOTOS/KLEIN/p_neu04k.gif" alt=""></a>
<a href="#" onclick="anzeigen('4')"><img src="IMG/FOTOS/KLEIN/p_neu05k.gif" alt=""></a>
<a href="#" onclick="anzeigen('4')"><img src="IMG/FOTOS/KLEIN/p_neu06k.gif" alt=""></a>
<div id="1" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu01g.jpg" alt=""></div>
<div id="2" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu02g.jpg" alt=""></div>
<div id="3" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu03g.jpg" alt=""></div>
<div id="4" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu04g.jpg" alt=""></div>
<div id="5" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu05g.jpg" alt=""></div>
<div id="6" style="display:none; position: absolute; top: -402px; left: 424px;"><img src="IMG/FOTOS/NORMAL/p_neu06g.jpg" alt=""></div>


"absolute" und Positionsangaben da ein bestimmter Bereich überschrieben werden soll... soweit sogut... nur irgendwie funktionieren die Bilder "5" und "6" nicht... Pfadangaben passen aber - alles schon drölftausendmal geprüft ^_^

Bin nicht mehr so ganz auf dem Stand was JS angeht (das letzte mal ca cor 3Jahren gemacht :( ) kann mir mal jemand sagen warum die letzten bilder irgendwie nicht mittels "onClick" angezeigt werden?

Gruß,

Stefan

Dieser Beitrag wurde von Stefan_der_held bearbeitet: 14. Mai 2011 - 16:19

Eingefügtes Bild
0

Anzeige

#2 Mitglied ist offline   Stefan_der_held 

  • Gruppe: Offizieller Support
  • Beiträge: 11.450
  • Beigetreten: 08. April 06
  • Reputation: 322

geschrieben 14. Mai 2011 - 16:19

Argh!

Ja-Ne... man sollte die "ID" Werte natürlich auch weiter "durchnummerieren" und nicht bei "4" aufhören :(

Funzt dann alles
Eingefügtes Bild
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0