WinFuture-Forum.de: Samba Kann Kein Änderungsdatum Auf Ntfs Mount Schreiben - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Linux
Seite 1 von 1

Samba Kann Kein Änderungsdatum Auf Ntfs Mount Schreiben Ubunut 9.10 Server 64 bit


#1 Mitglied ist offline   tavoc 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.446
  • Beigetreten: 22. Juli 04
  • Reputation: 1

geschrieben 10. Dezember 2009 - 18:07

Hi,

ich nutze eine Linux Ubuntu 9.10 64 bit Maschine mit dem FPT Server Proftpd mit FTPES.
Alle Verbindungen sind also mit TLS/SSLv3 geschützt und zudem läuft der Server hinter einem NAT Router, sodass nur passives FTP erlaubt ist.

Ich kann mich ohne Probleme mit allen Clients mit dem FTP Server verbinden und auch Daten übertragen.

Der FTP Server soll die Daten jedoch nicht auf seiner eigenen Festplatte schreiben, sondern auf einen Netzwerkmount. Es werden also diverse Netzwerkfreigaben von einem Windows Server 2008R2 (der in einer Domäne ist) eingebunden.

//192.168.5.200/FTP_DIR/public  /home/tavoc/public	 cifs credentials=/root/.smbcredentials,auto,nounix,isocharset=utf8,file_m
ode=0777,dir_mode=0777 0	   0
//192.168.5.200/FTP_DIR/tavoc  /home/tavoc/tavoc	 cifs credentials=/root/.smbcredentials,auto,nounix,isocharset=utf8,file_m
ode=0777,dir_mode=0777 0	   0
#


Es gibt einen speziellen User in der AD, der genau dafür eingerichtet ist: linuxftp. Dieser hat die entsprechenden Zugriffsberechtigungen (Vollzugriff) auf die obigen NTFS Ordner.
Das mounten klappt auch wunderbar über die Fstab.


Jetzt kommt das aber:

Wenn ich eine Datei per FTP in ein Verzeichnis hochlade, welches innerhalb des FTP Servers bleibt, dann wird das Erstelldatum/Änderungsdatum der Datei korrekt beibehalten (so wie es auch sein soll). Auch wenn ich Datein lokal verschiebe ist das so.
Wenn ich jedoch eine Datei auf einen der NTFS freigaben verschieben/hochladen möchte, dann wird die Erstellzeit falsch gesetzt. Es ist immer die aktuelle Zeit. Die MAC Zeiten (m-time, c-time etc.) werden also nicht korrekt gesetzt.
Dabei ist es egal ob ich das über den FTP mache, oder im Linux direkt die Datei hinkopiere.
Somit kann ich also nicht das MFMT Feature vom Proftpd richtig nutzen, da alle wichtigen Dateien einen falschen Timestamp tragen..

Es liegt also definitiv an Samba, oder der Art und Weise wie ich die Verzeichnisse mounte. Die erweitertern Attribute/Timestamps werden nicht mit übertragen. Wenn ich von der Freigabe ins Linux kopiere funktioniert es jedoch.

Nach einigem suchen habe ich das hier gefunden:

dos filemode (S)

The default behavior in Samba is to provide UNIX-like behavior where only the owner of a file/directory is able to change the permissions on it. However, this behavior is often confusing to DOS/Windows users. Enabling this parameter allows a user who has write access to the file (by whatever means) to modify the permissions (including ACL) on it. Note that a user belonging to the group owning the file will not be allowed to change permissions if the group is only granted read access. Ownership of the file/directory may also be changed.

Default: dos filemode = no

dos filetimes (S)

Under DOS and Windows, if a user can write to a file they can change the timestamp on it. Under POSIX semantics, only the owner of the file or root may change the timestamp. By default, Samba runs with POSIX semantics and refuses to change the timestamp on a file if the user smbd is acting on behalf of is not the file owner. Setting this option to yes allows DOS semantics and smbd( will change the file timestamp as DOS requires. Due to changes in Microsoft Office 2000 and beyond, the default for this parameter has been changed from "no" to "yes" in Samba 3.0.14 and above. Microsoft Excel will display dialog box warnings about the file being changed by another user if this parameter is not set to "yes" and files are being shared between users.

Default: dos filetimes = yes


also hab ich die beiden Sachen auf yes gestellt. Es geht aber immer noch nicht. So langsam bin ich mit meinem Latein am Ende. Wär super wenn jemand noch eine Lösung wüsste.

Hier noch meine smb.conf

[global]

## Browsing/Identification ###dos filemode = Yes
dos filetimes = Yes
dos filetime resolution = Yes

   workgroup = WORKGROUP


   server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
   dns proxy = no
# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast






#### Debugging/Accounting ####

   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user


 usershare allow guests = yes
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

your IP is 127.0.0.1 or ::1
you are running an OS
you use a Browser
I know so much about you...
0

Anzeige



#2 Mitglied ist offline   Mstyle 

  • Gruppe: Mitglieder
  • Beiträge: 1
  • Beigetreten: 27. Oktober 10
  • Reputation: 0

geschrieben 27. Oktober 2010 - 12:25

Hallo zusammen

Ich habe das selbe Problem hat jemand da schon eine Lösung gefunden?

Es währe sehr dringend

Gruss Thomas
0

#3 Mitglied ist offline   tavoc 

  • Gruppe: aktive Mitglieder
  • Beiträge: 3.446
  • Beigetreten: 22. Juli 04
  • Reputation: 1

geschrieben 27. Oktober 2010 - 12:51

Hallo,

also ich hab es damals nicht geschafft.
Ich hab das ganze (backupkonzept) jetzt mit rsync auf dem Windows Server gelöst,allerdings ganz ohne FTP.
your IP is 127.0.0.1 or ::1
you are running an OS
you use a Browser
I know so much about you...
0

#4 Mitglied ist offline   egal8888 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.001
  • Beigetreten: 23. September 10
  • Reputation: 20

geschrieben 27. Oktober 2010 - 13:24

Vielleicht so:

http://www.linuxquestions.org/questions/li...ve-time-321936/
0

Thema verteilen:


Seite 1 von 1

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0