WinFuture-Forum.de: Numlock Bei Systemstart Entsperren - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Linux
  • 2 Seiten +
  • 1
  • 2

Numlock Bei Systemstart Entsperren


#1 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

  geschrieben 12. August 2008 - 14:53

Hi Leute.

Wie kriege ich es hin, dass der NumLock beim Systemstart automatisch entsperrt wird?

Das ganze sollte für X und auch für die VCs funktionieren.


Habt ihr ne Idee?


Danke
firegate
Eingefügtes Bild
0

Anzeige



#2 Mitglied ist offline   bb83 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.870
  • Beigetreten: 30. August 05
  • Reputation: 24

geschrieben 12. August 2008 - 17:56

Kannst du das Verhalten nicht bei dir im Bios setzen ?

Edit:

Ansonsten: numlockx

Dieser Beitrag wurde von bb83 bearbeitet: 12. August 2008 - 18:02

0

#3 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 13. August 2008 - 14:17

Ich hab jetzt eine Lösung gefunden, die für die VCs funktioniert:

for tty in /dev/tty[1-6]; do
	/usr/bin/setleds -D +num < $tty
done

Wenn ich da einfach noch numlockx anhänge und es beim Systemstart ausgeführt wird, sollte alles funzen.


Kann mir jemand sagen, wie ich es anstelle, dass das Script beim Systemstart ausgeführt wird?

Dieser Beitrag wurde von firegate bearbeitet: 13. August 2008 - 14:18

Eingefügtes Bild
0

#4 Mitglied ist offline   bb83 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.870
  • Beigetreten: 30. August 05
  • Reputation: 24

geschrieben 13. August 2008 - 15:42

Kommt auf die Distri an, bei mir geht es über die rc.local
0

#5 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 13. August 2008 - 15:46

ich nutze auch arch. muss ich die zeilen einfach in die /etc/rc.local einfügen oder reicht das nich?

danke schon mal


edit: im bios gibts bei mir keine passende einstellung.

da fällt mir auf, numlockx darf ja erst ausgeführt werden, wenn x gestartet ist.

Dieser Beitrag wurde von firegate bearbeitet: 13. August 2008 - 16:01

Eingefügtes Bild
0

#6 Mitglied ist offline   Atropin 

  • Gruppe: aktive Mitglieder
  • Beiträge: 37
  • Beigetreten: 18. Juni 07
  • Reputation: 0

geschrieben 13. August 2008 - 17:53

Soweit ich weiß initialisiert X die Tastatur neu. setleds betrifft nur die Textterminals (tty1-x). Für X gibt es via xset eine Option, aber die betrifft nur die LEDs(!), nicht den Modus. Also das Numlocklämpchen wäre an aber der Nummernblock aus. Für X gibt's einige simple Lösungen in C ...
http://ktown.kde.org/~seli/numlockx/

Oder einfach

#include <X11/extensions/XTest.h>
#include <X11/keysym.h>
					
int main(void)
{
	Display* disp = XOpenDisplay(NULL);
	if (disp == NULL) return 1;
	XTestFakeKeyEvent(disp, XKeysymToKeycode(disp, XK_Num_Lock), True, CurrentTime);
	XTestFakeKeyEvent(disp, XKeysymToKeycode(disp, XK_Num_Lock), False, CurrentTime);
	XCloseDisplay(disp);
	return 0;
}


Der will -lX11 und -lXtst. Aber kann ja sein, dass bei deiner Distribution "numlockx" in den Repositorien ist :8):

Btw: Wenn du KDE verwendest, das unterstützt das direkt. (Kuck mal im Kontrollzentrum unter Angeschlossene Geräte -> Tastatur ...)

Edit: Jetzt erst gesehen, dass jemand schonmal numlockx reineditiert hatte.

Numlockx erst bei X startup starten lassen -> in die xinitrc eintragen. Das ist ein Shellscript, also einfach unten als Zeile anfügen.

Dieser Beitrag wurde von Atropin bearbeitet: 13. August 2008 - 18:10

0

#7 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 14. August 2008 - 01:00

Zitat

Soweit ich weiß initialisiert X die Tastatur neu. setleds betrifft nur die Textterminals (tty1-x).

So war das auch gedacht. Ich wollte mit dem Script Numlock in den Terminals freischalten und mit numlockx im xserver.

Zitat

Für X gibt es via xset eine Option, aber die betrifft nur die LEDs(!), nicht den Modus. Also das Numlocklämpchen wäre an aber der Nummernblock aus.

Das ist bei mir leider standardmäßig so: Das Lämpchen leuchtet aber die Tasten sind trotzdem gelockt.

Zitat

Btw: Wenn du KDE verwendest, das unterstützt das direkt. (Kuck mal im Kontrollzentrum unter Angeschlossene Geräte -> Tastatur ...)

Ich benutze XFCE4, da hab ich so eine Option leider nicht gefunden...

Zitat

Numlockx erst bei X startup starten lassen -> in die xinitrc eintragen. Das ist ein Shellscript, also einfach unten als Zeile anfügen.

Ich hab das schon mal versucht, allerdings vor "exec xfce-session".
Lag es daran, dass es nicht gefunzt hat, oder guckt gdm nicht in die .xinitrc?

Bleiben die Fragen: Wie führe ich das Script für die Konsole beim Systemstart aus und wie bring ich gdm dazu, numlockx mit auszuführen (oder andere Lösung mit numlockx)?


Danke auf jeden Fall für eure Beiträge!
Eingefügtes Bild
0

#8 Mitglied ist offline   Atropin 

  • Gruppe: aktive Mitglieder
  • Beiträge: 37
  • Beigetreten: 18. Juni 07
  • Reputation: 0

geschrieben 14. August 2008 - 05:51

Zitat

Ich hab das schon mal versucht, allerdings vor "exec xfce-session".
Lag es daran, dass es nicht gefunzt hat, oder guckt gdm nicht in die .xinitrc?


Ich nutz eigentlich immer startx, mit gdm kenn ich mich nicht aus. Auf jeden Fall solltest du den Eintrag immer UNTEN an das script anfügen, sprich in die letzte Zeile.
Schau mal nach verdächtig aussehenden gdm configfiles. Soweit ich weiß liest gdm die ~/.xsession von dem User, der sich in dem Moment anmeldete.

Das mit dem "beim Systemstart" ist etwas schwieriger. sysvinit macht keinen Spaß ...
-> /etc/rc.d, /etc/init.d. Debian bootet zB anders als Slackware. (Glaub Slackware supported sogar BSD-init...)
Ich gehe mal davon aus, dass du den sysvinit-style suchst. Der is recht "knotig", gibt's aber Dokumente zu wie Sand am Meer ->
http://www.debian.org/doc/debian-policy/ch...rsys#s-sysvinit

Hab nur ein oder zweimal in Sysv-Init scripten rumgefummelt, /etc/init.d/<scriptname> ist das generische Bootscript was du wahrscheinlich schreiben willst, und das linkst du dann in den Ordner des jeweiligen runlevels rein (zB /etc/rc3.d/S40.<deinscriptname>(S für Start und 40 ist die Ordnungszahl...)).
0

#9 Mitglied ist offline   dale 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.210
  • Beigetreten: 15. Februar 08
  • Reputation: 64

geschrieben 14. August 2008 - 08:38

bitte löschen hab mich verklickt

Dieser Beitrag wurde von dale bearbeitet: 14. August 2008 - 08:39

0

#10 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 14. August 2008 - 15:32

Das Problem mit den Consolen ist jetzt gelöst: Ich hab den Code in die /etc/rc.local geschrieben (danke bb83).

Mit startx funktionierts auch wunderbar (auch wenn numlockx vor xfce4-session steht).

Eine ~/.xsession existiert bei mir nicht. Es existiert allerdings eine Xsession in /etc/gdm. Ich häng mal numlockx hier an und starte x neu. Meld mich dann wieder.


Hat leider keinen Erfolg gebracht.
Was jetzt? Ich würde schon gerne GDM benutzen.

Dieser Beitrag wurde von firegate bearbeitet: 14. August 2008 - 15:43

Eingefügtes Bild
0

#11 Mitglied ist offline   Fabi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.958
  • Beigetreten: 30. August 04
  • Reputation: 1

geschrieben 14. August 2008 - 15:55

Zitat

Eine ~/.xsession existiert bei mir nicht. Es existiert allerdings eine Xsession in /etc/gdm. Ich häng mal numlockx hier an und starte x neu. Meld mich dann wieder.

schonmal dran gedacht diese einfach selbst zu erstellen......:smokin:

lg,
Fabi
0

#12 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 14. August 2008 - 17:20

hab ich, hatte nur grad keine zeit mehr. muss ich dabei irgendwas beachten und gibts die möglichkeit, es global zu regeln, nicht userseitig?

ich probier jetzt mal mit folgender ~/.xsession:
#!/bin/bash
numlockx on

:smokin:

edit: kein erfolg :wink:

Dieser Beitrag wurde von firegate bearbeitet: 14. August 2008 - 17:28

Eingefügtes Bild
0

#13 Mitglied ist offline   Atropin 

  • Gruppe: aktive Mitglieder
  • Beiträge: 37
  • Beigetreten: 18. Juni 07
  • Reputation: 0

geschrieben 14. August 2008 - 20:53

http://gentoo-wiki.com/HOWTO_Gdm_setup#Sel..._Window_Manager

Da sind wohl brauchbare Infos zu den Scriptnamen ...

Zitat

After a successful login, the /etc/X11/gdm/Xsession script will execute the file $HOME/.Xclients.

0

#14 Mitglied ist offline   firegate 

  • Gruppe: aktive Mitglieder
  • Beiträge: 752
  • Beigetreten: 12. April 05
  • Reputation: 0

geschrieben 15. August 2008 - 00:27

Klappt leider auch nicht. Hab das Script erstellt und ausführbar gemacht. Passiert immer noch nichts.
Eingefügtes Bild
0

#15 Mitglied ist offline   Fabi 

  • Gruppe: aktive Mitglieder
  • Beiträge: 1.958
  • Beigetreten: 30. August 04
  • Reputation: 1

geschrieben 15. August 2008 - 08:27

#!/bin/bash
numlockx on


mach da mal das
#!/bin/bash
weg, das is nämlich kein script sondern ne config datei!
könntest auchmal versuchen das ganze in die .bashrc zu schreiben, wäre dann halt auch wieder userseitig!

lg,
Fabi

Dieser Beitrag wurde von Fabi bearbeitet: 15. August 2008 - 08:28

0

Thema verteilen:


  • 2 Seiten +
  • 1
  • 2

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0