WinFuture-Forum.de: Tutorial: Hd4850 Untertakten - WinFuture-Forum.de

Zum Inhalt wechseln

Nachrichten zum Thema: Grafikkarten
  • 4 Seiten +
  • 1
  • 2
  • 3
  • 4

Tutorial: Hd4850 Untertakten Leiser, kühler, weniger stromfressend...


#1 _Hamlet81_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 17:56

Tutorial: Wie man die HD4850 untertaktet

Willkommen! Für alle Besitzer einer HD4850 schreibe ich dieses kleine Tutorial.

Prolog:
Ich bin Ende Juli von einer langen Reihe Nvidia-Karten auf ATi umgestiegen (MSI HD4850) und war ganz angetan von der Leistung. Nicht ganz so angetan war ich von den hohen Temperaturen und dem Umstand, dass PowerPlay 2.0 nicht richtig funktioniert; hat mich doch irgendwie gewurmt. Überall war zu lesen, der nächste Catalyst würde da nachbessern, aber bis jetzt ist da nicht wirklich etwas passiert... wahrscheinlich wird das auch so bleiben...
Dieses Problem trifft auf alle HD4850s mit ATis Standarddesign zu. Sie werden mit einem katastrophalen BIOS ausgeliefert, das weder anständig runtertaktet in 2D, noch den Lüfter angemessen schnell rotieren lässt. Wenn ATi das nicht interessiert, helfen wir uns also selbst. Ran an's Tutorial!

Ausgangslage:
Im 3D taktet die HD4850 mit 625/993 - das ist Standard, da gibt's nichts zu meckern.
Temperatur: ~ 80°C
Hinweis: In diesem Tutorial wird die 3D-Leistung nicht angetastet - wenn Ihr übertakten wollt, könnt Ihr das selbst machen, ich gebe Euch hier das Werkzeug und das Wissen an die Hand.

Im 2D taktet die Graka nur auf 500/750 runter. Das ist viel zu wenig.
Temperatur: ~ 75°C

Ziel:
Im 2D-Modus automatisch ohne irgendwelche Hotkeytippereien oder nervende im Hintergrund laufende Tuningtools auf 160/500 runtertakten und die Temperatur auf 60°C senken; das wär doch mal nett!

Vorgehensweise:
  • Ladet Euch das aktuellste Catalyst Treiberpaket herunter.
  • (Optional) Lasst vor der Installation des Catalyst evtl. Driver Cleaner drüberlaufen. Insbesondere, wenn Ihr von Nvidia zu ATi wechseln solltet, empfiehlt es sich, vorher tabula rasa zu machen.
  • Checkt mit dem Catalyst ControlCenter (--> Overclocking), ob Ihr nicht vielleicht schon das neue BIOS draufhabt. Wenn die Grafikkarte im 2D-Betrieb lediglich auf 500/750 runtertaktet, wisst Ihr bescheid: Ihr habt noch das alte!
  • BIOS-Backup!! <-- speichert die Datei an einem sicheren Ort, am besten auf einem USB-Stick o.ä., damit Ihr problemlos wieder dran kommt.
    Eingefügtes BildEingefügtes Bild
    Dazu besorgt Ihr Euch gpu-z und sichert Euer altes Graka-BIOS. Sicher ist sicher!
    Gpu-z ist außerdem exzellent, um die Lüfterdrehzahlen und Temperaturen in Echtzeit einzusehen.
  • Auf Grundlage des neuesten, offiziellen MSI-BIOS (vom 05.06.2008) wurde von mir ein modifiziertes BIOS zusammengestellt. Dieses findet Ihr im Anhang dieses Tutorials.
  • Winflash runterladen und starten.
  • Neues BIOS aus Schritt 5) draufflashen
    Eingefügtes Bild
    Ihr seht dabei einen Fortschrittsbalken (Anmerkung: Unter Vista64 wird keiner angezeigt!).
    Wichtig: Dieser Vorgang kann eine Weile dauern! Während der Prozedur solltet Ihr auf jeden Fall geduldig sein und WARTEN, falls mal ein paar Minuten nichts passieren sollte - es sei denn Ihr legt Wert auf einen 120€ teuren Briefbeschwerer...
    Ich weise hiermit darauf hin, dass Ihr auf eigene Gefahr flasht.
    Wer das nicht möchte, lese einfach weiter in diesem Thread, denn Merlin & Co. beschrieben hier wie man das Problem auch mit Hilfe von Profilen lösen kann. Dies ist aber keine dynamische Lösung und gehört deswegen nicht zu meinem Tutorial, deswegen weiter im Text:
  • Success? Flash fertig? Gut, (erst) wenn Euch ein Dialog auffordert neuzustarten, solltet Ihr das tun.
  • Genießen

---

Im Folgenden noch einige Anmerkungen zum Radeon BIOS Editor (RBE), falls Ihr auf den Geschmack gekommen sein solltet und selber editieren/experimentieren wollt. Damit Ihr das Rad nicht neu erfinden müsst, hier meine Erkenntnisse:

Erste interessante Entdeckung: Wenn gpu-z 0% fan speed anzeigt, ist das nicht gleichbedeutend mit 0 Umdrehungen des Lüfters! 0% fan speed heißt in Wahrheit ~1400 Umdrehungen und scheint der "Grundtakt" des Lüfters zu sein - langsamer mag er nicht (wäre auch überhaupt nicht zu empfehlen).

Übersetzungstabelle des Lüfters
10% fan speed = 1400U
20% fan speed = 1400U+ (d.h. über 20% fängt er überhaupt erst an, so langsam hochzudrehen!)
30% fan speed = ~1900U

Werkseinstellungen des Lüfters (oder: Was zum Teufel hat sich der ATi-BIOS-Ingenieur dabei bloß gedacht?!)
Eingefügtes BildEingefügtes Bild

Temperatur --> Fan speed
  • 69°C --> 00% (über 69°C wird mächtig aufgedreht)
  • 76°C --> 20%
  • 80°C --> 30%
  • 84°C --> 40%
  • 87°C --> 50%

Das hier müsst Ihr Euch mal zu Gemüte führen: Mit Werkseinstellungen dödelt die Graka bis 69°C (sic!) mit 1400 Umdrehungen rum (jetzt wissen wir auch, warum alle Tester schreiben, dass sie so unhörbar leise ist). Da eine Steigerung bis 20% immer noch keine Erhöhung der Lüfterdrehzahl mit sich bringt, wacht der Lüfter faktisch erst mit 76°C auf und fängt an stärker zu drehen!
Das dann allerdings recht schnell (s. Graph oben: die Drehzahl geht steil ab).
Bei 80°C sind 35% fan speed erreicht.
40% scheinen mehr als auszureichen, um die Graka kühl zu halten; ich habe nämlich noch nicht erlebt, dass sie während des Spielens wesentlich heißer als 80°C wurde...

Neue Lüftereinstellungen (Bild 1) ||| Außerdem habe ich die Voltage auf 0.93V abgesenkt (Bild 2)
Eingefügtes BildEingefügtes BildEingefügtes BildEingefügtes Bild
  • bis 60°C --> 30%
  • 74°C --> 40%
  • 88°C --> 50%

Wie man sieht, fängt der Lüfter mit meiner Einstellung bereits ab 60°C an schneller zu drehen.
Außerdem schreibe ich dem Lüfter einen Grundtakt von 30% (statt 20%) vor.

Nun habe ich im 2D-Mous:
fan speed: ~30% (= 60°C), 1800U
...und im 3D-Modus:
fan speed: 40% (= 71°C)

Drastisch, aber wahr: Meine Karte läuft jetzt mit dem modifizierten BIOS unter Volllast kühler als früher im Idle! Wenn ich dies mit den Werten ohne Untertaktung vergleiche, liege ich sowohl im Idle als auch im 3D gut 15°C niedriger! Wer bereit sein sollte, den Lüfter noch etwas stärker rotieren zu lassen (wie z.B. Montegiga auf Seite 2), sollte es sogar noch kühler haben... von dauerhaft 50%+ rate ich allerdings ab - es sei denn Ihr stellt Euch bei Festivals gerne direkt vor die Boxentürme...


Anhang:
Wer sich nicht selber die Mühe machen will, lädt sich einfach mein fertig-modifiziertes BIOS für die HD4850 runter. Es beinhaltet sowohl die Untertaktung (160/500), als auch Voltabsenkung (0.93V) sowie neue Lüftersettings (Grundtakt 30%). Einfach mittels winflash einlesen und fertig ist die Laube! :)

>>> Angehängte Datei  HD4850_BIOS_v13.rar (38,21K)
Anzahl der Downloads: 1159


Changelog:
BIOS v. 1.0 (24. Juli 2008)
- erste Version
BIOS v. 1.1 (24. August 2008)
- neueste Version des Radeon BIOS Editors verwendet
Tutorial aktualisiert (5. September 2008)
- Text überarbeitet
BIOS v. 1.2 (29. September 2008)
- Version 1.15 des Radeon BIOS Editors verwendet
- 2D-Voltage erfolgreich auf 0.93V abgesenkt
- Bilder auf imageshack umgestellt, Text überarbeitet
BIOS v. 1.3 (18. Oktober 2008)
- Version 1.17 des Radeon BIOS Editors verwendet
- Hyperlinks im Text so abgeändert, dass sie immer (i.e. auch nach Aktualisierung) gültig sind

Tests bestätigen, dass das BIOS auch für HD4850s anderer Hersteller (wie z.B. Sapphire und GeCube) funktioniert. An dieser Stelle ein großes Danke @ DonBonzo, Merlin und Martin für ihre Erfahrungsberichte!


PS: Rückmeldungen sind erwünscht und willkommen (am liebsten mit Vorher-Nachher-Werten).
Falls es neuere Versionen der vorgestellten Programme geben sollte, werde ich sie auf der dritten Seite des Threads mit Changelog posten und den Tutorialtext und die Links entsprechend anpassen.



Epilog - Kaufberatung:
(Danke @ Tim, für die Frage)
Die momentan beste HD4850 auf dem Markt liefert Powercolor mit der Powercolor HD4850 PCS (512mb), gefolgt von der MSI-Variante. Leider war die im Juli noch nicht draußen, sonst hätt ich mir die Powercolor bestellt - aber dann hätten wir jetzt auch kein Tutorial ;)

Dieser Beitrag wurde von Hamlet81 bearbeitet: 19. Oktober 2008 - 12:28

0

Anzeige

#2 _DonBonzo_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:02

Das BIOS funktioniert für Karten aller Hersteller?
0

#3 _Hamlet81_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:10

Mit den folgenden Karten sollte es theoretisch funktionieren:

Zitat

Same BIOS:
- ATI HD 4850
- Club3D HD 4850
- Connect3D HD 4850-
- Diamond HD 4850
- Force3D HD 4850
- Gainward HD 4850
- GeCube HD 4850
- Gigabyte HD 4850
- HIS HD 4850
- Jetway HD 4850
- Palit HD 4850
- Powercolor HD 4850
- Rextech HD 4850
- Sapphire HD 4850
- Visiontek HD 4850


Mit den folgenden Karten funktioniert es erwiesenermaßen:
- Gecube (danke @ Martin)
- Sapphire (danke @ DonBonzo, merlin1999)
- MSI (danke @ mich :))

Edit: Von welchem Hersteller ist denn Deine HD4850?

Dieser Beitrag wurde von Hamlet81 bearbeitet: 05. Oktober 2008 - 01:22

0

#4 _DonBonzo_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:11

Ja guckte ich bereits, ist leider nur das dabei, welches ich schon drauf hab, und damit taktet er nicht runter...

EDIT: Mein Fehler, gibt n neues was passt. Mal schaun obs funktioniert. Danke schonmal für den Hinweis.

Dieser Beitrag wurde von DonBonzo bearbeitet: 22. Juli 2008 - 18:19

0

#5 Mitglied ist offline   merlin1999 

  • Gruppe: aktive Mitglieder
  • Beiträge: 154
  • Beigetreten: 18. August 04
  • Reputation: 0

geschrieben 22. Juli 2008 - 18:36

Würde mich auch interessieren aber das genannte MSI Bios passt wohl ned für Sapphire oder ?
for happy people

DONT CLICK IF YOU DONT UNDERSTAND FUN !!!




0

#6 _DonBonzo_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:41

Also ich habs mit dem neuesten Sapphire probiert, da tut sich gar nichts, ich probiers jetzt nochmal mit dem von MSI, und schreib, sollte dann nicht alles abgeraucht sein, gleich obs geht ^^
0

#7 Mitglied ist offline   merlin1999 

  • Gruppe: aktive Mitglieder
  • Beiträge: 154
  • Beigetreten: 18. August 04
  • Reputation: 0

geschrieben 22. Juli 2008 - 18:47

Beitrag anzeigenZitat (DonBonzo: 22.07.2008, 19:41)

Also ich habs mit dem neuesten Sapphire probiert, da tut sich gar nichts, ich probiers jetzt nochmal mit dem von MSI, und schreib, sollte dann nicht alles abgeraucht sein, gleich obs geht ^^


Haste denn auch eine Sapphire ?
for happy people

DONT CLICK IF YOU DONT UNDERSTAND FUN !!!




0

#8 _DonBonzo_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:49

Beitrag anzeigenZitat (merlin1999: 22.07.2008, 19:47)

Haste denn auch eine Sapphire ?


Ja und es geht problemlos mit dem MSI Bios ;)

Man darf allerdings nicht ATIs Overdrive aktivieren, dann taktet er nur auf 500/750 zurück.
EDIT: muss mich korrigieren, geht doch, warum gestern nicht weiß ich nicht :)

Dieser Beitrag wurde von DonBonzo bearbeitet: 23. Juli 2008 - 15:40

0

#9 Mitglied ist offline   merlin1999 

  • Gruppe: aktive Mitglieder
  • Beiträge: 154
  • Beigetreten: 18. August 04
  • Reputation: 0

geschrieben 22. Juli 2008 - 18:50

Cool danke für die Info und den Mut.


Danke habe es auch gewagt und auch hier kann ich einen Erfolg melden mit der Sapphire HD4850

160/500 (allerdings bei 68°C statt 79°C)


Beitrag anzeigenZitat (Hamlet81: 22.07.2008, 18:56)

Ausgangslage:
Im 3D taktet die HD4850 mit 750/993 - das ist soweit in Ordnung, da gibt's nichts zu meckern.
Temperatur: ~ 80°C


Wie meinst du das? Bei der HD4850 ist doch 625/993 Ausgangslage oder habe ich da was nicht richtig gesehen ?

Dieser Beitrag wurde von merlin1999 bearbeitet: 22. Juli 2008 - 19:08

for happy people

DONT CLICK IF YOU DONT UNDERSTAND FUN !!!




0

#10 _Hamlet81_

  • Gruppe: Gäste

geschrieben 22. Juli 2008 - 18:52

Fein! Freut mich für Euch! ;)
Erfahrungsberichte und Temperaturen (--> Vorher: 3D/2D vs. Nachher: 3D/2D) bitte immer hier rein!

Also das kann ich hier nicht bestätigen. Meiner Karte scheint es egal zu sein, ob Overdrive an/aus ist.
Unter XP-Desktop sind's jetzt immer 160/500, selbst wenn ich im Hintergrund grade ein Spiel laufen habe und nur mal kurz mittels Alt-Tab auf den Desktop rüberwechsele, wird runtergetaktet!

@merlin:
Wups! Fehler von mir... Du hast vollkommen Recht: Standard-3D-Taktung ist: 625/993. Habs korrigiert.
Bin trotzdem stolz auf die Leistung. :)

Dieser Beitrag wurde von Hamlet81 bearbeitet: 09. September 2008 - 17:55

0

#11 _DonBonzo_

  • Gruppe: Gäste

geschrieben 23. Juli 2008 - 15:45

Ich hab allerdings ein Problem: Die Karte taktet ab und zu auch während des Spielens runter, und das macht keinen sehr guten Eindruck, weil der Schirm dann kurz dunkel wird und man nichts tun kann. Liegt das vllt am an sich nicht passenden BIOS.

@merlin1999: Hast du sowas auch?
0

#12 Mitglied ist offline   merlin1999 

  • Gruppe: aktive Mitglieder
  • Beiträge: 154
  • Beigetreten: 18. August 04
  • Reputation: 0

geschrieben 23. Juli 2008 - 16:03

Beitrag anzeigenZitat (DonBonzo: 23.07.2008, 16:45)

@merlin1999: Hast du sowas auch?


Nein habe nun alle meine "High End" Games like Crysis angespielt und kann das nicht bestätigen was bei dir ist. Also ich habe keine Probleme mit dem Bios. Läuft alles wie vorher auch.
for happy people

DONT CLICK IF YOU DONT UNDERSTAND FUN !!!




0

#13 _DonBonzo_

  • Gruppe: Gäste

geschrieben 23. Juli 2008 - 16:15

Gut liegt möglicherweise auch am Catalyst. An Übertaktung liegt es nicht, der Fehler tritt mit und ohne auf. Naja er bringt mich nicht um.

Edit: Ich las grad auf Computerbase, das zumindest Stromspartechnisch das runtertakten so gut wie nichts gebracht hat, schade eigentlich.

Dieser Beitrag wurde von DonBonzo bearbeitet: 23. Juli 2008 - 16:38

0

#14 _Hamlet81_

  • Gruppe: Gäste

geschrieben 23. Juli 2008 - 17:56

Wenn Du meine Anleitung befolgt hast, hast Du ja ein Backup Deines BIOS'.
Wenn es mit dem alten auch passiert, weisst Du, dass es nicht am Untertakten liegt.

Ja, den CB-Artikel hab ich auch gelesen. Nichtsdestotrotz: Die Temperatur ist definitiv niedriger und sinkt viel schneller nach dem Spielen - das bilde ich mir definitiv nicht nur ein...
Außerdem sollten unsere Karten länger leben, weil sie kühler sind als andere ohne Untertaktung (das haben sie bei CB nämlich nicht gemessen!)

Ein Strommessgerät besitze ich leider nicht.


Vllt. sollte ich das Tutorial erweitern, indem ich erläutere wie man den Lüfter ein wenig früher starten lässt.
Zieht Euch das rein: momentan ist der so eingestellt, dass er erst bei einer Temperatur von 69°C anspringt (= 1%) und bei 105°C volle Power dreht (= 100%).

Insgesamt kann ich meine Karte überhaupt nicht hören. Es wäre vielleicht clever, das Teil so zu konfigurieren, dass es permanent mit 10% mehr dreht, was unbemerkbar lauter, aber dafür auch merklich kühler kommen sollte... Tool dazu wäre der RBE...

Dieser Beitrag wurde von Hamlet81 bearbeitet: 09. September 2008 - 17:57

0

#15 _DonBonzo_

  • Gruppe: Gäste

geschrieben 23. Juli 2008 - 18:16

Das ganze tritt seit kurzem nicht mehr auf. Logisch aber nicht erklärbar. Da erst ohne Übertaktung das Problem bestand, dann mit, und jetzt wieder ohne Übertaktung weg ist.

Und ja das mit dem Lüfter wäre ne schöne Sache wenn du dir dazu noch die Zeit nimmst.
0

Thema verteilen:


  • 4 Seiten +
  • 1
  • 2
  • 3
  • 4

1 Besucher lesen dieses Thema
Mitglieder: 0, Gäste: 1, unsichtbare Mitglieder: 0